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Introduction
Welcome to the Official Red Hat Linux Getting Started Guide!
By now, you should have read the Official Red Hat Linux Installation Guide and successfully installed
Red Hat Linux. This manual is designed to help new and intermediate Linux users navigate and
perform common tasks. Keep in mind that Linux looks, feels, and performs differently from other
operating systems you may have used. Forget about the conventions of other operating systems and,
with an open mind, approach Red Hat Linux as a new, interesting, and versatile alternative.
This manual is task-oriented. You will find useful tips, hints, warnings, and screen shots interspersed
throughout. First, you will learn the basics of using Red Hat Linux, such as customizing a desktop,
configuring a printer, and getting online. Once the basics are covered, the tasks covered in this manual
become progressively more advanced.
Most users choose to work within either the GNOME or KDE graphical desktop environments (other
desktop environments are also available). The Official Red Hat Linux Getting Started Guide focuses
primarily on how to perform tasks in these two environments.
Topics discussed include:
•

Using the graphical desktop environment

•

Managing files and directories

•

Working with documents

•

Using the Web and email

•

Upgrading applications

•

Pointers to additional resources covering common questions and answers, computer basics, an explanation of Red Hat Linux system directories, and more.

After conquering the basics of your Red Hat Linux system, you may need information on more advanced topics. You can find this information in the Official Red Hat Linux Customization Guide and
the Official Red Hat Linux Reference Guide.
HTML and PDF versions of the Official Red Hat Linux manuals are available on the Documentation
CD and online at http://www.redhat.com/docs/.

Note
Although this manual reflects the most current information possible, you should read the Red Hat
Linux Release Notes for information that may not have been available prior to our documentation
being finalized. They can be found on the Red Hat Linux CD #1 and online at:
http://www.redhat.com/docs/

1. Changes to This Manual
This manual has been expanded to include new features in Red Hat Linux 8.0 as well as topics requested by our readers. Changes to this manual include:
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Working with Documents
The Official Red Hat Linux Getting Started Guide has been reorganized to include a chapter on
using the OpenOffice.org productivity suite, which includes pointers on using its word processing, spreadsheet, illustration, and presentation applications.
Audio, Video, and General Amusement
This chapter now includes information on troubleshooting sound cards using Sound Card Configuration Tool and video cards/monitors using X Configuration Tool.
Using the Graphical Desktop
This chapter has been modified to reflect the new desktop environment and the various ways you
can use and configure it.
Managing Files and Directories
This chapter adds instructions on using File Roller, a graphical tool for compressing, decompressing, and archiving files.

2. Document Conventions
When you read this manual, you will see that certain words are represented in different fonts, typefaces, sizes, and weights. This highlighting is systematic; different words are represented in the same
style to indicate their inclusion in a specific category. The types of words that are represented this way
include the following:
command

Linux commands (and other operating system commands, when used) are represented this way.
This style should indicate to you that you can type the word or phrase on the command line
and press [Enter] to invoke a command. Sometimes a command contains words that would be
displayed in a different style on their own (such as filenames). In these cases, they are considered
to be part of the command, so the entire phrase will be displayed as a command. For example:
Use the cat testfile command to view the contents of a file, named testfile, in the current
working directory.
filename

Filenames, directory names, paths, and RPM package names are represented this way. This style
should indicate that a particular file or directory exists by that name on your Red Hat Linux
system. Examples:
The .bashrc file in your home directory contains bash shell definitions and aliases for your own
use.
The /etc/fstab file contains information about different system devices and filesystems.
Install the webalizer RPM if you want to use a Web server log file analysis program.
application
This style should indicate to you that the program named is an end-user application (as opposed
to system software). For example:
Use Mozilla to browse the Web.
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[key]
A key on the keyboard is shown in this style. For example:
To use [Tab] completion, type in a character and then press the [Tab] key. Your terminal will
display the list of files in the directory that start with that letter.
[key]-[combination]
A combination of keystrokes is represented in this way. For example:
The [Ctrl]-[Alt]-[Backspace] key combination will exit your graphical session and return you to
the graphical login screen or the console.
text found on a GUI interface
A title, word, or phrase found on a GUI interface screen or window will be shown in this style.
When you see text shown in this style, it is being used to identify a particular GUI screen or an
element on a GUI screen (such as text associated with a checkbox or field). Example:
Select the Require Password checkbox if you would like your screensaver to require a password
before stopping.
top level of a menu on a GUI screen or window
When you see a word in this style, it indicates that the word is the top level of a pulldown menu.
If you click on the word on the GUI screen, the rest of the menu should appear. For example:
Under File on a GNOME terminal, you will see the New Tab option that allows you to open
multiple shell prompts in the same window.
If you need to type in a sequence of commands from a GUI menu, they will be shown like the
following example:
Go to Main Menu Button (on the Panel) => Programming => Emacs to start the Emacs text
editor.
button on a GUI screen or window
This style indicates that the text will be found on a clickable button on a GUI screen. For example:
Click on the Back button to return to the webpage you last viewed.
computer output

When you see text in this style, it indicates text displayed by the computer on the command line.
You will see responses to commands you typed in, error messages, and interactive prompts for
your input during scripts or programs shown this way. For example:
Use the ls command to display the contents of a directory:
$ ls
Desktop
Mail

about.html
backupfiles

logs
mail

paulwesterberg.png
reports

The output returned in response to the command (in this case, the contents of the directory) is
shown in this style.
prompt

A prompt, which is a computer’s way of signifying that it is ready for you to input something,
will be shown in this style. Examples:
$
#
[stephen@maturin stephen]$

x
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user input
Text that the user has to type, either on the command line, or into a text box on a GUI screen, is
displayed in this style. In the following example, text is displayed in this style:
To boot your system into the text based installation program, you will need to type in the text
command at the boot: prompt.
Additionally, we use several different strategies to draw your attention to certain pieces of information.
In order of how critical the information is to your system, these items will be marked as note, tip,
important, caution, or a warning. For example:

Note
Remember that Linux is case sensitive. In other words, a rose is not a ROSE is not a rOsE.

Tip
The directory /usr/share/doc contains additional documentation for packages installed on your
system.

Important
If you modify the DHCP configuration file, the changes will not take effect until you restart the DHCP
daemon.

Caution
Do not perform routine tasks as root — use a regular user account unless you need to use the root
account for system administration tasks.

Warning
If you choose not to partition manually, a server installation will remove all existing partitions on all
installed hard drives. Do not choose this installation class unless you are sure you have no data you
need to save.
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3. Copying and Pasting Text With X
Copying and pasting text is easy using your mouse and the X Window System. To copy text, simply
click and drag your mouse over the text to highlight it. To paste the text somewhere, click the middle
mouse button in the spot where the text should be placed.

4. Using the Mouse
Red Hat Linux is designed to use a three-button mouse. If you have a two-button mouse, you should
have selected three-button emulation during the installation process. If you’re using three-button emulation, pressing both mouse buttons at the same time equates to pressing the missing third (middle)
button.
In this document, if you are instructed to click with the mouse on something, that means click the left
mouse button. If you need to use the middle or right mouse button, that will be explicitly stated. (This
will be reversed if you’ve configured your mouse to be used by a left handed person.)
The phrase "drag and drop" may be familiar to you. If you’re instructed to drag and drop an item on
your GUI desktop, click on something and hold the mouse button down. While continuing to hold
down the mouse button, drag the item by moving the mouse to a new location. When you’ve reached
the desired location, release the mouse button to drop the item.

5. We Need Feedback!
If you spot a typographical error in the Official Red Hat Linux Getting Started Guide, or if you have
thought of a way to make this manual better, we would love to hear from you! Please submit a report
in Bugzilla (http://www.redhat.com/bugzilla) against the component Official Red Hat Linux Getting
Started Guide.
When submitting a bug report, be sure to mention the manual’s identifier:
rhl-gsg(EN)-8.0-Print-RHI (2002-08-20T12:16-0400)

If you have a suggestion for improving the documentation, try to be as specific as possible when describing it. If you have found an error, please include the section number and some of the surrounding
text so we can find it easily.

6. Sign Up for Support
If you have an official edition of Red Hat Linux 8.0, please remember to sign up for the benefits you
are entitled to as a Red Hat customer.
You will be entitled to any or all of the following benefits, depending upon the Official Red Hat Linux
product you purchased:
•

Official Red Hat support — Get help with your installation questions from Red Hat, Inc.’s support
team.

•

Red Hat Network — Easily update your packages and receive security notices that are customized
for your system. Go to http://rhn.redhat.com for more details.

•

Under the Brim: The Official Red Hat E-Newsletter — Every month, get the latest news and product
information directly from Red Hat.

xii
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To sign up, go to http://www.redhat.com/apps/activate/. You will find your Product ID on a black, red,
and white card in your Official Red Hat Linux box.
To read more about technical support for Official Red Hat Linux, refer to the Getting Technical Support Appendix in the Official Red Hat Linux Installation Guide.
Good luck, and thank you for choosing Red Hat Linux!
The Red Hat Documentation Team

Chapter 1.
Getting Started
From booting up to shutting down, whether you are working or playing, Red Hat Linux provides tools
and applications to help you get the most out of your computing environment. This chapter guides
you through some basic tasks that you will commonly perform day-to-day on your Red Hat Linux
machine.

1.1. Setup Agent
The first time you start your Red Hat Linux machine, you will be presented with the Setup Agent,
which guides you through the Red Hat Linux configuration. Using this tool, you can set your system
time and date, install software, register your machine with the Red Hat Network, and more. Setup
Agent lets you configure your environment at the beginning, so that you can get started using your
Red Hat Linux system quickly.
Setup Agent allows you to set your machine’s date and time, or lets you synchronize your date and
time with an network time server — a machine that sends date and time information to your machine
through a network connection. Set the day, month, and year using the calendar tool and set your time
in hours, minutes, and seconds using provided text boxes. Once you have set your time and date, click
Forward to continue.

Figure 1-1. Date and Time Configuration
If you wish to register your system with the Red Hat Network and receive automatic updates of your
Red Hat Linux system, choose Yes, I would like to register with Red Hat Network. This will start
the Red Hat Update Agent — a utility that guides you step-by-step through the registration of your
machine with the Red Hat Network. Selecting No, I do not want to register my machine skips the
registration. For more information about Red Hat Network and registering your machine, refer to the
Red Hat Network documentation at http://www.redhat.com/docs/manuals/RHNetwork/.
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Figure 1-2. Red Hat Network Registration Client
If you want to install Red Hat Linux RPM packages that you did not install during installation, software from third-party providers, or documentation from the Official Red Hat Linux Documentation
CD, you can do so at the Install Additional Software screen. Insert the CD containing the software
or documentation you want to install, click the Install... button, and follow the instructions.

Note
If you are installing a package from the Red Hat Linux installation CDs, you must insert CD 1, click the
Install... button, choose the package(s) or component you want to install, and, if prompted , change
the CD.

Figure 1-3. Installing Additional Software
Now your system is configured. You are ready to log in and start using Red Hat Linux.

1.2. Introductory Terms
When you learn about a new operating system, you also need to learn new terminology. Here are a few
basic terms you should learn. You will see these terms often throughout all Official Red Hat Linux
documentation including the Official Red Hat Linux Getting Started Guide:

Chapter 1. Getting Started
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Shell prompt: A command line interface (similar to a DOS screen) between the user and the operating system (Figure 1-4). The shell interprets commands entered by the user and passes them on
to the operating system.

Figure 1-4. A Shell Prompt

•

Command line: The place in the shell prompt where commands are typed.

•

Command: An instruction given to the computer, most often with the keyboard or mouse.

•

Graphical User Interface (GUI): A screen with icons, menus, and panels for the user to click on to
initiate actions such as starting applications and opening files.

•

Icons are small images representing an application, folder, shortcut or system resource (such as a
floppy drive). Launcher icons usually refer to application shortcuts.

•

Graphical Desktop Environment: The most visible area of a GUI. The desktop is where your user
Home and Start Here launcher icons are located. You can configure desktop to have special backgrounds colors and pictures to add a personal touch to your desktop.

•

Panel: A desktop toolbar, usually located across the bottom of the screen (such as Figure 1-5). The
panel contains the Main Menu button and shortcut icons to start commonly used programs. It can
be customized by the user.

Figure 1-5. The Desktop Panel

•

Root: The root user account is created during installation and has complete access to the system.
You must be logged in as root to accomplish certain system administration tasks. User accounts are
created so typical user tasks can be done without using the root account, to reduce the chance of
damaging your Red Hat Linux installation or its applications permanently.

•

su and su -: The command su gives you access to the root account or other accounts on your system.
When you type su to switch to your root account while still inside your user account shell, you have
access to important system files that you can change, or damage, permanently. Logging in with the
su - command makes you root within the root account shell. Use caution when you are logged in
as root.
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•

Man page and info page: Man (short for manual) and info pages give detailed information about a
command or file (man pages tend to be brief and provide less explanation than info pages). To read
the man page for the su command, for example, type man su at a shell prompt (or type info su
for the info page). To close one of these pages, press [q].

•

X or X Window System: These terms refer to the graphical user interface environments. If you are
"in X" or "running X" you are working in a GUI rather than a console environment.

•

RPM: RPM stands for RPM Package manager and is how Red Hat builds and delivers its software
files. An RPM is a software package file you can install on your Red Hat Linux computer.

Although the emphasis throughout this book will be on navigation and productivity using the graphical
desktop environment, it will cover both the graphical and shell prompt methods of logging in and using
your Red Hat Linux system for your reference (or if you feel comfortable using the shell prompt).

1.3. Logging In
The next step to using your Red Hat Linux system is to log in. When you log in, you are introducing
yourself to the system (also called authentication). If you type the wrong user name or password, you
will not be allowed access to your system.
Unlike some other operating systems, your Red Hat Linux system uses accounts to manage privileges,
maintain security, and more. Not all accounts are created equal: some accounts have fewer rights to
access files or services than others.

Note
Like UNIX, Linux is case sensitive. That means that typing root refers to a different account than
Root. By default, root refers to the root user (also known as the superuser), or system administrator.

If you have already created and logged into a user account, you can skip ahead to Chapter 2. If you
created only the root account, read on to learn how to set up a user account.
If you did not create a user account during installation, you must log in as root. After you create a user
account, it is highly recommended that you log in as that user instead of root to prevent accidental
deletion of files or damage to your Red Hat Linux installation.

Caution
Because your Red Hat Linux system creates the root account during installation, some new users are
tempted to use only this account for all of their activities. This is a dangerous idea, because the root
account is allowed to do anything on the system. You can easily damage your system by accidentally
deleting or modifying sensitive system files. You may be tempted to forego creating and using a user
account during or after installation, but it is not recommended.

1.3.1. Graphical Login
During installation, if you selected graphical as the login type, you will see a graphical login screen
as shown in Figure 1-6. Again, unless you have chosen to give your machine its own hostname, which
is primarily used in a network setting, your machine will probably be called localhost.
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Figure 1-6. The Graphical Login Screen
To log in as root from the graphical login screen, type root at the login prompt, press [Enter], type
the root password that you chose during installation at the password prompt, and press [Enter]. To log
in as a regular user, type your username at the login prompt, type your password that you selected
when creating the user at the password prompt, and press [Enter].
Logging in from the graphical login screen automatically starts the graphical desktop for you.

1.3.2. Virtual Console Login
During installation, if you selected text as the login type, you will see a login prompt similar to the
following after booting your system:
Red Hat Linux release 8.0
Kernel 2.4.18-0.1 on an i686
localhost login:

Unless you have chosen to give your machine its own hostname, which is primarily used in a network
setting, your machine will probably be called localhost.localdomain.
To log in as root from the console, type root at the login prompt, press [Enter], type the root password
that you chose during installation at the password prompt, and press [Enter]. To log in as a regular
user, type your username at the login prompt, press [Enter], type your password that you selected
when creating the user at the password prompt, and press [Enter].
After logging in, you can type the command startx to start the graphical desktop.

1.4. Graphical Interface
When you installed Red Hat Linux you had the opportunity to install a graphical environment. Once
you start the X Window System, you will find a graphical interface known as a desktop similar to
Figure 1-7.
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Figure 1-7. The Graphical Desktop

1.5. Opening a Shell Prompt
The graphical desktop offers access to a shell prompt, an application that allows you to type commands instead of using a graphical interface for all computing needs. While this manual focuses on
performing tasks using the graphical interface and graphical tools, it is sometimes useful and faster to
perform tasks from a shell prompt. Refer to Chapter 11 for more details.
You can open a shell prompt by selecting Main Menu => System Tools => Terminal.
You can also start a shell prompt by double-clicking the Start Here icon, then Applications, then
System Tools, and finally Terminal.
To exit a terminal window, click the X button on the upper right corner of the window, type exit at
the prompt, or press [Ctrl]-[D] at the prompt.

1.6. Creating a User Account
When you installed Red Hat Linux you were given the opportunity to create one or more user accounts.
If you did not create at least one (not including the root account) you should do so now. You should
avoid working in the root account unless you absolutely have to.
There are two ways to create new and/or additional user accounts: using the User Manager or from a
shell prompt.
To create a user account graphically using the User Manager:
1. Click the Start Here icon on the panel at the bottom of your desktop. In the new window that
opens, click the System Settings icon, and then click the Users & Groups icon. You can also
select Main Menu => System Settings => Users & Groups.
You can also start the User Manager by typing redhat-config-users at a shell prompt.
2. If you are not logged in as root, you will be prompted for your root password.
3. The window shown in Figure 1-8 will appear. Click Add User.
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Figure 1-8. The Red Hat User Manager
4. In the Create New User dialog box, enter a username (this can be an abbreviation or nickname),
the full name of the user for whom this account is being created, and a password (which you
will enter a second time for verification). The name of this user’s home directory and the name
of the login shell should appear by default. For most users, you can accept the defaults for the
other configuration options. Refer to the Official Red Hat Linux Customization Guide for details
about additional options.
5. Click OK. The new user will appear in the user list, and the user account creation is complete.
To create a user account from a shell prompt:
1. Open a shell prompt.
2. If you are not logged in as root, type the command su - and enter the root password.
3. Type useradd followed by a space and the username for the new account you are creating at the
command line (for example, useradd jsmith). Press [Enter]. Often, usernames are variations
on the user’s name, such as jsmith for John Smith. User account names can be anything from
the user’s name, initials, or birthplace to something more creative.
4. Type passwd followed by a space and the username again (for example, passwd jsmith).
5. At the New password: prompt enter a password for the new user and press [Enter].
6. At the Retype new password: prompt, enter the same password to confirm your selection.
Important
You can be fancy or plain when you pick a user account name, but take precautions when you
choose a password. The password is the key to your account, so it should be both unique and
easy for you to remember. Your password should be at least six characters. You can use both
uppercase and lowercase letters, as well as numbers and characters. Avoid easy selections,
such as qwerty or password. If you want to pick an easy-to-remember but somewhat unique
password, consider a variation of a word, such as a!rPl8nE for airplane.

1.7. Documentation Resources
If you have the Official Red Hat Linux boxed set, remember to take a look through the Red Hat
Linux Documentation CD. All of the Official Red Hat Linux manuals are on this CD. Individual
downloads of our documentation in HTML, RPM, PDF, and compressed tarball format (.tar.gz) are
also available at http://www.redhat.com/docs/. Once you have logged in to your user account, inserting
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the Documentation CD in your CD-ROM drive should automatically start the Package Management
Tool and allow you to install any of the Official Red Hat Linux documentation. Follow the instructions
and choose the documentation you would like to install.

Figure 1-9. Package Management Tool Installing Documentation
After you have installed the documentation packages you want, you can access them at any time by
clicking Main Menu => Documentation.
If you have downloaded individual documentation RPM packages from the Red Hat website at
http://www.redhat.com/docs, you can install these manuals from a shell prompt. Open a shell
prompt, and type the following at the command line:
su

Press [Enter]. You will be asked for your root password. Enter the password at the prompt and press
[Enter]. You are now logged in as root. To install all four manuals, change to the directory that contains
the RPM files and type the following:
rpm -ivh rhl-*.rpm

Press [Enter].
To install only certain manuals, replace rhl-*.rpm with the full file name of the manual that you
want to install. For example, the file name for the Official Red Hat Linux Getting Started Guide will
look something like rhl-gsg-en-8.0.noarch.rpm, so you would type the following to install the
Official Red Hat Linux Getting Started Guide on your computer:
rpm -ivh /mnt/cdrom/rhl-gsg-en-8.0.noarch.rpm

Press [Enter]. Type exit at the command line and press [Enter]. This takes you out of root and back
to your user account.
Now go to Main Menu => Documentation and select the manual you want to read.

1.8. Logging Out
1.8.1. Graphical Logout
To log out your graphical desktop session, select Main Menu => Log Out.
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When the confirmation dialog appears as shown in Figure 1-10, select the Logout option and click
the Yes button. If you want to save the configuration of your desktop, as well as any programs which
are running, check the Save current setup option, as well.

Figure 1-10. Logout Confirmation

1.8.2. Virtual Console Logout
If you are not using the X Window System, and you logged in at the console, type exit or [Ctrl]-[D]
to log out of the console session.

1.9. Shutting Down your Computer
Before turning off your computer, it is important to shut down Red Hat Linux. Never turn off your
computer without shutting down first, as you may lose unsaved data or damage your system.

1.9.1. Graphical Shutdown
If you are in the graphical desktop, log out of your session as described in Section 1.8. From the
graphical desktop logout screen shown in Figure 1-10, select Shutdown and click OK to confirm.
Some computers automatically turn the power off after shutting down Red Hat Linux. If your computer
does not, you can turn off the power to your computer after you see the message:
Power down.

1.9.2. Virtual Console Shutdown
If you are logged in to a console, type the following command to shutdown your computer:
halt

Some computers automatically turn the power off after shutting down Red Hat Linux. If your computer
does not, you can turn off the power to your computer after you see the message: System halted.
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Chapter 2.
Using the Graphical Desktop
Red Hat Linux includes a powerful graphical desktop environment where you can easily access your
applications, files, and system resources. Both new and experienced users will be able to take full
advantage of their Red Hat Linux system using the graphical desktop.
This chapter covers the fundamentals of the desktop and how you can customize it for your needs.

2.1. Using the Desktop
Your first view of the graphical desktop will look something like Figure 2-1.

Figure 2-1. The Graphical Desktop
The graphical desktop gives you access to the applications and system settings on your computer. You
will notice that it offers three main tools to make use of the applications on your system: panel icons,
desktop icons, and menu systems.
The long bar across the bottom of the desktop is the panel. The panel contains application launchers,
status indicators, and small applications called applets that let you control sound volume, switch
workspaces, and indicates the status of your system.
The icons elsewhere on the desktop can be file folders, application launchers, and removable devices
such as CD-ROM and diskettes when they have been mounted. To open a folder or launch an application, double-click on its icon.
The menu systems can be found by clicking on the Main Menu button. They can also be found by
clicking on the Start Here icon located on the desktop and then clicking the Applications icon.
The desktop works in the manner you might expect it to when working with other operating systems.
You can drag and drop files and application icons to areas that are easily accessible. You can add new
icons for files and applications to the desktop, panel, and file manager. You can change the appearance
of most of the tools and applications, as well as changing system settings with provided configuration
tools.
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2.2. Using the Panel
The desktop panel is the bar that stretches across the bottom of the screen and holds icons and small
applications which makes using your system easier. The panel also holds the Main Menu which
contains menu items for all of your applications. Applets allow you to run specific tasks or monitor
your system or services, like Red Hat Network, while remaining out of your way.

Figure 2-2. The Panel at the Bottom of the Desktop

2.2.1. Using the Main Menu
You can click on the panel Main Menu button
you to access the applications on your system.

to expand it into a large set of menus that allows

From here, you can start most applications included in Red Hat Linux. Notice that, in addition to the
recommended applications, you can also access additional applications under the Extras entry These
sub-menus give you access to a full range of applications on your system. From the Main Menu, you
can also log out, run applications from a command line, find files, and lock your screen (which runs a
password protected screen saver).

2.2.2. Using Applets
Applets are small applications that run on the panel. Applets usually let you monitor things on your
system or the Internet. Some have more specific tasks while others are designed to be entertaining.
There are a few applets that run on your panel by default. These applets are fairly important and are
covered in the following list.
Workspace Switcher
The Workspace Switcher is a simple applet that allows you to see what applications you have
open on your desktops. The graphical desktop gives you the ability to use multiple workspaces so
you do not have to have all your running applications crowding one viewable desktop area. The
Workspace Switcher will represent each workspace in small squares and show the applications
running on them. You may click on one of the squares with your mouse to move to that desktop.
You can also use the keyboard shortcut [Ctrl]-[Alt]-[right-arrow] or [Ctrl]-[Alt]-[left-arrow] to
switch between desktops.

Figure 2-3. Workspace Switcher

Taskbar
Next to the Workspace Switcher is the Taskbar. The taskbar is an applet which shows you the
titles of running applications on any desktop. This is very helpful if you decide to minimize an
application as it will seem to disappear from the desktop. Once it disappears, you can bring it
back by clicking on its title in the Taskbar.
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Figure 2-4. The Taskbar

2.2.3. Using the Notification Area
Red Hat Network Notification Tool
Part of the Panel Notification Area, the Red Hat Network Notification Tool provides you with
an easy way to make sure your system is up-to-date with current errata and bug fixes from Red
Hat. The applet shows you different images that indicate whether your system is up to date or
needs upgrades. If you click on the applet, a list of available updates will by displayed. To update
your system, click the button to launch the Red Hat Update Agent. If you are not registered
with Red Hat Network, it will launch the registration application. Right-click on the applet icon
and select Help for details.

Figure 2-5. Red Hat Network Notification Tool

The Authentication Icon
The key icon that is sometimes displayed in the Notification Area is a security notification that
alerts you whenever you have gained root authentication for your system. It disappears when the
authentication times out.

Figure 2-6. Authentication Icon

2.2.4. Adding Icons and Applets to the Panel
To make the panel fit your needs, you may want to add more applets and launcher icons.
To add an applet to the panel, right-click in an unused area on the panel and select Add to Panel and
choose from the menu of applets. When you select an applet, it will appear on your panel as that is
the only place it will run.
To add a launcher icon to the panel, right-click in an unused area on the panel and select Add to Panel
=> Launcher. This will launch a dialog box that allows you to enter the name of the application, the
location and name of the command that starts the application (such as /usr/bin/foo), and even
choose an icon for the application. Click OK and the new launcher icon will appear on the panel.
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Tip
Another quick and easy way to add a launcher to the panel is to right-click on an unused area of the
panel and choose Add to Panel => Launcher from menu. Then select an application that appears
in the menu. This will automatically add a launcher icon based on the properties of the item in the
Main Menu.

2.2.5. Configuring the Desktop Panel
You can hide the panel automatically or manually, place it on any edge of your desktop, change its size
and color, and change the way it behaves. To alter the default panel settings, right-click in an unused
area of the panel and select Properties. You can set the size of the panel, its position on the desktop,
and whether you want the panel to be automatically hidden (Autohide) when not in use. If you choose
to Autohide the panel, it will not appear on the desktop until you move your mouse pointer toward it
(called hovering).

2.3. Using Nautilus
The graphical desktop includes a file manager called Nautilus that gives you a graphical display
of your system and personal files. Nautilus is designed to be much more than a visual listing of
files, however. It allows you to configure your desktop, configure your Red Hat Linux system, play
your digital music and video files, browse your photo collection, access your network resources, and
more all from one integrated interface. In essence, Nautilus becomes a shell for your entire desktop
experience.
Working in Nautilus is efficient and provides an alternative to searching through the various submenus connected to the Main Menu or using a shell prompt to navigate the file system. The following
sections explain how to use the Nautilus to enhance your desktop experience.
To start Nautilus as a file manager, double-click on your home directory icon:
Once Nautilus appears, you can navigate through your home directory or the rest of the file system.
To return to your home directory, click the Home button.
When you navigate through your file system, you can always see where you are by looking at the
frame on the left which shows you the current directory.
The main frame contains folders and files which you can drag with your mouse to move and copy
them into new locations. If you prefer, you may click on the Tree tab on the bottom left to display a
hierarchical view of your complete file system which may make moving and copying easier for you.
If the Tree tab does not appear on the bottom left, you can make the tab available by right clicking in
the tab area and choosing Tree from the menu.
If you do not want to use the tree view, you can open another Nautilus window by selecting File
=> New Window. Once you have another Nautilus window, you can drag and drop files to different
directories. By default, dragging a file from one directory to another will move the file. If you wish to
copy the file to another directory, press the [Ctrl] key while dragging and dropping the file.
By default, text-based files and images in your home directory will be seen as thumbnails. For text
files, this means you will see a portion of the actual text in the icon. For images, you will see a scaleddown (or thumbnail) version of the image. To turn off this feature, select Edit => Preferences. Select
Performance from the menu on the left. Select Never for the visual enhancements that you want to
disable. Disabling these features will increase the speed of Nautilus.
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2.4. Start Here

Figure 2-7. The Start Here Window
Start Here was designed to hold all of the tools and applications you need to access when using your
system. From your favorite applications to system and configuration tools, the Start Here window
provides a central location for using and customizing your system.
You may access Start Here at any time by clicking on the desktop icon labeled Start Here or by
selecting Start Here from the Main Menu.
The Start Here screen includes icons that allow you to access your favorite applications, desktop
preferences, Main Menu items, server configuration tools, and system settings.

2.4.1. Customizing the Desktop
From the Start Here screen you can select the Preferences icon to configure your desktop, which
presents you with a wide selection of configuration options. Below you will find a list of a few of the
options and tools in each area.
Background
You can configure your background with new colors or a new image.
Sound
In this section you can configure the system sounds associated with various functions. For example, if you would like to have a sound play when you log in to your desktop, you can configure
that here.
Keyboard Shortcuts
You can configure shortcuts — pressing a combination of keystrokes on the keyboard — to
perform actions within an application or on your desktop. For example, you can configure a
shortcut to move from your current Workspace to Workspace 2 by pressing [Ctrl]-[F2].
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2.4.2. Customizing your System
The Start Here screen in Nautilus contains additional configuration tools that help you with your
new Red Hat Linux system and the server applications included.
The System Settings icon includes tools that help you set up your system for personal everyday use.
Below you will find a list of some of the tools included in System Settings and what you can do with
them.
Date & Time
This tool allows you to set the date and time of your machine. You will be able to set your time
zone information as well.
Soundcard Detection
The Soundcard Detection tool probes your machine for available sound devices. Refer to Section 9.3 for more details on configuring your sound hardware.
Users & Groups
The Users & Groups tool allows you to add and remove users from your system. Refer to Section
1.6 for details.
Printing
The Printer Configuration Tool allows you to add a new printer to your system. The printer
may be connected to your machine or available on a network. Refer to Chapter 7 and the Official
Red Hat Linux Customization Guide for details.
As mentioned before, you will also find server configuration tools in the Start Here area. These
tools help you configure services and applications you are using on the local machine to serve other
machines. The server configuration tools are found by clicking on the Server Settings icon. A couple
of examples of the tools found in this area are the tools for the Apache Web Server and a DNS/Bind
tool. You must have those server applications installed before these tools appear in this section. Refer
to the Official Red Hat Linux Customization Guide for details.

2.5. Logging Out
When you have finished working and want to quit GNOME, you are presented with the choice of
simply logging out of GNOME (leaving the system running), restarting the machine, or halting the
system completely.

Figure 2-8. The Desktop Log Out Confirmation
To quit the graphical desktop, select the Log Out menu item from the Main Menu. This will bring
up a dialog which presents you with the options listed above.

Chapter 3.
Diskettes and CD-ROMs
Using diskettes and CD-ROMs with Red Hat Linux requires some understanding about removable media. This chapter discusses how to read and write files to and from diskettes, how to format diskettes,
and how to read and copy data from a CD-ROM. This chapter also covers using CD-writable and
CD-rewritable drives.

3.1. Using Diskettes
Diskettes are one of the oldest removable media solutions available for the personal computer (PC).
Diskettes are ideal as a portable storage solution used for files that need to be physically moved
around. For example, if two PCs are not on the same network, diskettes are a great solution to transfer
files from one computer to the other.

3.1.1. Mounting and Unmounting a Diskette
A diskette must be mounted first before it can be used. Insert a diskette into the diskette drive and type

mount /mnt/floppy/ at a shell prompt.

The diskette drive activity light should blink as the diskette’s file system is mounted to the
/mnt/floppy directory.
You can access the contents of the diskette by changing into that directory with the cd
/mnt/floppy/ command.
Alternatively, you can also mount a diskette by right-clicking on the desktop and choosing Disks =>
Floppy. This mounts the diskette and adds a desktop icon which you can double-click to explore the
diskette contents

.

Now that the diskette has been mounted it is available to be copied from or written to. You can open,
save, and copy files to/from it as you would normally do to your hard drive. You can even explore the
diskette’s contents in Nautilus (as shown in Figure 3-1) or Konqueror.

Figure 3-1. Viewing files on a Diskette with Nautilus
When you are done using the diskette, you should unmount it before ejecting it from the drive. To do
this, close any applications that may be using files on the diskette or exploring the diskette’s contents
(such as Nautilus or Konqueror), and at a shell prompt type the following command :
umount /mnt/floppy/
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If you are using GNOME, unmount the diskette by right-clicking on the
mount Volume from the menu.

icon and choosing Un-

You can now safely eject the diskette from the drive.

3.1.2. Reading MS-DOS formatted Diskettes
If you have an MS-DOS formatted diskette, you can access the files on it using the mtools utility.
mtools offers a wide range of options for working with diskettes, including copying, moving, deleting, and formatting. To read more about mtools, type man mtools at a shell prompt.

For example, to copy a file from an MS-DOS formatted diskette (such as one from a Windows system),
type the following command at a shell prompt:
mcopy a:thisfile.txt
thisfile.txt

thisfile.txt will be copied from the diskette drive (drive A:) to the directory you were in when
you issued the mcopy command. If you are in your home directory, you will find thisfile.txt
located there.

If you want to view the contents of an MS-DOS formatted diskette, type mdir at the prompt. You will
be shown the contents of the diskette. The directory listing will look familiar to some MS-DOS or
Windows users, as it is styled in the MS-DOS dir listing format. For example:
[joe@localhost joe]$ mdir a:
Volume in drive A has no label
Volume Serial Number is 0000-0000
Directory for A:/
FOOBAR
ZZTOP
TAXES99
THISFILE
COMMAND
5

TXT
COM
XLS
TXT
COM
files

6004
1533
26469
277
93890

01-01-1999
1:01
01-01-1999
1:01
01-01-1999
1:01
01-01-1999
1:01
01-01-1999
1:01
128 173 bytes
1 271 827 bytes free

To change to a subdirectory on the diskette, type the following command at a shell prompt:
mcd a:subdir

In the above command, subdir is the name of the subdirectory you want to access.

3.1.3. Putting Linux Files on an MS-DOS Diskette
To copy files from a Linux machine to an MS-DOS formatted diskette so that a Windows machine
can read it you should format your disk with an MS-DOS (FAT) filesystem, which can be done with
a Windows OS or with gfloppy (see Section 3.1.4.1). Then mount it in Linux as described in Section
3.1.1. Copy files using the following command (substituting filename with the name of the file you
wish to copy):
cp filename /mnt/floppy

You can then unmount the floppy and eject it from the drive. The new file on the diskette should now
be accessible from your Windows machine.

Chapter 3. Diskettes and CD-ROMs

31

3.1.4. Formatting a Diskette
To use a diskette specifically with Red Hat Linux, you need to format the disk using the ext2 file
system. ext2 is one of the file systems supported by Red Hat Linux, and is the default method used for
formatting diskettes.

Warning
Formatting a diskette will erase all of its contents. Be sure to backup any files that you need before
performing any of the following operations on your diskettes.

Once you have created an ext2 file system on the diskette, you can manipulate its contents in the same
ways that you manipulate directories and files on your hard drive.
3.1.4.1. Using gfloppy
To start gfloppy, choose Main Menu => System Tools => Floppy Formatter. From a shell prompt,
type /usr/bin/gfloppy. As shown in Figure 3-2, the gfloppy interface is small and has few options.
The default settings are sufficient for most users and needs; however, you can format your diskette
with an MS-DOS file system type if you desire. You can also choose the density of your floppy disk
(if you are not using the usual high density 3.5" 1.44MB diskette. You can also elect to quick format
the diskette if it was previously formatted as ext2.

Figure 3-2. gfloppy
Insert a diskette and change the settings to suit your needs; then click Format. The status box will
appear on top of the main window, showing you the status of formatting and verifying (see Figure
3-3). When it is complete, you can eject the disk and close gfloppy.

Figure 3-3. gfloppy Status Box
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3.1.4.2. Using KFloppy
Another way to format a diskette for either ext2 or MS-DOS is to use KFloppy. To start the utility,
open a shell prompt and type the command kfloppy. You will be presented with a graphical interface
shown in Figure 3-4.

Figure 3-4. KDE Floppy Formatter
Insert a diskette that you wish to format and choose whether you want a Quick Format or Full
Format by choosing the appropriate radio button. To check for bad sectors or blocks on the diskette
while formatting, choose Verify Integrity in the associated check box.
To begin formatting, click the Format button. A window will pop-up asking if you wish to format the
diskette. Click Continue to dismiss this window and begin formatting. A status bar will appear at the
bottom of the window showing the status of the format. After the diskette has been formatted, a final
window will appear to inform you of a successful format. Click OK, remove the diskette, and click
Quit to close the application.
3.1.4.3. Using mke2fs
The mke2fs command is used to create a Linux ext2 file system on a device such as a hard drive
partition or (in this case) a floppy diskette. mke2fs essentially formats the device and creates an
empty, Linux-compatible device which can then be used for storing files and data.
Insert your diskette into the drive and issue the following command at a shell prompt:
/sbin/mke2fs /dev/fd0

On Linux systems, /dev/fd0 refers to the first diskette drive. If your computer has more than one
floppy disk drive, your primary floppy drive will be /dev/fd0, your second /dev/fd1, and so on.
The mke2fs utility has a number of options. The -c option makes the mke2fs command check the
device for bad blocks before creating the file system. The other options are covered in the mke2fs
man page.
Once you have created an ext2 file system on the diskette, it is ready to be used with your Red Hat
Linux system.
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3.2. CD-ROMs
The CD-ROM format is a popular way to deliver typically large software applications and multimedia
presentations. Most of the software that can be purchased from retail outlets come in the form of
CD-ROMs. This section shows you how to use CD-ROMs on your Red Hat Linux system.
By default, Red Hat Linux automatically detects if a CD-ROM is inserted in the CD-ROM device.
The disc will then be mounted and your file manager will open a window with the drives contents for
you to explore.

3.2.1. Using CD-ROMs with Your File Manager
By default, CDs are automatically mounted and opens the default file manager for you to explore the
contents of the CD. Figure 3-5 shows the contents of a CD-ROM within the Nautilus file manager.

Figure 3-5. Contents of a CD-ROM in Nautilus
A CD desktop icon
will also appear, which you can use to unmount and eject your CD-ROM
after use. Right-click on the icon to view all of the available choices. For example, to unmount and
eject the CD-ROM, choose Eject from the menu.

3.2.2. Using CD-ROMs From a Shell Prompt
You can also manually mount and unmount your CD-ROMs from a shell prompt. Insert a CD into
your CD-ROM drive, open a shell prompt and type the following command:
mount /mnt/cdrom

The CD-ROM should now be mounted and available for use with your file manager. For example, if
you are using Konqueror, you can access your CD-ROM by clicking the
icon on the desktop
and typing /mnt/cdrom in the location bar. Figure 3-6 shows the contents of a CD-ROM displayed
in the Konqueror file manager.
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Figure 3-6. Contents of a CD-ROM in Konqueror
After working with your CD, you must unmount it before you eject it from your CD-ROM drive.
Close any applications or file managers that are using the CD-ROM and type the following at a shell
prompt:
umount /mnt/cdrom

You can now safely press the eject button on your CD-ROM drive to retrieve your CD.

3.3. CD-Rs and CD-RWs
CD-writable (CD-R) drives have grown in popularity as an inexpensive way to backup and archive several megabytes of data, including applications, personal files, and even multimedia (audio/video and
still image) presentations. Red Hat Linux includes several tools for using CD-Rs and CD-rewritable
(CD-RW) drives.

3.3.1. Using X-CD-Roast
X-CD-Roast is a graphical application for duplicating and creating (mastering) CD-ROMs. X-CDRoast automates the process of burning CD-Rs and CD-RWs and is highly configurable to many CD
mastering or duplicating needs.
To start X-CD-Roast choose Main Menu => System Tools => CD Writer. To start it at a shell
prompt, type /usr/bin/xcdroast. X-CD-Roast will first scan your device busses and find your
CD-R(W) drive. It will then allow you to configure settings for CD-writer, CD-ROM drive, and more.
Figure 3-7 illustrates the Setup screen and its configuration options. Note that your CD-R(W) drive
brand may be different from the drive shown.
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Figure 3-7. X-CD-Roast Setup Screen
Check your CD-R(W) manufacturer documentation to set some of the CD Settings options, such as
CD Writer Speed and CD Writer FIFO-Buffer Size. All CD image (.iso or .img) files need to be
stored in a central location accessible to X-CD-Roast. You will have to specify a path on your hard
drive’s file system that has at least 700 Megabytes (MB) of free space available. You can configure
the path where you wish to store CD images in the HD Settings tab under Path.
X-CD-Roast is well-documented within the interface itself, as several of the options have long, descriptive pop-up tips that informs you of the associated function in detail. You can access these tooltips
by leaving your mouse pointer on a button or drop-down menu for at least two seconds.
3.3.1.1. Using X-CD-Roast to Duplicate CD-ROMs
To duplicate an existing CD-ROM for backup purposes, click the Duplicate CD button in the main
panel. You can read all of the tracks on a CD — all CD-ROM information, including data and audio, is
stored on tracks — by clicking Read CD. You can set the speed at which you read a CD-ROM as well
as find out some information about the CD-ROM track such as its type and size. If you are copying
tracks from an audio CD, you can preview each track with Play Audio-Tracks. Since X-CD-Roast
reads all tracks of a CD-ROM by default, you can delete unwanted tracks with Delete Tracks.
Finally, to burn your tracks onto CD-R(W) media, choose Write CD. Figure 3-8 shows the Write
CD dialog box, where you can configure the speed at which you read and write the tracks to CD-R as
well as whether you wish to copy the CD-ROM on-the-fly or create an image file first before burning,
which is recommended to prevent write or read errors from occurring during the duplication process.
Click the Write CD button to start the burning process.
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Figure 3-8. Using X-CD-Roast to Duplicate CDs

3.3.1.2. Using X-CD-Roast to Create a CD
It is always recommended to backup personal data and information often in case of hardware failure or
file system corruption. X-CD-Roast allows you to backup files on your hard drive partition using Create CD. This facility allows you to add files and directories into a CD session using Master Tracks.
There are other options within the Master Tracks dialog that allows you to configure advanced settings; however, the defaults are set correctly to create data CD-ROMs, so no further configuration is
necessary. Figure 3-9 shows a session that is preparing the entire /home directory for backup.

Figure 3-9. Using X-CD-Roast to Back-up Hard Drive Files
Highlight the files and directories that you wish to add to the session and click Add. After you have
added all the files and directories you want to write to the CD-R(W), click the Create session/image
tab to create the .img file. You must first click Calculate size, then Master to image file to create the
image.
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To write your tracks to the CD-R(W), click Write Tracks from the panel on the left. In the Layout
Tracks tab, highlight the image file you created in the box on the right, and click Add. The image
will be displayed in the Tracks to write box on the left side. Click Accept track layout, and click
the Write Tracks tab to return to the main writing dialog. Click Write tracks to write the image to
the CD-R(W).

Tip
You can also create and write the image to the CD-R(W) in one step by clicking Master and write onthe-fly in the Create session image tab. This saves a few steps but can sometimes cause read-write
errors. It is recommended that you use the multi-step method instead of on-the-fly methods.

3.3.1.3. Writing ISOs with X-CD-Roast
Large files that end in .iso are known as ISO9660 (or ISO) image files. For example, Red Hat Linux
is freely available as ISO images that you can download and write to the CD-R(W). There are other
ISO image files available on FTP and websites. There are other file types that can be burned as images,
such as .img and .raw, but ISO images are the most common CD image format.
To write an ISO image file to a CD-R(W) with X-CD-Roast, move the ISO file to the path specified
during setup, then click Create CD. In the Layout tracks tab, highlight the ISO image file you wish
to burn and click Add, then Accept track layout. This will automatically load the Write Tracks tab,
where you can click Write Tracks to burn the image to the CD-R(W).

3.3.2. Using CD-Rs and CD-RWs with Command Line Tools
If you want to use a shell prompt to write images to CD-R or CD-RWs, there are two utilities available:
mkisofs and cdrecord. These two utilities have several advanced options that are beyond the scope
of this guide; however, for basic image creation and writing, these tools save some time over the
graphical alternatives such as X-CD-Roast.
3.3.2.1. Using mkisofs
The mkisofs utility creates ISO9660 image files that can be written to a CD-R(RW). The images that
mkisofs can be made up of all types of files. It is most useful for archival and file backup purposes.
Suppose you wish to backup a directory called /home/joeuser/, but exclude the subdirectory
/home/joeuser/junk/ because it contains unnecessary files. You want to create an ISO image
called backup.iso and write it to CD-R so that you can use it on your Red Hat Linux PC at work
and your Windows laptop for trips. This can be done with mkisofs by running the following command:
mkisofs -o backup.iso -x /home/joeuser/junk/ -J -R -A -V -v /home/joeuser/

The image will be created in the directory which you were in when you ran the command. Table 3-1
explains each command-line option. For more information on using mkisofs, refer to the additional
resources in Section 3.4.
You can now use the ISO image file with either X-CD-Roast as described in Section 3.3.1.3, or
using cdrecord, the command-line based CD recording utility. For more information about using
cdrecord, refer to Section 3.3.2.2.
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Option

Function

-o

Specify an output filename of the ISO image

-J

Generate Joliet naming records; useful if the CD will be used in
Windows environments

-R

Generate Rock Ridge (RR) naming records to preserve filename
length and casing, especially for UNIX/Linux environments

-A

Set an Application ID — a text string that will be written into the
volume header of the image that can be useful to determine what
applications are on the CD

-V

Set a Volume ID — a name that will be assigned to it if the image
is burned and the disc is mounted in Solaris and Windows
environments

-v

Set verbose execution, which is useful for viewing the status of
the image as it is being made.

-x

Exclude any directory immediately following this option; this
option can be repeated (for example, ... -x /home/joe/trash -x
/home/joe/delete ...)

Table 3-1. mkisofs Options

3.3.2.2. Using cdrecord
The cdrecord utility writes audio, data, and mixed-mode (a combination of audio, video, and/or data)
CD-ROMs using options to configure several aspects of the write process, including speed, device,
and data settings.
To use cdrecord, you must first establish the device address of your CD-R(W) device by running the
following command as root at a shell prompt:
cdrecord -scanbus

This command will show all CD-R(W) devices on your computer. Remember the device address of
the device you will use to write your CD. The following is an example output from running cdrecord
-scanbus.
Cdrecord 1.8 (i686-pc-linux-gnu) Copyright (C) 1995-2000 Jorg Schilling
Using libscg version ’schily-0.1’
scsibus0:
0,0,0
0) *
0,1,0
1) *
0,2,0
2) *
0,3,0
3) ’HP
’ ’CD-Writer+ 9200 ’ ’1.0c’ Removable CD-ROM
0,4,0
4) *
0,5,0
5) *
0,6,0
6) *
0,7,0
7) *

To write the backup file image created with mkisofs in the previous section, switch to root user and
type the following at a shell prompt:
cdrecord -v -eject speed=4 dev=0,3,0 backup.iso
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The command above sets the write speed at 4, the device address as 0,3,0, and sets write output to
verbose (-v), which is useful for tracking the status of the write process. The -eject argument ejects
the CD-ROM after the write process is complete. The same command can also be used for burning
ISO image files downloaded from the Internet, such as Red Hat Linux ISO images.
You can use cdrecord to blank CD-RW discs for reuse by typing the following:
cdrecord --dev=0,3,0 --blank=fast

3.4. Additional Resources
This chapter covers several applications briefly. Refer to the following resources for more information
about the applications in this chapter

3.4.1. Installed Documentation
•

cdrecord man page — Discusses how to burn data, audio and mixed-mode CD-ROMs. Offers
all options and commands in detail, including some example commands for common CD-R(W)
burning tasks.







(where version is the version of cdrecord
installed on your system) — Several documentation files are included with general usage and licensing information.

• /usr/share/doc/cdrecord- version

•

mkisofs man page — Comprehensive detail of the utility, including some warnings about creating
certain types of ISO images. Offers all options and commands in detail, including some example
commands for creating common ISO image files.







(where version is the version of mkisofs installed on your system) — Several documentation files are included with general usage and licensing information.

• /usr/share/doc/mkisofs- version







(where version is the version of X-CD-Roast
installed on your system) — Contains useful command-line options and usage information for this
graphical CD-R(W) mastering application.

• /usr/share/doc/xcdroast- version



• /usr/share/doc/dvdrecord- version /

(where



version



is the version of

dvdrecord installed on your system) — For users who have DVD-R(+W) devices, this set of

documentation helps you get started mastering DVD-ROMs for data backup and multimedia
presentation.

3.4.2. Useful Websites
•

http://www.xcdroast.org/ — The Official website of the X-CD-Roast project.

•

http://freshmeat.net/projects/cdrecord/ The cdrecord project page on Freshmeat is regularly updated with the newest releases, news, and user commentary.

•

http://www.freesoftware.fsf.org/dvdrtools/ — The official website of the dvdrtools project,
which includes the dvdrecord utility for writing DVD-R(+W) discs.
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Chapter 4.
Getting Online
There are many types of Internet connections including:
•

ISDN Connection

•

Modem Connection

•

xDSL Connection

•

Cable Modem Connection

The Internet Druid application can be used to configure an Internet connection in Red Hat Linux.
If you would like to configure an Internet connection in Red Hat Linux, you can use the Internet
Druid application.
To use Internet Druid, you must be running the X Window System and have root privileges. To start
the application, use one of the following methods:
•

In the graphical desktop environment, go to the Main Menu => System Tools => Internet Configuration Wizard.

•

At a shell prompt, type the command internet-druid

In both cases you will have to enter your root password to continue.
Your own ISP may have specific connection requirements for their service which differ from the
instructions in this chapter. Before connecting, check with your ISP for any specific instructions that
they provide, including the following information:
•

The phone number that your modem must dial to connect to your ISP if you are using a modem.

•

Your login name and password for the ISP account.

•

A gateway address. Some ISPs may require you to configure a gateway address.

•

DNS entries: DNS means Domain Name System. DNS servers act as a road map for the Internet.
When you use the Internet, the DNS tells your machine where to send its message traffic. DNS
tracks IP (Internet Protocol) addresses; each computer connected to the Internet must have an IP
address, which is a unique set of numbers like 2xx.2xx.2x.2. You may receive one or more
DNS entries from your ISP when you sign up.

Figure 4-1. Internet Connection Wizard
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ISDN Connection
An ISDN (Integrated Services Digital Network) connection uses high-speed, high-quality digital
telecommunication lines as opposed to an analog modem connection. This special phone line
must be installed by a phone company. To configure this type of connection, start Internet Druid,
select ISDN Connection, and follow the steps in the wizard.
Modem Connection
A modem connection uses a modem to establish a connection to the Internet. Digital data is
modulated into analog signals and sent over phone lines. To configure this type of connection,
start Internet Druid, select Modem Connection, and follow the steps in the wizard.
xDSL Connection
An xDSL (Digital Subscriber Line) connection uses high-speed transmissions through telephone
lines. There are different types of DSL such as ADSL, IDSL, and SDSL. Internet Druid uses
the term xDSL to mean all types of DSL connections.
Some DSL providers require you to configure your system to obtain an IP address through DHCP
with an Ethernet card. To configure this type of connection, start Internet Druid, select Ethernet
Connection, and select DHCP on the Configure Network Settings screen. Some DSL providers
require you to configure a PPPoE (Point-to-Point Protocol over Ethernet) connection with an Ethernet card. To configure this type of connection, start Internet Druid, select xDSL Connection,
and follow the steps in the wizard. If you must supply a username and password to connect, you
are probably using PPPoE. Ask your DSL provider which method you should use.
Cable Modem Connection
A cable modem connection uses the same coaxial cable that your TV cable travels on to transmit
data. Most cable Internet providers require you to install an Ethernet card in your computer that
connects to the cable modem. Then, the cable modem connects to the coaxial cable. The Ethernet
card is usually required to be configured for DHCP. To configure this type of connection, start
Internet Druid, select Ethernet Connection, and select DHCP on the Configure Network
Settings screen.
Wireless Connection
If you are connecting your Red Hat Linux computer to a wireless access point (WAP) or peerto-peer (also called ad-hoc) network with a wireless (802.11x) network card, then you will need
to configure your wireless device. Choose the Wireless Connection, then select the device from
the list provided. You can then configure the device for DHCP or fixed IP addresses In the pop-up
device configuration window.
For more detailed instructions, refer to the Network Configuration chapter in the Official Red Hat
Linux Customization Guide.

Chapter 5.
Web Browsing
Once you have configured your Internet connection (see Chapter 4), you are ready to get online. Red
Hat Linux comes with several open source browsers for you to choose from. This chapter briefly
explains how to surf the Web using the following browsers:
•

Mozilla

•

Nautilus

•

Konqueror

•

Galeon

5.1. Mozilla
Mozilla functions like any other Web browser. It has the standard navigation toolbars, buttons, and
menus.

Figure 5-1. Mozilla Main Browser Window
If you have previously been using Netscape as your Web browser and performed an upgrade of Red
Hat Linux, the first time that you start Mozilla you will not see the main Mozilla browser as seen in
Figure 5-1.
Instead, you will first see:

44

Chapter 5. Web Browsing

Figure 5-2. Mozilla Profile Creation
If you click Convert Profile, your prior Netscape bookmarks and preferences will be converted to a
Mozilla profile for you.
When you next launch Mozilla, either from the panel or from Main Menu => Internet => Web
Browser, you will see that your previous bookmarks are now available in Mozilla.
If you click Manage Profiles, you will have the opportunity to create one or more profiles, or user
accounts, for Mozilla.

Figure 5-3. Mozilla Profile Manager
Here you can select to create a new profile or you can create a profile based on your user account.
This feature helps you stay organized by creating separate user accounts for business use, personal
use, multiple accounts, etc.
Clicking Create Profile will take you to a information screen explaining what this process really
means. To continue, click Next.
Next, choose a name to use for this new profile. If you do not enter a name, the profile will be called
Default User.

Figure 5-4. Profile Configuration
You can also click Choose Folder to select where your Mozilla settings and preferences will be
stored. By default, these settings are stored in:
/home/youraccountname/.mozilla/Default User

When you click Finish, your new profile will be added.
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Figure 5-5. Profile Screen With New Profile Added
Now that you have created a user profile, click on Start Mozilla to launch the application or click on
Exit to close it.
To add new profiles or delete existing profiles later on, you will need to run the Mozilla Profile
Manager again. To launch the Mozilla Profile Manager, at the shell prompt type the following
command:
mozilla --ProfileManager

5.1.1. Mozilla Web Browser
Once you have configured your user profile, you are ready to use the browser. To access Mozilla click
the Mozilla launcher on the panel or choose Main Menu => Internet => Web Browser.

Figure 5-6. Mozilla Main Browser Window
The Mozilla screen has all of the standard Web browser functions that other browsers have. There
is a main menu at the top of the screen and a navigation bar below it. There is a sidebar on the left
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that contains additional options. And in the bottom left corner, there are four small icons: Navigator,
Mail, Composer, and Address Book.
To browse the Internet, click on Search and enter a topic in the search engine that opens, type a
website URL in the location bar, click on and create bookmarks, or check the What’s Related sidebar
tab to see pages related to the one you are viewing currently.

Tip
Mozilla allows you to browse multiple websites within one browser window using navigational tabs.
Instead of using two separate windows to read web pages, you can open a tab by clicking File =>
New => Navigation Tab or by pressing [CTRL] and [T] at the same time. This will open the new tab
and allow you to switch between tabs by clicking on them. To close a tab, right-click on the tab and
choose Close Tab from the menu.

For additional information on using Mozilla, click on Help (on the top menu panel) and then on Help
Content.

5.1.2. Mozilla Composer
You can use Mozilla Composer to create webpages. You do not need to know HTML to use this tool.
To open Composer, go to Tasks => Composer on the Mozilla main menu, or click on the Composer
icon in the lower left part of the screen:
The Mozilla help files provide information on creating webpages with Composer.
Go to Help on the main menu and select Help Contents. When the help screen opens, click on the
Contents tab and expand the Creating Webpages menu by clicking on the arrow next to it. A list
of topics will appear and clicking on any of these will provide you with information for creating and
editing webpages using Mozilla Composer.

Figure 5-7. Mozilla Composer
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5.2. Nautilus
Nautilus is a core component of the GNOME desktop environment and provides an easy way to view,
manage, and customize your files and folders, as well as browse the Web.
Nautilus integrates your access to files, applications, media, Internet-based resources, and the Web,
making it convenient for you to locate and use all the resources that are available.
If you are using Nautilus, browsing the Web is one mouse click away. Click Web Search in the
toolbar to launch the Nautilus Web browser feature.

Figure 5-8. Nautilus Web Search
Or, you can use the Location: bar to enter path names, URLs, or other types of addresses.
When you are viewing a Web page, Nautilus gives you additional browser choices in case you want to
use a full-featured Web browser. To select a different browser, click one of the buttons in the sidebar.
For additional information on using Nautilus, click on Help (on the top menu panel) and select Nautilus User Manual or Nautilus Quick Reference.

5.3. Konqueror
Konqueror not only allows you to browse your local and network file system, but with component
technology used throughout KDE, Konqueror is also a full featured Web browser, which you can use
to explore the Internet.
To launch Konqueror choose Main Menu => Extras => Internet => Konqueror Web Browser.
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Figure 5-9. Welcome to Konqueror
When you first launch Konqueror, you will be presented with an Introduction screen. This screen
offers basic instructions for browsing a webpage or your local file system.
If you click Continue, you will be presented with the Tips screen. This screen shows you basic tips
for using Konqueror so that you can begin to take advantage of the features.
By clicking Continue from the Tips screen, you will see the Specifications screen. This screen displays information on supported standards (such as Cascading Stylesheets, plug-ins, and OpenSSL),
featured protocols, and more.
To begin your first Web search, enter a URL in the open field beside Location.
For additional information on using Konqueror, click on Help (on the top menu panel) and then on
Konqueror Handbook.
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Figure 5-10. The Konqueror Handbook

5.4. Galeon
Galeon is a GNOME browser, based on Mozilla. It is only a Web browser. It does not feature email,
newsgroups, or anything other than Web browsing and searching.
To use Galeon, a working installation of Mozilla is required. Galeon uses Mozilla’s rendering engine
to display content. If you cannot run Mozilla, it is doubtful that you would be able to run Galeon.
To launch Galeon, go to Main Menu => Extras => Internet => Galeon.
The first time you launch Galeon, it will take you through the configuration process.
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Figure 5-11. Configuring Galeon
During the initial configuration, you have the option of importing bookmarks from Netscape or
Mozilla, as well as some preference from Netscape if you have been using it as your previous Web
browser.
Once you have finished your configuration of Galeon, the main browser will appear.
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Figure 5-12. Online with Galeon

Tip
Galeon, like Mozilla, also has a navigational tab feature that can help you avoid having your desktop
cluttered with browser windows. Multiple pages can be stored in a single Galeon window, and you
can switch between them by clicking on the each tab. To launch a new Tab, use the [Ctrl]-[T] key
combination or select New Tab from the File menu. The tabbed browsing mode can be configured in
the Tabs page of the Preferences Window.

For additional information or help with Galeon, click Help on the top menu bar. From there, you can
choose to view the Galeon FAQ and Galeon manual.
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Chapter 6.
Email Applications
Email is a very popular way of communicating with others over the Internet. You can use email with
an email client, an application that understands the various email transmission standards and allows
you to send, receive, and read email. Red Hat Linux includes several email applications, including
graphical email clients like Evolution and Mozilla Mail, and text-based clients like Pine and mutt.
All of the email client applications are designed to suit certain types of users; so, you can choose one
with the features that best suits your particular needs.
The purpose of this chapter is to demonstrate how to use some of the popular email applications
included in Red Hat Linux. Since all email clients perform the same basic tasks (send and receive
email), choose the one that is most convenient and easy to use.
This chapter will briefly discuss the following email clients:
•

Evolution

•

KMail

•

Mozilla Mail

•

Text-based email clients

Before you launch an email client, you should have some information from your Internet Service
Provider (ISP) handy so that you can configure the client properly. The following lists a few important
things you may need to know:
Your email address
The email address you will use to send and receive mail. This is usually in the form of yourname@yourisp.net.
Server type for receiving email (POP or IMAP)
In order to receive mail, you must know what type of server your network administrator or ISP
is using. This POP or IMAP address, is usually in the form of mail.someisp.net.
POP, short for Post Office Protocol, is used to send email from a mail server to your email client’s
inbox, the place where incoming email is stored. Most ISP email servers use the POP protocol,
although some can use the newer IMAP (Internet Message Access Protocol).
IMAP, short for Internet Message Access Protocol, is a protocol for retrieving email messages
from your ISP’s email server. IMAP differs from POP in that email from IMAP servers are
stored on the server and stays there even as you download and read your mail, whereas POP mail
is downloaded to your email client directly and does not stay on the server.
Server type for sending email (SMTP)
The Simple Mail Transfer Protocol (SMTP) is a protocol for sending email messages between
servers. Most email systems that send mail over the Internet use SMTP to send messages from
one server to another; the messages can then be retrieved with an email client using either POP
or IMAP. SMTP is also used to send messages from a mail client to a mail server. This is why
you need to specify both the POP or IMAP server and the SMTP server when you configure your
email application.
If you have any questions regarding what information you need, contact your ISP or network administrator. Unless properly configured, you will not be able to make full use of the email clients discussed
in this chapter.
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6.1. Evolution
Evolution is more than just an email client. It provides all of the standard email client features, including powerful mailbox management, user-defined filters, and quick searches. It additionally features
a flexible calendar/scheduler which allows users to create and confirm group meetings and special
events online. Evolution is a full-featured personal and workgroup information management tool for
Linux and UNIX-based systems, and is the default email client for Red Hat Linux.
To launch Evolution from the desktop panel, go to Main Menu => Internet => Email.

Figure 6-1. Evolution Welcome Screen
The first time you start Evolution you will be presented with the Welcome Screen (Figure 6-1),
which allows you to configure your email connection. Follow the on-screen instructions and fill in the
information you collected from your ISP or administrator in the text boxes provided. When you are
done, click Finish, and you will be presented with the Main Screen as shown in Figure 6-2.

Figure 6-2. Evolution Main Screen
To see what is in your inbox or to send an email, click on the Inbox icon.
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Figure 6-3. Evolution Inbox Screen
To compose a mail, select New Message from the toolbar.

Figure 6-4. Evolution New Email Message Screen
Once you have composed a message and entered an email address to send the email to, click Send on
the toolbar.
While Evolution does so much more than read and send email, this chapter focusses exclusively on its
email capabilities. If you would like to learn more about using some of the other features of Evolution,
like calendering/scheduling and group messaging, click Help from the main toolbar and choose the
component you want to learn more about.
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6.2. Mozilla Mail
This section briefly covers the basic steps for sending and receiving email with Mozilla. If you need
further information about using Mozilla Mail, the Mozilla Help contents are located under Help on
the main menu.
To start Mozilla Mail, select Main Menu => Extras Internet => Mozilla Mail.
To open Mozilla Mail while in Mozilla, click on the mail icon near the lower left corner of the
Mozilla screen.

Figure 6-5. Mozilla Mail and News

Figure 6-6. Mozilla Mail New Email Message Screen
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To send an email, click on the Send button or go to File => Send Now or Send Later. If you choose
to send later, you can go back to the main mail screen and go to File => Send unsent messages.
To read email, click on the mail folder you created for yourself to see a list of messages waiting for
you. Then, click on the message you want to read.
Once you read a message, you can delete it, save it to a separate folder, and more.

6.2.1. Mozilla and Newsgroups
Newsgroups are Internet discussion groups with specific topics. The discussions are in threaded format
(which means all topics and responses to the topic are sorted and organized for convenient reading)
and subscribing to a group is very easy. You do not have to post messages if you do not want to; you
can just lurk, which is a Newsgroup term for reading without posting messages. There are a great
many newsgroups on the Web with topics ranging from politics to computer games to random strange
thoughts. You can even post and download pictures and files to Newsgroups (although your ISP may
restrict Newsgroups to text-based postings only).
To join a newsgroup, you first need to set up a newsgroup account. Click on your mail account name
in the sidebar and select Create a new account from the options that appear on the right of the screen.
The New Account Setup screen will appear. Select Newsgroup account and then click Next.

Figure 6-7. Newsgroup Account Setup
Enter your name and email address on the next screen and click Next. On the following screen, enter
the name of your news server (if you do not know the name of your news server, contact your Internet
service provider or network administrator for this information). On the last few screens, you can
determine the name that this account will be referred to and review your settings.
The newsgroup account you created will appear in the sidebar of the Mozilla mail screen. Right-click
on this account name and select Subscribe. A dialog box appears, listing all the newsgroups available.
Select the groups you are interested in reading and click Subscribe. When you are done, click on OK.
Now, click on the arrow next to the newsgroup account name and the list of groups you are subscribed
to will appear beneath. Select the newsgroup you want to access and a dialog box appears with information about downloading and reading existing messages. Posting to a newsgroup is just like writing
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an email, except that the newsgroup name appears in the To field rather than an email address. To
unsubscribe from a newsgroup, right-click on the group name and select Unsubscribe.

6.3. KMail
If you chose a custom installation of Red Hat Linux, your system may have the KMail email client.
KMail is an email tool for KDE, the K Desktop Environment. It has an intuitive graphical interface
similar to Evolution that makes sending and receiving email simpler. To open KMail, click on the
Main Menu => Extras => Internet => KMail.
Before you can really use KMail, you must configure it so it can send and receive mail. To run the
configuration tool, select Settings from the KMail toobar, and click on Configure KMail.
The Configure Mail Client window consists of seven sections: Identity, Network, Appearance,
Composer, Security, and Miscellaneous. To begin sending and receiving messages you will only
have to change the settings in the Identity and Network tabs. Have your email information from
your service provider or administrator handy so that you can fill in the required information to begin
using KMail. For additional information, refer to the KMail user manual (Help => Contents) or visit
KMail’s homepage at http://kmail.kde.org.

Figure 6-8. KMail Main Screen
Once you have your email settings configured, you can begin sending and receiving email. The folders
on the left side of the KMail screen allow you to view emails you have received, emails ready to be
sent, emails you have sent, and more.
To compose a mail, click on the new message icon in the tool bar:
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Figure 6-9. KMail New Email Message Screen
Once you have composed a message and entered an email address to send the email to, click Send in
the toolbar:

6.4. Plain Text Email Clients
Most modern email clients allow the user to select whether they want to send their emails in plain
text or in HTML. The advantage of HTML formatted email is that they can contain graphics and
interactive links to Web sites. The particular font can be specified, the layout is very controllable,
textures, and pictures or backgrounds can be added; all this makes for a visually appealing message
when it gets to the recipient.
On the other hand, plain text email is just that — plain text. They is nothing fancy, there are no pictures
embedded in the email, and there are no special fonts. Plain text emails are simple.
The term plain text refers to textual data in ASCII format. Plain text (also called clear text) is the
most portable format because it is supported by nearly every email application on various types of
machines.
This chapter will discuss two plain text email clients, Pine and mutt.

6.4.1. Using Pine
Pine (acronym for Pine is not elm or Program for Internet News and Email) is a character-based email
client for UNIX systems.
To launch Pine, type pine at a shell prompt. After starting Pine, the Main Menu screen appears.

60

Chapter 6. Email Applications

Figure 6-10. Pine Main Screen
Each Pine screen has a similar layout: the top line tells you the screen name and additional useful
information, below that is the work area (on the Main Menu screen, the work area is a menu of
options), then the message/prompt line, and finally the menu of commands.
From the Main Menu you can choose to read online help, compose and send a message, look at an
index of your mail messages, open or maintain your mail folders, update your address book, configure
Pine, and quit Pine. There are additional options listed at the bottom of the screen as well.
To write a message, press [C] (which is short for Compose). The Compose Message screen will then
appear.

Figure 6-11. Pine Compose Message Screen
Different commands are available to you when your cursor is in different fields on this screen. To see
additional commands available when your cursor is in the Message Text field, type [Ctrl]-[G] (for Get
Help). For example, to move around, use the arrow keys or [Ctrl]-[N] (for Next line) and [Ctrl]-[P]
(for Previous line); to correct typing errors, use [Backspace] or [Delete].
In the command menu shown in Figure 6-11, the ^ character is used to indicate the Control key.
This character means you must hold down the Control ([Ctrl]) key while you press the letter for each
command.
When you want to leave Pine, press [Q] (Quit).
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To view a message in the Message Index screen, use the arrow keys to highlight the message you want
to view. Press [V] (ViewMsg) or press [Enter] to read a selected message. To see the next message,
press [N] (NextMsg). To see the previous message, press [P] (PrevMsg) To return from your message
to the Message Index, press [I] (Index).
For addition help with Pine, refer to the Pine man page. To view this man page, type the command

man pine at a shell prompt.

6.4.2. Using Mutt
Mutt is a small but very powerful text-based mail client for UNIX operating systems.
Mutt’s configuration file, ~/.muttrc. gives mutt its flexibility and configurability. It is also this
file that might give new users problems. The number of options that mutt has available to it are truly
astounding. mutt allows the user to control nearly all of the functions that mutt uses to send, receive,
and read your mail. As is true with all powerful software, it takes time to understand the features and
what they can do for you.
Most of the options are invoked using the set or unset commands, with either boolean or string
values, e.g. set folder = ~/Mail.
All configuration options can be changed at any time by typing a [:] followed by the relevant command. For example :unset help turns off the handy keyboard command hints at the top of the
screen. To turn those hints back on, type :set help.
If you cannot remember the command you want to use, there is always tab-completion to help you.
You do not have to type all your preferred configuration commands each time you run mutt, you can
save them in a file which is loaded every time the program starts up. This configuration file must exist
in your home directory, it has to be named either ~/.muttrc or ~/.mutt/muttrc.
When you launch mutt, the first thing you see is a screen with a list of email messages. This initial
menu is called the index.

Figure 6-12. mutt Main Screen
These messages are in a default mail folder, often called the mailspool, that you can think of as your
inbox. Use the [K] and [J] keys on your keyboard to move the highlighted cursor up and down the list
of messages.
In the index or pager views, use the [R] key to reply to a message or the [M] key to create a new
one. Mutt will prompt for the To: address and the Subject: line. A text editor (defined by your
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$EDITOR environmental variable in the configuration file) will then launch allowing you to compose
your message. Type your message, save your file and exit the editor.
After editing your email, Mutt displays the compose menu, where you can customize your message
headers, change the encoding, add file attachments or simply press the [Y] key to send your email on
its way.
To learn more about mutt, refer to the man pages for muttrc and mutt (type man muttrc or man
mutt at the shell prompt). You may also find the mutt manual to be very helpful. The mutt manual
is installed in /usr/share/doc/mutt-1.2.x , where x is the version number of mutt installed on
your system.

Chapter 7.
Printer Configuration
This chapter provides information on configuring, testing, and modifying a local printer with printconf. For information on configuring other types of printers, creating printer aliases, and more, refer
to the Official Red Hat Linux Customization Guide or click on the Help button once you open the
printconf application.
Red Hat Linux comes with two different printing systems: LPRng and CUPS. LPRng is the default
printing system. It is recommended that new users use the default printing system as described in this
chapter. For information on the CUPS printing system, refer to the Official Red Hat Linux Customization Guide.
To use Printer Configuration Tool, you must have root privileges. To start Printer Configuration
Tool, use one of the following methods:
•

In a graphical desktop environment, click Main Menu => System Settings => Printing.

•

Type the command redhat-config-printer at a shell prompt (for example, in a command-line
terminal window) to start the graphical version.

•

You can also run Printer Configuration Tool as a text-based application if you do not have the
X Window System installed, or if you just prefer the text-based interface. Type the command
/usr/bin/redhat-config-printer from a shell prompt, which will prompt your for your user
password before it continues.

Important
Do not edit the /etc/printcap file. Each time the printer daemon (lpd) is started or restarted, a new
/etc/printcap file is dynamically created.

If you want to add a printer without using the Printer Configuration Tool, edit the
/etc/printcap.local file. The entries in /etc/printcap.local are not displayed in the
Printer Configuration Tool but are read by the printer daemon. If you upgrade your system from a
previous version of Red Hat Linux, your existing configuration file is converted to the new format
used by the Printer Configuration Tool. Each time a new configuration file is generated by the
Printer Configuration Tool, the old file is saved as /etc/printcap.old.

Figure 7-1. Printer Configuration Tool
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This chapter explains local printer configuration only, but five types of print queues can be configured
with the Printer Configuration Tool:
•

Local Printer — a printer attached directly to your computer through a parallel or USB port. In
the main printer list as shown in Figure 7-1, the Queue Type for a local printer is set to LOCAL.

•

Unix Printer (lpd Spool) — a printer attached to a different UNIX system that can be accessed
over a TCP/IP network (or example, a printer attached to another Red Hat Linux system on your
network). In the main printer list as shown in Figure 7-1, the Queue Type for a remote UNIX
printer is set to LPD.

•

Windows Printer (SMB) — a printer attached to a different system which is sharing a printer over
a SMB network (for example, a printer attached to a Microsoft Windows machine). In the main
printer list as shown in Figure 7-1, the Queue Type for a remote Windows printer is set to SMB.

•

Novell Printer (NCP Queue) — a printer attached to a different system which uses Novell’s NetWare network technology. In the main printer list as shown in Figure 7-1, the Queue Type for a
remote Novell printer is set to NCP.

•

JetDirect Printer — a printer connected directly to the network instead of to a computer. In the
main printer list as shown in Figure 7-1, the Queue Type for a JetDirect printer is set to JETDIRECT.

See the Official Red Hat Linux Customization Guide or click on the Printer Configuration Tool Help
button for information on configuring printers other than local.

Important
If you add a new print queue or modify an existing one, you need to restart the printer daemon (lpd)
for the changes to take effect.

Clicking the Apply button saves any changes that you have made and restarts the printer daemon. The
changes are not written to the /etc/printcap configuration file until the printer daemon (lpd) is
restarted. Alternatively, you can choose File => Save Changes and then choose File => Restart lpd
to save your changes and then restart the printer daemon.
If a printer appears in the main printer list with the Queue Type set to INVALID, the printer configuration is missing options that are required for the printer to function properly. To remove this printer
from the list, select it from the list and click the Delete button.

7.1. Adding a Local Printer
To add a local printer such as one attached to the parallel port or USB port of your computer, click the
New button in the main Printer Configuration Tool window. The window shown in Figure 7-2 will
appear. Click Forward to proceed.
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Figure 7-2. Adding a Printer
You will then see the screen shown in Figure 7-3. Enter a unique name for the printer in the Queue
Name text field. This can be any descriptive name for your printer. The printer name cannot contain
spaces and must begin with a letter a through z or A through Z. The valid characters are a through z,
A through Z, 0 through 9, -, and _.
Select Local Printer from the Queue Type menu, and click Forward.

Figure 7-3. Adding a Local Printer
The Printer Configuration Tool attempts to detect your printer device and display it as shown in
Figure 7-4. If your printer device is not shown, click Custom Device. Type the name of your printer
device and click OK to add it to the printer device list. After selecting your printer device, click
Forward.
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Figure 7-4. Choosing a Printer Device
Next, the Printer Configuration Tool will try to detect which printer is attached to the printer device you selected as shown in Figure 7-5. If you are configuring a local printer and the model was
autodetected, the recommended driver is automatically selected and marked with an asterisk (*). If it
detects the wrong printer or does not detect any printer, you can manually select one. The printers are
divided by manufacturers. Click the arrow beside the manufacturer for your printer. Find your printer
from the expanded list, and click the arrow beside the printer name. A list of drivers for your printer
will appear. Select one. If you do not know which one to use, select the first one in the list. If you are
having problems using that driver, edit the printer in printconf and select a different driver.

Figure 7-5. Choosing a Printer Driver
The last step is to confirm your printer. Click Apply if this is the printer that you want to add. Click
Back to modify your printer configuration.
The new printer will appear in the printer list in the main window. Click the Apply button in the
main window to save your changes to the /etc/printcap configuration file and restart the printer
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daemon (lpd). After applying the changes, print a test page to ensure the configuration is correct.
Refer to Section 7.1.1 for details.

7.1.1. Printing a Test Page
After you have configured your printer, you should print a test page to make sure the printer is functioning properly. To print a test page, select the printer that you want to test from the printer list,
and choose Test => Print US Letter Postscript Test Page, Print A4 Postscript Test Page, or Print
ASCII Test Page from the pulldown menu. If your printer does not support PostScript printing, choose
to print the ASCII test page.

7.2. Modifying Existing Printers
To delete an existing printer, select the printer and click the Delete button on the toolbar. The printer
will be removed from the printer list. Click Apply to save the changes and restart the printer daemon.
To set the default printer, select the printer from the printer list and click the Default button on the
toolbar. The default printer icon
printer.

appears in the first column of the printer list beside the default

If you want to modify an imported printer’s settings, you cannot modify its settings directly. You
must override the printer. You can only override an imported printer that has been imported using
the alchemist libraries. Imported printers have the
printer list.

symbol beside them in the first column of the

To override the printer, select the printer, and choose File => Override Queue from the pulldown
menu. After overriding a printer, the original imported printer will have the
the first column of the printer list.

symbol beside it in

After adding your printer(s), you can edit settings by selecting the printer from the printer list and
clicking the Edit button. The tabbed window shown in Figure 7-6 will appear. The window contains
the current values for the printer that you selected to edit. Make any changes, and click OK. Click
Apply in the main Printer Configuration Tool window to save the changes and restart the printer
daemon.
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Figure 7-6. Editing a Printer

7.2.1. Names and Aliases
If you want to rename a printer, change the value of Queue Name in the Names and Aliases tab.
Click OK to return to the main window. The name of the printer should change in the printer list.
Click Apply to save the change and restart the printer daemon.
A printer alias is an alternate name for a printer. To add an alias for an existing printer, click the Add
button in the Name and Aliases tab, enter the name of the alias, and click OK. Click OK again to
return to the main window. Click Apply to save the aliases and restart the printer daemon. A printer
can have more than one alias.

7.2.2. Queue Type
The Queue Type tab shows queue type that you selected when adding the printer and its settings. You
can change the queue type of the printer or just change the settings. After making modifications, click
OK to return to the main window. Click Apply to save the change and restart the printer daemon.
Depending on which queue type you choose, you will see different different options. Refer to the
appropriate section on adding a printer for a description of the options.

7.2.3. Driver
The Driver tab shows which print driver is currently being used. This is the same list that you used
when adding the printer. If you change the print driver, click OK to return to the main window. Click
Apply to save the change and restart the printer daemon.
If you are having problems printing, try selecting a different driver from this list and printing a test
page. Some drivers might work better than others for your printer.
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7.2.4. Driver Options
The Driver Options tab displays advanced printer options. Options vary for each print driver. Common options include:
•

Send Form-Feed (FF) should be selected if the last page of your print job is not ejected from
the printer (for example, the form feed light flashes). If this does not work, try selecting Send
End-of-Transmission (EOT) instead. Some printers require both Send Form-Feed (FF) and Send
End-of-Transmission (EOT) to eject the last page.

•

Send End-of-Transmission (EOT) if sending a form-feed does not work. Refer to Send FF above.

•

Assume Unknown Data is Text should be selected if your print driver does not recognize some
of the data sent to it. Only select it if you are having problems printing. If this option is selected,
the print driver will assume that any data that it can not recognize is text and try to print it as text.
If you select this option and Convert Text to Postscript, the print driver will assume the unknown
data is text and then convert it to PostScript.

•

Prerender Postscript should be selected if you are printing characters beyond the basic ASCII
set but they are not printing correctly (such as Japanese characters). This option will prerender
non-standard PostScript fonts so that they are printed correctly.
If your printer does not support the fonts you are trying to print, try selecting this option. For
example, you should select this option if you are printing Japanese fonts to a non-Japanese printer.
Extra time is required to perform this action. Do not choose it unless you are having problems
printing the correct fonts.

•

Convert Text to Postscript is selected by default. If your printer can print plain text, try unselecting
this when printing plain text documents to decrease the time it takes to print.

•

Page Size allows you to select the paper size for your printer such as US Letter, US Legal, A3, and
A4.

•

Effective Filter Locale defaults to C. If you are printing Japanese characters, select ja_JP. Otherwise, accept the default of C.

If you modify the driver options, click OK to return to the main window. Click Apply to save the
change and restart the printer daemon.
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Chapter 8.
Working with Documents
Red Hat Linux includes several tools for managing all of your documents. Whether you are preparing
for a business or school presentation, writing a formal letter, or opening a document from an email
attachment, Red Hat Linux has a tool that suits your needs.

8.1. The OpenOffice.org Suite
Productivity suites are collections of applications designed to save time and assist users at the office,
at school, and at home. Usually, productivity suites are graphical and include such applications as
word processors, spreadsheets, and presentation utilities. The applications that comprise a productivity suite are integrated — which means that you can, for example, write a document with an embedded
chart created by the spreadsheet application as well as a slide from a graphical presentation application. Integration of the software that make up a productivity suite helps you to give impact to your
presentations, lectures, or printed collateral.
Red Hat Linux includes a powerful business productivity suite called OpenOffice.org, which incorporates several complementary applications into one integrated package. Using OpenOffice.org is
much faster and easier than learning complex tags and code to format your documents and presentations. It allows you complete control over the layout and content of your documents and lets you see
the results as you edit it. This real-time, visual form of document formatting is called what you see is
what you get (or WYSIWYG) editing.

8.1.1. OpenOffice.org Features
The OpenOffice.org suite contains several applications for creating and editing documents, spreadsheets, business presentations, and artwork. It includes templates, forms, and wizards for creating
basic professional documents and presentations quickly. If you have ever worked with or received
.doc or .xls files, you know they are commonly associated with the Microsoft Office suite. The
OpenOffice.org suite is able to read, edit, and create files in several formats, including files which
are commonly associated with Microsoft Office. Table 8-1 shows the many different types of files you
can use and tasks you can accomplish with the OpenOffice.org suite.
Application

File Compatibility

Document Types

OpenOffice.org
Writer

.sxw, .sdw, .doc, .rtf, .txt,
.htm/.html

Formal letters, business forms, school
papers, resumes, newsletters, reports

OpenOffice.org
Calc

.sxc, .dbf, .xls, .sdc, .slk,
.csv, .htm/.html

Spreadsheets, charts, tables, graphs,
directories, address books, receipts
and bills, budgets, small databases

OpenOffice.org
Impress

.sxi, .ppt, .sxd, .sdd

Business and academic presentations,
Web presentations, lectures, slide
shows

OpenOffice.org
Draw

.sxd, .sda; export files to several
Illustrations, line drawings, clip art,
image formats, including .jpg, .bmp, organizational charts
.gif, and .png

Table 8-1. OpenOffice.org Features
As you can see, the OpenOffice.org suite has many file compatibility features, and allows you to
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accomplish several tasks for academic, business, or home use. The following sections will show you
how to use the OpenOffice.org suite.

8.1.2. OpenOffice.org Writer
Writing documents using OpenOffice.org is similar to other word processing applications you may
have used before. A word processor is like a text editor but has several additional features that allow
you to format, design, and print your documents without the need to memorize complex formatting
tags or codes. OpenOffice.org Writer is a powerful word processor that features WYSIWYG formatting — what you see in the OpenOffice.org Writer window is exactly what you will get if you
printed the document or if you gave the document file to someone else for them to view. Figure 8-1
shows OpenOffice.org Writer in action:

Figure 8-1. OpenOffice.org Writer
To start OpenOffice.org Writer from your desktop panel, choose Main Menu => Office => OpenOffice.org Writer; to start it from a shell prompt, type oowriter.
The main interface is the document editing area (the white space in the middle of the window where
you can type your text). At the top of the window are various functions collected into toolbars that
control fonts, letter sizes, justification (to align the text of your document to the left, center, or right
margins), and other text formatting buttons. There is also a text box that enables you to type in the
exact location of a document on your machine and load the document into the editing area. There
are also buttons for opening, saving, and printing documents, as well as buttons for creating new
documents (which will open up a new window with a blank document for you to add content).
Along the left side of the window, there is a toolbar with buttons for checking your spelling, automatic
highlighting of misspelled words, word and phrase searching, and other convenient editing functions.
If you hover over a toolbar button, a pop-up Tip will display a brief explanation of the button’s functionality. You can display more detailed Tips by clicking the Help menu and checking Extended
Tips.
You can immediately begin typing text into the document editing area at any time using the default
settings. To save your text, click the Save button . You can choose the file format from the File type
drop down menu. The default file type is appropriate for files that you are working on exclusively with
OpenOffice.org applications. However, for files that you need to distribute to Microsoft Office users,
or if you are editing a file that was sent as an email attachment with the .doc extension, you can save
the file as a Microsoft Word file type that others will be able to open it in Microsoft Word.
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While OpenOffice.org Writer is useful for general document editing, you can also add objects such
as images, illustrations, charts, and tables to your document to complement your text or give impact
to your documents. To add an image, click Insert => Graphics => From File, and choose the image
from the pop-up file browser. The image will appear where you placed your cursor and can be sized
larger or smaller to fit your needs. Figure 8-2 shows an image added to a document.

Figure 8-2. Adding an Image to Your Document
Once you have created your document, you can save it in any format that you wish. Please consult
Table 8-1 for available file formats. Note that you can also export your document to HTML or PDF
format, formats which can be read by almost every computer with a Web browser or PDF viewer
application (such as xpdf or Adobe Acrobat Reader).

8.1.3. OpenOffice.org Calc
From large enterprises to home offices, professionals in every industry use spreadsheets for keeping
records, creating business charts, and manipulating data. OpenOffice.org Calc is a software spreadsheet application that allows you to enter and manipulate data in cells organized columns and rows.
You can perform calculations on groups of cells (such as adding or subtracting a column of cells) or
create charts based on cell groupings. You can even incorporate spreadsheet data into your documents
for a professional touch.
To start OpenOffice.org Calc from the desktop panel, select Main Menu => Office => OpenOffice.org Calc. To start OpenOffice.org Calc from a shell prompt, type oocalc.
Figure 8-3 shows OpenOffice.org Calc in action.
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Figure 8-3. OpenOffice.org Calc
OpenOffice.org Calc allows you to enter and manipulate personal or business data. For example,
you can create a personal budget by entering data descriptions (such as rent, groceries, and
utilities) into column A and the quantities of those data descriptions in column B. OpenOffice.org Calc allows you to enter the data either in the cell itself by double clicking the cell and
typing your information or by using the Input Line (the text box on the toolbar). Then you can run
arithmetic commands on column B to come up with a total. OpenOffice.org Calc has several preset
functions and calculations (such as =SUM() for addition/multiplication, =quotient() for division,
and =subtotal()for preparing receipts). For detailed information about creating functions for calculating your numerical data in OpenOffice.org Calc, refer to the documentation by selecting Help
=> Contents.
If you need to create charts or graphs for class or business presentations, OpenOffice.org has several
chart and graph templates available to choose from. Highlight the areas you would like to chart, then
click Insert => Chart.... In the Chart window, the data ranges you chose will be shown in the text box
for you to customize further if desired. Click Next to display the many different charts and graphs you
can create using your data. Choose the style you want, and click Create. The graph will be displayed
anchored within the spreadsheet window. You can move it anywhere on the screen for printing, or you
can save the graph as an object that you can then embed in OpenOffice.org Writer documents or
OpenOffice.org Impress presentations.
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Figure 8-4. Creating Charts with OpenOffice.org Calc

8.1.4. OpenOffice.org Impress
Visual aids can give your presentations an added impact that catches your audience’s attention and
keeps them interested. OpenOffice.org Impress is a graphical tool that can help you make a more
convincing presentation.
To start OpenOffice.org Impress from the desktop panel, select Main Menu => Office => OpenOffice.org Impress. To start OpenOffice.org Impress from a shell prompt, type ooimpress.
OpenOffice.org Impress features several AutoPilot features that allow you to create presentations
from a collection of style templates. You can make slides with itemized lists, outlines, or images. You
can even import charts and graphs from OpenOffice.org Calc into a slide.
Figure 8-5 shows OpenOffice.org Impress in action.

Figure 8-5. OpenOffice.org Impress
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When you first start OpenOffice.org Impress, you will be presented with a presentation setup screen,
which will prompt you for basic information about what type of presentation you want to make. You
can choose the style of your slides, the medium with which you will present your slides (plain paper,
transparent paper for overhead projectors, slides, or a display monitor), and any visual effects you
want to apply to the slides during presentations from your computer.

Figure 8-6. OpenOffice.org Impress AutoPilot Wizard
Once you have chosen your preferences with AutoPilot tool, you can choose the type of slide you want
to create. You can select a pre-formatted slide from the list or start with a blank slide and customize
the layout yourself. To create new slides for your presentation, click Insert Slide... in the floating
toolbar, and a pop-up window will appear allowing you to choose the layout of the new slide. You can
have as many slides in your presentation as you need.
You can also preview your presentation at any point by selecting Slide Show => Slide Show from the
pull-down menu. The presentation will be in full screen, which you can exit by cycling through every
slide until you reach the end or by pressing the [Esc] key at any point in the slide show.
Your presentation can be saved in several file formats. You can save in the native OpenOffice.org
Impress format (for example, mypresentation.sxi), the Microsoft PowerPoint format
(mypresentation.ppt), or StarImpress format (mypresentation.sdd). You can also print your
presentation to plain or transparent paper formats by clicking File => Print from the file menu.
To learn more about OpenOffice.org Impress, click Help => Contents form the file menu for the
help browser.

8.1.5. OpenOffice.org Draw
If you would like to create graphics to include in your documents and presentations, you can use
OpenOffice.org Draw. Using your mouse as a you would a pen or a paintbrush, OpenOffice.org
Draw allows you to make illustrations and save them in several formats that you can add to printed
documents, place on websites, or attach to an email.
To start OpenOffice.org Draw from the desktop panel, click Main Menu => Office => OpenOffice.org Draw. To start OpenOffice.org Draw from a shell prompt, type oodraw.
Figure 8-7 Shows OpenOffice.org Draw in action.
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Figure 8-7. OpenOffice.org Draw
If you are familiar with illustration and graphics applications such as The GIMP (refer to Chapter 10
for more information), you will find that OpenOffice.org Draw has some of the same basic functions.
There are toolbars for creating straight and curved lines, basic shapes such as squares and circles, 3D
objects such as cones and cubes, and more. You can create images and fill them with the color of your
choice using the Area Style/Filling drop-down menu on the main toolbar. You can additionally insert
text into your illustrations. OpenOffice.org Draw also allows you to open and import images and
modify them with the tools provided.
When you complete your illustration or image modifications, you can save the file in one of several
native file formats or export your work to a universal format such as .jpg or .png. Refer to Table 8-1
for the complete list of compatible image file formats.

8.2. Viewing PDFs
A PDF (Portable Document Format) file is an electronic image of a document. PDF captures formatting information from a variety of desktop publishing applications, making it possible to send formatted documents and have them appear on the recipient’s monitor or printer as they were intended. To
view a PDF you must have a PDF reader.
An open source application called xpdf is included with Red Hat Linux. To see a list of menu options,
right-click inside the screen. The toolbar at the bottom has navigational tools that let you move backward and forward through the document, as well as standard zoom, print, and find tools. The xpdf
man page provides useful information on the xpdf options. To view the xpdf man page, at a shell
prompt type man xpdf.
To view a PDF with xpdf:
1. In your desktop environment, go to Main Menu => Graphics => xpdf. You can also launch
xpdf by typing xpdf at a shell prompt.
2. Right-click in the xpdf screen to display a list of options.
3. Select Open to display a list of files.
4. Select the PDF file you want to view and click on Open.
Another popular PDF viewer is Adobe Acrobat Reader. While it is not included with Red Hat Linux,
you can download it free of charge at http://www.adobe.com/.
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Chapter 9.
Audio, Video, and General Amusement
This chapter presents you with the lighter side of Red Hat Linux. From games and toys to audio
and video applications, Red Hat Linux provides many packages to let you have some fun with your
computer.

9.1. Playing CDs
To play an audio CD, place the CD in your CD-ROM drive and click Main Menu => Sound & Video
=> CD Player to open the CD Player application.

Figure 9-1. CD Player Interface
The CD Player interface acts like a standard CD player, with play, pause, and stop functions. There
is also a sliding bar that allows you to adjust the volume. You can press the Next track and Previous
Track buttons to skip forward or backward one track; you may also use the Track List drop down
menu to choose a track from the available menu.
You can edit the track listings for your CDs by clicking the Open track editor button. You can also
change the way the utility functions by clicking on the Open Preferences button. Here you can set
themes for the player as well as set the behavior of the CD-ROM drive when you open or quit the CD
Player application.

Figure 9-2. CD Player Preferences

9.2. Playing Digital Music Files
Digital audio has become very popular in recent years. Users enjoy the technology because the sound
quality is excellent compared to analog tape or records and the files are compact, so an audio file can
easily be transferred across the Internet.
To allow you to take advantage of this technology, Red Hat Linux includes the powerful X Multimedia
System (XMMS), a cross-platform multimedia player that allows you to play several digital music file
formats.
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Figure 9-3. XMMS Interface
XMMS can be used for more than just playing digital audio files. By default XMMS can play Ogg
Vorbis, RIFF wave, and most module formats. XMMS can be extended through plugins to play a
number of other digital multimedia formats.
To launch XMMS, go to Main Menu => Sound & Video => XMMS.
To launch XMMS from a shell prompt, type the command xmms.

9.2.1. Using XMMS
To play an audio file with XMMS, click the Open button
window.

and choose a file from the Load File(s)

Figure 9-4. The Load File(s) Window
In Figure 9-4, you see that there are several files to choose from. The files that end in .ogg are Ogg
Vorbis files, a popular new audio file format; the .pls file is an audio playlist file. You can use XMMS
to add audio files into a list and then save it as a playlist. This can be convenient if you have several
audio files and you want to categorize them (for example, by genre or artist). Highlight the file you
wish to play (if you have more than one, you can click and hold the mouse button and drag it over
all of the files you want to open) and click OK. Notice that XMMS begins to play your audio files
immediately. To adjust the volume click the volume slider (the long slider above the Open button) to
the left to lower the volume, and to the right to increase it. There are also buttons to stop, pause, and
skip (backward and forward) your music.
There is so much more you can do with XMMS. To learn more about using XMMS, refer to the man
page by typing man xmms at a shell prompt.

9.3. Troubleshooting Your Sound Card
If, for some reason, you do not hear sound and know that you do have a sound card installed, you can
run the Sound Card Configuration Tool utility.
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To use the Sound Card Configuration Tool, choose Main Menu => System Settings => Soundcard
Detection. A small text box will pop up prompting you for your root password.

Note
Most sound cards are supported by Red Hat Linux, but there are some sound cards that are not
completely compatible or may not work at all. If you are having trouble configuring your sound card,
check the Hardware Compatibility List at http://hardware.redhat.com/ to see if your card is supported.

The Sound Card Configuration Tool utility probes your system for sound cards. If the utility detects
a plug and play sound card, it will automatically try to configure the correct settings for your card.
You can then click the Play test sound button to play a sound sample. If you can hear the sample,
select OK and your sound card configuration is complete.

Figure 9-5. Sound Card Configuration Tool

9.3.1. If Sound Card Configuration Tool Does Not Work
If the Sound Card Configuration Tool does not work (if the sample does not play and you still do not
have audio sounds), there are alternatives, although they are not quite as simple as running the Sound
Card Configuration Tool. You can edit your modules.conf file as discussed below (this strategy is
not recommended for most new users), or refer to the documentation that came with your sound card
for more information.
9.3.1.1. Manual Sound Card Configuration
If your sound card is not a plug and play card, you can manually edit your /etc/modules.conf file
to include the sound card module that it should use, for example:
alias sound sb
alias midi opl3
options opl3 io=0x388
options sb io=0x220 irq=7 dma=0,1 mpu_io=0x300

9.4. Troubleshooting Your Video Card
Video card configuration is handled during the Red Hat Linux installation (see the Official Red Hat
Linux Installation Guide). However, if you did not choose to configure a video card at that time, or if
you need to reconfigure your settings, you can use the X Configuration Tool utility. You will want to
do this, for example, if you install a new video card.
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Note
The X Configuration Tool will backup your system’s original video configuration file to
/etc/X11/XF86Config.backup in case you need it to switch back.

To run the X Configuration Tool, click Main Menu => System Settings => Display. A pop-up
window will prompt you for your root password. You can also start from a shell prompt by typing the
command redhat-config-xfree86, which will then prompt you to input your root password. If
you are working from a shell prompt and X is not working, redhat-config-xfree86 will attempt
to start a minimal X session to allow you to continue your configuration. Follow the instructions that
appear on the screen. X Configuration Tool will attempt to automatically configure your video card
and monitor settings for you. Figure 9-6 shows the Advanced tab for configuring your video devices
manually.

Figure 9-6. X Configuration Tool
To configure your monitor manually, click the Advanced tab, then click the Configure... button next
to the Monitor Type entry. A pop-up window will display a list of monitor models. Choose your
model and click OK. You can also let X Configuration Tool probe your monitor for the correct
model and vertical/horizontal frequency settings.
To configure your video card manually, click the Advanced tab, then click the Configure... button
next to the Video Card entry. A pop-up window will display a list of video card models. Choose your
model and click OK. You can also let X Configuration Tool probe your video card for the correct
model and settings by clicking the Probe Videocard button.
When you have finished reconfiguring your video card and monitor, you should be able to start an X
session and enjoy your graphical desktop environment.

9.5. Games
Playing games under Red Hat Linux is a fun way to pass the time. The games included in Red Hat
Linux appeal to quite a large number of video game enthusiasts. Whether you enjoy card games like
Aisle Riot (a solitaire card game), arcade games like Tux Racer, board games like Chess, or space
shooting games like Chromium and Maelstrom, you can find it in Red Hat Linux.
To start a game, click Main Menu => Games and select the game of your choice. Figure 9-7 shows
a fun game for kids of all ages called Same Gnome. In this game you point your mouse at matching
marbles until they start to spin; then, you can click them to make them disappear. Try to make all the
marbles disappear.
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Figure 9-7. Same Gnome — Match the Marbles Game

9.6. Finding Games Online
There are many more games available within Red Hat Linux and online. For more information, here
are a few suggestions:
•

http://www.evil3d.net/ — A 3D gaming site that covers 3D Linux games in depth.

•

http://www.tuxgames.com — A store where you can buy games just for Linux.

•

http://www.linuxgames.com/ — a Linux gaming news site.

•

http://happypenguin.org/ — the Linux gaming repository.

You can also browse the Internet for linux games using a search engine, such as
http://www.google.com.
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Chapter 10.
Working with Images
There are several types of image files. Some images are created using sophisticated software packages,
while others are made from digital cameras and scanners. You may have downloaded some of these
image files from the Internet or received them in an email. You may also want to create your own
images to send to others. You can view and manipulate the most common types of image files using
the many applications included in Red Hat Linux.

10.1. Viewing Images
This section discusses some of the common tools for viewing image files. Certain tools available are
specialized applications with several functions that enhance your image viewing experience; while
others are general-purpose browsers that have some image viewing functionality.

10.1.1. Using Nautilus to view Images
Nautilus is a general-purpose file manager and browser for your desktop environment. Nautilus has
many functions beyond simple image viewing; however, for this section, we will use it for basic image
browsing. For more information about Nautilus, see Chapter 1.
Nautilus is known for its ease-of-use, and it handles images with the same ease as it does for other file
types. To begin browsing your image collection with Nautilus, double-click on your home desktop
icon:
You will be presented with a view of all the files and folders within your home directory. Double-click
the image (or folder containing the image) and Nautilus will open the new file or folder within its
browser window. Figure 10-1 shows that Nautilus automatically creates thumbnails of any images in
your folders:

Figure 10-1. Contents of a Folder in Nautilus
Double-click on any thumbnail icon to view the image in its native size. The image will load within
the browser window, along with a thumbnail view and detailed file information along the left panel.
Below the file information are advanced options for working with the file. By default, Nautilus offers
you the option of opening the file with Eye of Gnome, a robust image viewer with more advanced
imaging features than Nautilus.
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To increase and decrease the size of the viewed image in Nautilus, click on the magnifying glass icon
on the location bar as shown in Figure 10-2:

Figure 10-2. The Zoom Function in Nautilus
Click the + icon to increase the size of the image or - to decrease it.

10.1.2. Using Konqueror to View Images
You can also use the Konqueror file manager to view images. If you chose KDE as your default desktop environment, click on your home directory desktop icon to access the Konqueror file manager:
Using Konqueror as an image browser works similarly to Nautilus. To configure Konqueror to view
image files within a folder as automatically-generated thumbnail icons, choose View => Preview =>
Images. When you click on a thumbnail icon, the browser displays the image in its native size, as
shown in Figure 10-3.

Figure 10-3. Viewing an Image in Konqueror
To zoom in and out of an image within Konqueror, you first need to change the way it renders the
image. From the top toolbar, choose View => View Mode => KView. This will re-display the image
and allow for zooming in and out using the two magnifying glass icons on the toolbar, as shown in
Figure 10-4.

Figure 10-4. Zooming Buttons in the Konqueror Toolbar
You can also open the image with more advanced image viewers, as well as with the GIMP. Rightclick on the image and choose Open With.... A pop-up menu will appear allowing you to open
the application you wish to use. To launch the GIMP, choose Graphics and scroll down the list
of applications. Click on the GIMP icon and click OK, as seen in Figure 10-5.
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Figure 10-5. The Open With... Dialog Box

10.1.3. Using GQview
GQview is a powerful image viewer for GNOME desktop users that supports several image file formats, including:
•

JPG/JPEG

•

GIF

•

PGM

•

XPM

•

PNG

•

PCX

•

TIF/TIFF

•

PPM

•

BMP

GQview is useful for viewing individual image files as well as browsing collections of files in folders.
It supports zoom in and zoom out functions, as well as thumbnail views of all image files within
a directory. It also supports several advanced options not found in the simple image viewers listed
above.
GQview can be started from your desktop panel. Choose Main Menu => Graphics => GQview to
start the application. If you are at a shell or terminal prompt, start the application by typing gqview.
Upon start-up, GQview will browse your user home directory by default. If you have any images in
this directory, the gallery panel will automatically generate thumbnails for you to highlight and view
in the main display area.
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Figure 10-6. GQview Displaying a .jpg Image
The interface of GQview is straightforward. The toolbar allows you to fit the image to the display
window, zoom in and out and toggle between thumbnail view and text-only browser panels. It also
has a text field for you to enter a particular path to your image directories. Right-clicking on an image
in the display area opens a pop-up menu of image size and other file options such as renaming, moving,
copying. You can also hide and unhide the thumbnail file panel and toggle windowed and fullscreen
modes within the pop-up menu.
You can also combine functions within GQview and create a dynamic presentation effect for groups
of images within a directory. In the text field below the toolbar, type the path to the the directory where
your images are located and highlight the first image in the thumbnail file list panel on the left. Now
press [V] then [S], and you will start a full-screen slideshow where GQview displays images against
a black background over your entire desktop. By default, each image in the slideshow is presented for
15 seconds. You can stop and resume the slideshow at any time by pressing [S]. When the slideshow
ends, press [V] to exit full-screen mode.
GQview can also be used to change your desktop wallpaper quickly and easily. Right-click on the
image and choose Edit => Set as wallpaper. From the Edit menu, you can also choose to open the
file with a number of image editing utilities, including the GIMP, Xview, and Xpaint.
GQview also allows you to customize several settings by clicking the Configure button:
The configuration pop-up menu allows advanced users to configure several options. You can customize a directory on startup, change thumbnail sizes, and even change the default image editors to
manipulate the file if you would like to use one that is not listed.
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Figure 10-7. The GQview Options Dialog Box

10.2. Manipulating Images with the GIMP
The GNU Image Manipulation Program (GIMP) is a powerful tool that can be used to create, alter,
manipulate, and enhance digital image files — photographs, scanned images, computer-generated
images, and more. This section offers a quick overview of the GIMP and refers you to comprehensive
references for learning more about it.

10.2.1. GIMP Basics
To use the GIMP, you will need to know some of the basics. From a shell prompt, you start the
GIMP using the command gimp. Start the GIMP from the desktop panel by choosing Main Menu
=> Graphics => The GIMP.
Figure 10-8 shows a typical GIMP session in action.
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Figure 10-8. The GIMP in Action

10.2.2. Loading a File
To load an existing file, click on File => Open. You will see the Load Image dialog, as shown in
Figure 10-9.

Figure 10-9. The Load Image Dialog
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The Load Image dialog displays your working directory — the directory you were in when the
GIMP was launched. You can navigate up and down the file system tree by double-clicking on the
Directories list on the left, then selecting a file to open from the Files list on the right.
File name completion is supported by the GIMP. If you type the first letter (or more) of a file name
into the Selection field and press the [Tab] key, the view will change to only those subdirectories
and/or files beginning with that letter or letters.
The file you select will appear in the Selection field near the bottom of the dialog. A thumbnail
preview will be displayed on the dialog; alternatively, you will see a Generate Preview button. If you
want to see a thumbnail of the image, click on the Generate Preview button.
Once you have selected a file, click on the OK button to open it. You can also double-click on a file
name to open it.

10.2.3. Saving a File
To save an image file, right click on the image and choose File => Save (or Save as). You will see
the Save Image dialog if you choose Save as or if you choose Save and the file has not been saved
before.
The Save Image dialog looks almost exactly like the Load Image dialog and navigation of the file
system tree and choosing files works in the same way.
When you are saving an image, you will need to choose an image format. The GIMP supports a wide
variety of image formats, including .gif, .png, .jpg, and .bmp.

10.2.4. GIMP Options
Like many applications, the GIMP provides more than one method to accomplish tasks. The easiest
way to work with images is to right-click the image, which will display a set of menus containing
most of the GIMP’s many capabilities, including image sizing, rotation, and filter application.
For example, imagine you have a picture that you would like to modify to make it look as if it were
clipped from a newspaper. To do this, right-click on the image and select Filters => Distorts =>
Newsprint.... Select the quantity of lines per inch using the sliders. When you reach a desired quantity
and are ready to render the image, click OK. The GIMP will then render the image with the new effect
applied. Figure 10-10 shows an example of an image after the Newsprint filter has been applied:

Figure 10-10. An Image modified with a GIMP Filter
The Toolbox also has several easily accessible functions. Using the Toolbox, you can add text to
images, erase regions of an image, or even fill selected regions with the color of your choice.
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For example, if you wish to add text to a file, select the
button and click on your image. This
will load the Text Tool dialog box, where you can choose a font and type some text in the provided
text box. Click OK and your text will be displayed in as a floating section on the image. You can then
move the text to the position you wish using the Move Layers tool. Figure 10-11 shows our photo
with exciting new text:

Figure 10-11. Using the Text Tool on an Image
As you can see, the GIMP is a powerful imaging tool, and it takes some time to master all of the
functions. Try exploring some of the options yourself. If you make a mistake, do not worry. You can
always undo your mistakes by right-clicking on the image and choosing Edit => Undo.

10.3. Additional Resources
While this chapter covers several applications briefly, there is so much more you can do with them.
Refer to the following resources if you are interested in learning more about the applications in this
chapter.

10.3.1. Useful Websites
The Web has several sites of interest if you are looking for more detailed information about an application covered in this chapter:
•

http://gqview.sourceforge.net — The official GQview home page.

•

http://www.gimp.org/ — The official GIMP website.

•

http://www.rru.com/~meo/gimp/faq-user.html — A Frequently Asked Questions (FAQ) list for
questions commonly asked about the GIMP by GIMP users (as opposed to developers).

•

http://manual.gimp.org/manual/ — The GIMP User Manual website.

•

http://gimp-savvy.com/ — The companion website to the book Grokking the GIMP, by Carey
Bunks. The entire book is also available on the site for download!

•

http://tigert.gimp.org/gimp/ — The GIMP website of tigert (Tuomas Kuosmanen).
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10.3.2. Related Documentation
Some applications discussed have online documentation included with the package, accessible right
from your PC.
•

For

more

information

about



using

GQview,



refer

to

is the version of GQview installed on your system).

•

the



documentation

in

/usr/share/doc/gqview- version-number /README (where > version-number



The GIMP manual page contains some of the more advanced command-line options and environment variables associated with it. You can read the manual page by typing man gimp at a shell or
terminal prompt.

If you need in-depth information about the many capabilities of the GIMP, try your favorite bookstore.
The following books were available at the time of this writing:
•

The Artists’ Guide to the GIMP by Michael J. Hammel; Frank Kasper and Associates, Inc.

•

GIMP Essential Reference by Alex Harford; New Riders Publishing

•

GIMP for Linux Bible by Stephanie Cottrell Bryant, et al; Hungry Minds, Inc.

•

GIMP: The Official Handbook by Karin Kylander and Olof S. Kylander; Coriolis Group

•

Grokking the GIMP by Carey Bunks; New Riders Publishing

•

Sams Teach Yourself GIMP in 24 Hours by Joshua and Ramona Pruitt; Sams
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Chapter 11.
Shell Prompt Basics
11.1. Why Use a Shell Prompt
Graphical environments for Linux have come a long way in the past few years. You can be perfectly
productive in the X Window System, and only have to open a shell prompt to complete a few tasks.
However, many Red Hat Linux functions can be completed faster from the shell prompt than from a
GUI. In less time than it might take you to open a file manager, locate a directory, and then create,
delete, or modify files from a GUI, you could have finished your work with just a few commands at a
shell prompt.
A shell prompt looks similar to other command-line interfaces you might be familiar with. Users type
commands at a shell prompt, the shell interprets these commands, and then the shell tells the OS what
to do. Experienced users can write shell scripts to expand their capabilities even further.

Figure 11-1. A Shell Prompt
This section explains how to navigate, manipulate files, perform simple administration tasks, and other
shell prompt basics.

11.2. The History of the Shell
When AT&T software engineers Dennis Ritchie and Ken Thompson were designing UNIX™, they
wanted to create a way for people to interact with their new system.
Operating systems at that time came with command interpreters, which could take commands from
the user and interpret them so that computers could use them.
But Ritchie and Thompson wanted something more, something that offered better features than the
command interpreters available at that time. This lead to the development of the Bourne shell (known
simply as sh), created by S.R. Bourne. Since the creation of the Bourne shell, other shells have been
developed, such as the C shell (csh) and the Korn shell (ksh).
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When the Free Software Foundation sought a royalty-free shell, developers began to work on the
language behind the Bourne shell as well as some of the popular features from other shells available
at the time.
The result was the Bourne Again Shell, or bash. Although your Red Hat Linux includes several
different shells, bash is the default shell for interactive users. You can learn more about bash by
reading the bash man page (type man bash at a shell prompt).

11.3. Determining Your Current Directory with pwd
Once you start looking through directories, it is easy to get lost or forget the name of your current
directory. By default, bash shows just your current directory, not the entire path.

Figure 11-2. The Command pwd Shows You Where You Are
To determine the exact location of your current directory within the file system, go to a shell prompt
and type the command pwd.
You should see something like:
/home/sam

This tells you that you are in the user sam’s directory, which is in the /home directory.
The command pwd stands for print working directory. When you typed pwd, you asked your Linux
system to display your current location. Your system responded by printing the name of the current
directory in the terminal window, also known as the standard output.
You will find that using pwd is very helpful as you learn to navigate your new Linux system.

11.4. Changing Directories with cd
Changing directories is easy as long as you know where you are (your current directory) and how that
relates to where you want to go.
To change directories, use the cd command. Typing this command by itself will always return you to
your home directory; moving to any other directory requires a pathname.
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You can use absolute or relative pathnames. Absolute paths start at the top with / (referred to as root)
and then look down for the requested directory; relative paths look down from your current directory,
wherever that may be. The following directory tree illustrates how cd operates.
/
/directory1
/directory1/directory2
/directory1/directory2/directory3

If you are currently in directory3 and you want to switch to directory1, you need to move up in
the directory tree.
Executing the command
cd directory1

while you are in directory3, will present you with an error message explaining that there is no such
directory. This is because there is no directory1 below directory3.
To move up to directory1, type:
cd /directory1

This is an example of an absolute path. It tells Linux to start at the top (/) and look down until it finds
directory1. A path is absolute if the first character is a /. Otherwise, it is a relative path.
Absolute paths will take you to any directory, from any directory. Relative paths will only take you to
directories below your current one.
Use the following exercise to test what you have learned so far regarding absolute and relative paths.
From your home directory, type the relative path:
cd ../../etc/X11

The command cd .. tells your system to go up to the directory immediately above the one in which
you are currently working. To go up two directories, type the following:
cd ../..

After using the full command in the example, you should be in the directory X11, which is where you
will find configuration files and directories related to the X Window System.
Take a look at your last cd command. You told your system to:
1. Go up one level to your login directory’s parent directory (probably /home)
2. Then go up to that directory’s parent (which is the root, or /, directory)
3. Then go down to the etc directory
4. Finally, go to the X11 directory
Conversely, using an absolute path would get you to the /etc/X11 directory more quickly. For example:
cd /etc/X11

Absolute paths start from the root directory (/) and move down to the directory you specify.
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Note
Always make sure you know which working directory you are in before you state the relative path to
the directory or file you want to get to. You do not have to worry about your position in the file system,
though, when you state the absolute path to another directory or file. If you are not sure, type pwd and
your current working directory will be displayed, which can be your guide for moving up and down
directories using relative pathnames.

Command

Function

cd

returns you to your login directory

cd ~

also returns you to your login directory

cd /

takes you to the entire system’s root directory

cd /root

takes you to the home directory of the root, or superuser,
account created at installation; you must be the root user
to access this directory

cd /home

takes you to the home directory, where user login
directories are usually stored

cd ..

moves you up one directory

cd ~otheruser

takes you to otheruser’s login directory, if otheruser has
granted you permission

cd /dir1/subdirfoo

regardless of which directory you are in, this absolute path
would take you straight to subdirfoo, a subdirectory of

cd ../../dir3/X11

this relative path would take you up two directories to
root, then to dir3, then to the X11 directory.

dir1

Table 11-1. cd Options
Now that you are starting to understand how to change directories, see what happens when you change
to root’s login directory (the superuser account). Type:
cd /root

If you are not logged in as root, you are denied permission to access that directory.
Denying access to the root and other users’ accounts (or login directories) is one way your Linux
system prevents accidental or malicious tampering. See Section 11.14.
To change to the root login and root directory, use the su command. For example:
[sam@halloween sam]$su
Password:your root password
[root@halloween sam]#cd /root
[root@halloween /root]#

Tip
The command su means substitute users and it allows you to temporarily log in as another user.
When you type su by itself and press [Enter], you become root (also called the superuser) while still
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inside your login shell (your user’s home directory). Typing su - makes you become root with root’s
login shell — it is as if you had logged in as root originally.

As soon as you give the root password, you will see the changes in your command prompt to show
your new, superuser status, the root account designation at the front of the prompt and "#" at the end
(as shown in the prior example).
When you are done working as root, type exit at the prompt and you will return to your user account.
[root@halloween /root]#exit
exit
[sam@halloween sam]$

11.5. View Directory Contents with ls
Now that you know how to change directories, it is time to learn how to view the contents of these
directories. Using the ls command, you can display the contents of your current directory.
Many options are available with the ls command. The ls command, by itself, will not show you all
the files in your directory. Some files are hidden files (also called dot files) and can only be seen with
an additional option specified to the ls command.

Tip
To see all the options of the ls command, you can read the man page by typing man ls at a shell
prompt. If you want to print the man page, at the prompt type man ls | col -b | lpr.

Type the command ls -a. Now you will see files that begin with dots.

Figure 11-3. ls with the -a Option
Hidden files are mostly configuration files which set preferences in programs, window managers,
shells, and more. The reason they are hidden is to help prevent any accidental tampering by the user.
When you are searching for something in a directory, you are not usually looking for these configuration files, so keep them hidden to help avoid some screen clutter when viewing directories at the shell
prompt.
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Viewing all the files using the ls -a command can give you plenty of detail, but you can view still
more information, simply by adding more than one option.
If you want to see the size of a file or directory, when it was created and more, just add the long
option (-l) to the ls -a command. This command shows the file creation date, its size, ownership,
permissions, and more.
You do not have to be in the directory whose contents you want to view to use the ls command. For
example, to see what is in the /etc directory from your home directory, type:
ls -al /etc

Figure 11-4. Sample ls Output for the /etc Directory
The following is a short list of some options commonly used with ls. Remember, you can view the
full list by reading the ls man page (man ls).
— all. Lists all the files in the directory, including the hidden files (.filename). The .. and .
at the top of your list refer to the parent directory and the current directory, respectively.

• -a

• -l — long. Lists details about contents, including

permissions (modes), owner, group, size, creation
date, whether the file is a link to somewhere else on the system and where its link points.
— file type. Adds a symbol to the end of each listing. These symbols include / to indicate a
directory; @ to indicate a symbolic link to another file; and * to indicate an executable file.

• -F

• -r

— reverse. Lists the contents of the directory from back to front.

— recursive. This option lists the contents of all directories below the current directory recursively.

• -R

• -S

— size. Sorts files by their size.

11.6. Locating Files and Directories
There will be times when you know a file or directory exists but you will not know where to find it.
Searching for a file or directory can be easier with the locate command.
With locate, you will see every file or directory whose name contains the search criterion. For
example, if you want to search for all files with the word finger in the name, type:
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locate finger

The locate command uses a database to locate files and directories that have the word finger in the
file or directory name. The search results could include a file called finger.txt, a file called pointerfinger.txt, a directory named fingerthumbnails, and so on. To learn more about locate,
read the locate man page (type man locate at a shell prompt).
The locate command works very quickly, as long as the database is up to date. That database is
automatically updated on a nightly basis through a cron job. cron is a small program that runs in the
background, performing various tasks (such as updating the locate database) at regularly scheduled
intervals.

Tip
Cron is a daemon that executes tasks at regularly scheduled intervals. To read the cron man page,
type man cron at the shell prompt.

cron periodically updates the slocate database, which is used to catalog file location. Switching

between operating systems and shutting down your machine at the end of the day can interfere with
the automatic database update run by cron.

To update the database manually, log in as root (type su at a shell prompt and then your root password)
and type the command updatedb.
After a few minutes, the slocate database that is used by the locate command will be current.

Note
You can run anacron to have your system execute commands periodically, with a frequency specified
in days. Unlike cron, it does not assume that the machine is running continuously. Hence, it can be
used on machines that are not running 24 hours a day, to control daily, weekly, and monthly jobs that
are usually controlled by cron.
Refer to the man page on anacron (type man anacron at the command line) for more information.

11.7. Printing From The Command Line
Printing is not an involved process whether you click on a button in a GUI or type commands from
the command line. This section explains how to print, cancel, and view print jobs from the command
line, assuming you have a properly configured printer connected to your system. Refer to Chapter 7
for more information about setting up your printer.
The lpr command, followed by a filename, sends that specified file to the print queue. For example,
lpr foo.txt prints the foo.txt file.
To view the jobs waiting in the print queue, type lpq at the command line. Type lpq, and you will
see information similar to this:
active root

389

foo.txt

In this example, 389 is the job number.
You can cancel jobs in the queue by typing lprm followed by the print job number displayed when
you use the lpq command. To cancel the foo.txt print job, type lprm 389 and press [Enter].
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11.8. Clearing and Resetting the Terminal
After even one ls command in a shell prompt, the terminal window you are working in can begin
to look crowded. You can always exit from the terminal window and open a new one, but there is a
quicker and easier way to clear the contents displayed in the terminal.
Try typing the command clear at the shell prompt. The clear command does just what it implies:
it clears the terminal window.
Sometimes, you may accidentally open a program file or some other non-text file in a terminal window.
Once you close the file, you could find that the text you are typing does not match the output on the
monitor.
In such cases, type reset to return the terminal window to its default values.

11.9. Manipulating Files with cat
Red Hat Linux has a utility which can help you keep short lists, gather lists together, and even show
you information about your system.
The utility is called cat, short for concatenate, which means to combine files.
The command cat will also display the contents of an entire file on the screen (for example, type cat
filename.txt). If the file is fairly long, it will quickly scroll past you on the screen. To prevent this,
use the cat filename.txt | less command.
Using the pipe (|) and the less command together displays the file one page at a time. You can then
use the up and down arrow keys to move backward and forward through the pages. For more on using
pipes to combine two separate functions, see Section 11.10.

11.9.1. Using Redirection
Redirection means causing the shell to change what it considers to be standard input or where the
standard output should be going.





To redirect standard output, use the symbol. Placing after the cat command (or after any utility or
application that writes to standard output) will direct its output to the filename following the symbol.
For example, using cat by itself simply outputs whatever you input to the screen as if it were repeating
the line you just typed. The following example shows cat repeating every line that is entered:
[sam@halloween sam]$cat

buy some sneakers
buy some sneakers
then go to the coffee shop
then go to the coffee shop
then buy some coffee
then buy some coffee

To redirect cat output to a file, type the following at a shell prompt (pressing the [Enter] key takes
you to the next blank line):



sneakers.txt
[sam@halloween sam]$cat
buy some sneakers
then go to the coffee shop
then buy some coffee
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Figure 11-5. Redirecting Output to a File
Press [Enter] to go to an empty line and use the [Ctrl]-[D] keys to quit cat.
Do you notice anything different in Figure 11-5? There are no repeated entries. That is because the
standard output from cat was redirected. That redirection was to a brand new file you made called
sneakers.txt.
You can find the file in the directory you were in when you started cat (type ls if you want to see it
listed).
As you learned earlier, you can then use cat to read the file. At the prompt, type:
cat sneakers.txt

Caution
Be careful when you redirect the output to a file, because you can easily overwrite an existing file!
Make sure the name of the file you are creating does not match the name of a pre-existing file, unless
you want to replace it.

Use output redirection again for another file and call it home.txt. For this example, type the following:
[sam@halloween sam]$cat
bring the coffee home
take off shoes
put on sneakers
make some coffee
relax!

home.txt

Now, on an empty line, use the [Ctrl]-[D] key combination again to quit cat.
Next, use cat to join home.txt with sneakers.txt and redirect the output of both files to a brand
new file called saturday.txt (you will find an example in Figure 11-6). Type the following:
[sam@halloween sam]$cat sneakers.txt home.txt

saturday.txt
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Figure 11-6. Joining Files and Redirecting Output
You can see that cat has added home.txt where sneakers.txt ended.

11.9.2. Appending Standard Output
You can use output redirection to add new information to the end of an existing file. Similar to when
you used the symbol, you tell your shell to send the information somewhere other than standard
output.
However, when you use
of a file entirely.

, you are adding information to a file, rather than replacing the contents

The best explanation is a demonstration. Take two files which have already been created
(sneakers.txt and home.txt) and join them by using the append output symbol. You want to add
the information in home.txt to the information already in sneakers.txt, so type:
cat home.txt

sneakers.txt

Now check the file using the command cat sneakers.txt. The final output shows the contents of

home.txt at the end of the file.

[sam@halloween sam]$cat sneakers.txt
buy some sneakers
then go to the coffee shop
then buy some coffee
bring the coffee home
take off shoes
put on sneakers
make some coffee
relax!
[sam@halloween sam]$

The command you typed told the system to append the output from the file home.txt to the file

sneakers.txt.

By appending the output, you save yourself time (and a bit of disk clutter) by using existing files,
rather than creating a new file.
Compare the results of the files sneakers.txt and saturday.txt now, and you will see that they
are identical. To make your comparison, type:
cat sneakers.txt; cat saturday.txt
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The contents of both files will be displayed — first sneakers.txt, then saturday.txt (as shown
in Figure 11-7).

Figure 11-7. Stringing Commands and Comparing Files

11.9.3. Redirecting Standard Input
Not only can you redirect standard output, you can perform the same type of redirection with standard
input.
When you use the redirect standard input symbol
read as input for a command.



, you are telling the shell that you want a file to be

Use a file you have already created to demonstrate this idea. Just type:
cat



sneakers.txt



Because you used the less-than symbol ( ) to separate the cat command from the file, the output of

sneakers.txt was read by cat.

11.10. Pipes and Pagers
In Linux, pipes connect the standard output of one command to the standard input of another command.
Consider the ls command that was discussed earlier. There are plenty of options available with ls,
but what if the contents of a directory scroll by too quickly for you to view them?
View the contents of the /etc directory.
ls -al /etc

How do you get a closer look at the output before it moves off the screen?
One way is to pipe the output to a utility called less. less is a pager utility that allows you to view
information one page (or screen) at a time.
Use the vertical bar (|) to pipe the commands.
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ls -al /etc | less

Now you can view the contents of /etc one screen at a time. To move forward a screen, press [Space];
to move back a screen, press [B]; to quit, press [Q]. Alternatively, you can use the arrow keys to
navigate with less.

Tip
To read startup messages more closely, at a shell prompt, type dmesg | less. You will be able to
read the file one screen at a time. Use the arrow keys to navigate the file.

Pipes can also be used to print only certain lines from a file. Type:
grep coffee sneakers.txt | lpr

This will print every line in the sneakers.txt file that mentions the word "coffee" (read more about
grep in Section 11.11.3).

11.10.1. The more Command
The main difference between more and less is that less lets you move backward and forward using
the arrow keys, while more uses the [Spacebar] and the [B] key for forward and backward navigation.
List the contents of the /etc directory using ls and more.
ls -al /etc | more

Figure 11-8. Piping Output of ls to more
Use the [Spacebar] to move forward through the pages. Press [q] to exit.
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11.11. More Commands for Reading Text Files
You have already been introduced to several basic shell prompt commands for reading files in text
editors. Here are a few more.

11.11.1. The head Command
You can use the head command to look at the beginning of a file. The command is:
head



filename



head can be a useful command, but because it is limited to the first several lines, you will not see how
long the file actually is. By default, you can only read the first ten lines of a file. You can change the
number of lines displayed by specifying a number option, as shown in the following command:
head -20



filename



11.11.2. The tail Command
The reverse of head is tail. Using tail, you can view the last ten lines of a file.

11.11.3. The grep Command
The grep command is useful for finding specific character strings in a file. For example, if you want
to find every reference made to "coffee" in the file sneakers.txt, you would type:
grep coffee sneakers.txt

You would see every line in that file where the word "coffee" is found.

Tip
Unless otherwise specified, grep searches are case sensitive. That means that searching for Coffee
is different than searching for coffee. So among grep’s options is -i, which allows you to make a
case-insensitive search through a file. Read the grep man page for more about this command.

11.11.4. I/O Redirection and Pipes
You can use pipes and output redirection when you want to store and/or print information to read at a
later time.
You can, for example, use grep to search for particular contents of a file, then have those results either
saved as a file or sent to a printer.
To print the information about references to "coffee" in sneakers.txt, for example, just type:
grep coffee sneakers.txt | lpr
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11.11.5. Wildcards and Regular Expressions
What if you forget the name of the file you are looking for? Using wildcards or regular expressions,
you can perform actions on a file or files without knowing the complete filename. Just fill out what
you know, then substitute the remainder with a wildcard. Wildcards are special symbols that you can
substitute for letters, numbers, and symbols that make finding particular directories and files easier
than examining long directory listings to find what you are searching for.

Tip
To read more about wildcards and regular expressions, take a look at the bash man page (man bash).
bash.txt. Then,
Remember that you can save the file to a text file by typing man bash | col -b
you can open and read the file with less or pico (pico bash.txt). If you want to print the file, be
aware that it is quite long.



We know the file is called "sneak____.txt," so type:
ls sneak*.txt

and there is the name of the file:
sneakers.txt

You will probably use the asterisk (*) most frequently when you are searching. The asterisk will
search out everything that matches the pattern you are looking for. So even by typing:
ls *.txt

or:
ls sn*

You would find sneakers.txt and any other files whose names begin with sn or ends with .txt. It
helps to narrow your search as much as possible.
One way to narrow a search is to use the question mark symbol (?). Like the asterisk, using ? can help
locate a file matching a search pattern.
In this case, though, ? is useful for matching a single character, so if you were searching for
sneaker?.txt, you would get sneakers.txt as a result, and/or sneakerz.txt, if there were
such a filename.
Regular expressions are more complex than the straightforward asterisk or question mark.
When an asterisk, for example, just happens to be part of a filename, as might be the case if the file

sneakers.txt was called sneak*.txt, that is when regular expressions can be useful.

Using the backslash (\), you can specify that you do not want to search out everything by using the
asterisk, but you are instead looking for a file with an asterisk in the name.
If the file is called sneak*.txt, type:
sneak\*.txt

Here is a brief list of wildcards and regular expressions:
• *

— Matches all characters

• ?

— Matches one character in a string (such as sneaker?.txt)
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— Matches the * character

• \?

— Matches the ? character

• \)

— Matches the ) character

11.12. Command History and Tab Completion
It does not take long before the thought of typing the same command over and over becomes unappealing. One minor typing error can ruin lines of a command.
One solution is to use the command line history. By scrolling with the [Up Arrow] and [Down Arrow]
keys, you can find plenty of your previously typed commands.
Try it by taking a look again at sneakers.txt (created in Section 11.9.1. The first time, however, at
the shell prompt, type:
cat sneakrs.txt

Nothing happens, of course, because there is no sneakrs.txt file. No problem. We will just use the
up-arrow key to bring back the command, then use the left-arrow key to get to the point where we
missed the "e." Insert the letter and press [Enter] again.
We now see the contents of sneakers.txt.
By default, up to 500 commands can be stored in the bash command line history file.

Tip
By typing the env command at a shell prompt, we can see the environment variable that controls
the size of the command line history. The line which reads, HISTFILESIZE=500 shows the number of
commands that bash will store.

The command line history is actually kept in a file, called .bash_history in our login directory. We
can read it in a number of ways: by using pico, cat, less, more, and others.
Be aware that the file can be long. To read it with the more command, from your home directory type:
more .bash_history

To move forward a screen, press [Space]; to move back a screen, press [b]; to quit, press [q].

Tip
To find a command in your history file without having to keep hitting the arrow keys or page through
the history file, use grep, a powerful search utility (see Section 11.11.3. Here is how you can quickly
find a previously used command: say you are searching for a command that is similar to cat sneaksomething. You have used the command and you think it might be in your history file. At the shell
prompt, type:
history | grep sneak

Another time-saving tool is known as command completion. If you type part of a file, command, or
pathname and then press the [Tab] key, bash will present you with either the remaining portion of the
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file/path, or a beep (if sound is enabled on your system). If you get a beep, just press [Tab] again to
obtain a list of the files/paths that match what has been typed so far.
For example, if you forget the command updatedb, but remember a portion of the command, you
can su to root, then at the shell prompt, type up, press the [Tab] key twice and you will see a list
of possible completions, including updatedb and uptime. By typing the partial command upd and
pressing [Tab] again, your command is completed for you.

11.13. Using Multiple Commands
Linux allows you to enter multiple commands at one time. The only requirement is that you separate
the commands with a semicolon (you can see an example in Figure 11-7).
Want to see how long you have been online? Just combine the date command with Mozilla’s command.
date; mozilla; date

Remember that commands are case sensitive, so the command to start Mozilla must be in lowercase
to start the browser.
[sam@halloween sam]$date; mozilla; date
Mon Feb 7 13:26:27 EST 2000
Mon Feb 7 14:28:32 EST 2000
[sam@halloween sam]$

Running the combination of commands prints out the time and date, starts Mozilla, and then prints
the time and date again after you close Mozilla. The discrepancy between the two results from the
date command shows that you were using Mozilla for just over an hour.

11.14. Ownership and Permissions
Earlier in this chapter, when you tried to cd to root’s login directory, you received the following
message:
[sam@halloween sam]$cd /root
bash: /root: Permission denied
[sam@halloween sam]$

That was one demonstration of Linux’s security features. Linux, like UNIX, is a multi-user system,
and file permissions are one way the system protects against malicious tampering.
One way to gain entry when you are denied permission is to su to root, as you learned earlier. This is
because whoever knows the root password has complete access.
[sam@halloween sam]$su
Password: your root password
[root@localhost sam]#cd /root
[root@localhost /root]#

But switching to superuser is not always convenient or recommended, since it is easy to make mistakes
and alter important configuration files as superuser.
All files and directories are "owned" by the person who created them. You created the file sneak-

ers.txt (see Section 11.9.1) in your login directory, so sneakers.txt belongs to you.
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That means you can specify who is allowed to read the file, write to the file, or (if it is an application
instead of a text file) who can execute the file.
Reading, writing, and executing are the three main settings in permissions. Since users are placed into
a group when their accounts are created, you can also specify whether certain groups can read, write
to, or execute a file.
Take a closer look at sneakers.txt with the ls command using the -l (long) option (see Figure
11-9).
[sam@halloween sam]$ls -l sneakers.txt
-rw-rw-r-1 sam sam
150 Mar 19 08:08 sneakers.txt

There is a lot of detail provided here. You can see who can read (r) and write to (w) the file, as well as
who created the file (sam), and to which group the owner belongs (sam). Remember that, by default,
the name of your group is the same as your login name.

Figure 11-9. Permissions for sneakers.txt
Other information to the right of the group includes file size, date and time of file creation, and file
name.
The first column shows current permissions; it has ten slots. The first slot represents the type of file.
The remaining nine slots are actually three sets of permissions for three different categories of users.
-rw-rw-r--

Those three sets are: the owner of the file, the group in which the file belongs, and "others," meaning
users and groups not yet specified.
(rw-)
|
|
type owner

(rw-)
|
group

(r--) 1 sam sam
|
others

The first item, which specifies the file type, can show one of the following:
• d

— a directory

• -(dash)
• l

— a regular file (rather than directory or link)

— a symbolic link to another program or file elsewhere on the system
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Beyond the first item, in the following three sets, you will see one of the following:
• r

— file can be read

• w

— file can be written to

• x

— file can be executed (if it is a program)

When you see a dash in owner, group, or others, it means that particular permission has not been
granted. Look again at the first column of sneakers.txt and identify its permissions.
[sam@halloween sam]$ls -l sneakers.txt
-rw-rw-r-1 sam sam
150 Mar 19 08:08 sneakers.txt
[sam@halloween sam]$

The file’s owner (in this case, sam) has permission to read and write to the file. The group, sam, has
permission to read and write to sneakers.txt, as well. It is not a program, so neither the owner or
the group has permission to execute it.

11.14.1. The chmod Command
Use the chmod command to change permissions easily. This example shows how to change the permissions on sneakers.txt with the chmod command.
The original file looks like this, with its initial permissions settings:
-rw-rw-r--

1 sam sam

150 Mar 19 08:08 sneakers.txt

If you are the owner of the file or are logged into the root account you can change any permissions for
the owner, group, and others.
Right now, the owner and group can read and write to the file. Anyone outside of the group can only
read the file (r--).

Caution
Remember that file permissions are a security feature. Whenever you allow anyone else to read, write
to, and execute files, you are increasing the risk of files being tampered with, altered, or deleted. As
a rule, you should only grant read and write permissions to those who truly need them.

In the following example, you want to allow everyone to write to the file, so they can read it, write
notes in it, and save it. That means you will have to change the "others" section of the file permissions.
Take a look at the file first. At the shell prompt, type:
ls -l sneakers.txt

The previous command displays this file information:
-rw-rw-r--

1 sam sam

150 Mar 19 08:08 sneakers.txt

Now, type the following:
chmod o+w sneakers.txt

The o+w command tells the system you want to give others write permission to the file sneakers.txt. To check the results, list the file’s details again. Now, the file looks like this:
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-rw-rw-rw-

1 sam sam
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150 Mar 19 08:08 sneakers.txt

Now, everyone can read and write to the file (Figure 11-10).

Figure 11-10. Changing Permissions for sneakers.txt
To remove read and write permissions from sneakers.txt use the chmod command to take away
both the read and write permissions.
chmod go-rw sneakers.txt

By typing go-rw, you are telling the system to remove read and write permissions for the group and
for others from the file sneakers.txt.
The result will look like this:
-rw-------

1 sam sam

150 Mar 19 08:08 sneakers.txt

Think of these settings as a kind of shorthand when you want to change permissions with chmod,
because all you really have to do is remember a few symbols and letters with the chmod command.
Here is a list of what the shorthand represents:
Identities
u — the user who owns the file (that is, the owner)
g — the group to which the user belongs
o — others (not the owner or the owner’s group)
a — everyone or all (u, g, and o)

Permissions
r — read access
w — write access
x — execute access

Actions
+ — adds the permission
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- — removes the permission
= — makes it the only permission

Want to test your permissions skills? Remove all permissions from sneakers.txt — for everyone.
chmod a-rwx sneakers.txt

Now, see if you can read the file:
[sam@halloween sam]$ cat sneakers.txt
cat: sneakers.txt: Permission denied
[sam@halloween sam]$

Removing all permissions, including your own, successfully locked the file. But since the file belongs
to you, you can always change its permissions back (see Figure 11-11).
[sam@halloween sam]$ chmod u+rw sneakers.txt
[sam@halloween sam]$ cat sneakers.txt
buy some sneakers
then go to the coffee shop
then buy some coffee
bring the coffee home
take off shoes
put on sneakers
make some coffee
relax!
[sam@halloween sam]$

Figure 11-11. Removing and Restoring Permissions
Here are some common examples of settings that can be used with chmod:
• g+w

— adds write access for the group

• o-rwx
• u+x

— removes all permissions for others

— allows the file owner to execute the file

• a+rw

— allows everyone to read and write to the file
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• ug+r

— allows the owner and group to read the file

• g=rx

— lets the group only read and execute (not write)

By adding the -R option, you can change permissions for entire directory trees.
Because you can not really "execute" a directory as you would an application, when you add or remove
execute permission for a directory, you are really allowing (or denying) permission to search through
that directory.
To allow everyone read and write access to every file in the example directory tigger, type:
chmod -R a+rw tigger

If you do not allow others to have execute permission to tigger, it will not matter who has read or
write access. No one will be able to get into the directory unless they know the exact filename they
want.
For example, type:
chmod a-x tigger

to remove everyone’s execute permissions.
Here is what happens now when you try to cd to into tigger:
[sam@halloween sam]$cd tigger
bash: tigger: Permission denied
[sam@halloween sam]$

Next, restore your own and your group’s access.
chmod ug+x tigger

Now, if you check your work with ls -dl you will see that only others will be denied access to the

tigger directory.

11.14.2. Changing Permissions With Numbers
Remember the reference to the shorthand method of chmod? Here is another way to change permissions, although it may seem a little complex at first.
Go back to the original permissions for sneakers.txt (type ls -l sneakers.txt ).
-rw-rw-r--

1 sam sam

150 Mar 19 08:08 sneakers.txt

Each permission setting can be represented by a numerical value:
•

r=4

•

w=2

•

x=1

•

-=0

When these values are added together, the total is used to set specific permissions. For example, if you
want read and write permissions, you would have a value of 6; 4 (read) + 2 (write) = 6.
For sneakers.txt, here are the numerical permissions settings:
-

(rw-)

(rw-)

(r--)
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|
4+2+0

|
4+2+0

|
4+0+0

The total for the user is six, the total for the group is six, and the total for others is four. The permissions
setting is read as 664.
If you want to change sneakers.txt so those in your group will not have write access, but can still
read the file, remove the access by subtracting two (2) from that set of numbers.
The numerical values, then, would become six, four, and four (644).
To implement these new settings, type:
chmod 644 sneakers.txt

Now verify the changes by listing the file. Type:
ls -l
sneakers.txt

The output should be:
-rw-r--r--

1 sam sam

150 Mar 19 08:08 sneakers.txt

Now, neither the group nor others have write permission to sneakers.txt. To return the group’s
write access for the file, add the value of w (2) to the second set of permissions.
chmod 664 sneakers.txt

Warning
Setting permissions to 666 will allow everyone to read and write to a file or directory. Setting permissions to 777 allows everyone read, write, and execute permission. These permissions could allow
tampering with sensitive files, so in general, it is not a good idea to use these settings.

Here is a list of some common settings, numerical values and their meanings:
• -rw-------

(600) — Only the owner has read and write permissions.

• -rw-r--r--

(644) — Only the owner has read and write permissions; the group and others have

• -rwx------

(700) — Only the owner has read, write and execute permissions.

read only.

(755) — The owner has read, write and execute permissions; the group and others
have only read and execute.

• -rwxr-xr-x

(711) — The owner has read, write and execute permissions; the group and others
have only execute.

• -rwx--x--x

• -rw-rw-rw- (666)

— Everyone can read and write to the file. (Be careful with these permissions.)

(777) — Everyone can read, write, and execute. (Again, this permissions setting can
be hazardous.)

• -rwxrwxrwx

Here are some common settings for directories:
• drwx------

(700) — Only the user can read, write in this directory.
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• drwxr-xr-x (755)

user.
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— Everyone can read the directory, but its contents can only be changed by the
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Chapter 12.
Managing Files and Directories
Your desktop file manager is a powerful and important tool for managing files and directories using a
graphical interface. This chapter discusses various shell prompt commands that can be used to manage
files and directories on your Red Hat Linux system. This chapter also discusses compression tools to
create archives of your files for backups, or to send to others conveniently.

Note
Due to system security, unless you are root, you will not be able to gain access to all system-level files
and directories. If you do not have the permission to open, delete, or execute a file, you will receive
an error message saying your access is denied. This is normal behavior and is used to prevent
non-priveleged users from deleting important system files.

12.1. A Larger Picture of the File System
Every operating system has a method of storing data in files and directories so that it can keep track
of additions, modifications, and other changes.
In Linux, every file is stored in a directory. Directories can also contain directories; these subdirectories can also contain files and other subdirectories.
You might think of the file system as a tree-like structure, in which directories branch off . These
directories may contain, or be the "parent" of, other directories which may hold files and directories
of their own.
There would not be a tree without a root, and the same is true for the Linux file system. No matter how
far away the directories branch, everything is connected to the root directory, which is represented as
a single forward slash (/).

Tip
Red Hat Linux uses the term root in several different ways, which might be confusing to new users.
There is the root account (the superuser, who has permission to do anything), the root account’s
home directory (/root) and the root directory for the entire file system (/). When you are speaking
to someone and using the term root, be sure you know which root you are talking about.

Unless you are a system administrator or have root (super user) access, you probably do not have
permission to write to the files and directories outside of your home directory. Certain directories are
reserved for specific purposes. For example, /home is the default location for users’ home directories.
Users that are not system administrators might find the following directories useful for finding their
home directories, reading documentation, or storing temporary files.
— Default location for users’ home directories. For example, a user with the username foo
has the home directory /home/foo.

• /home

— Location of documentation for installed packages. For example, the documentation for the dateconfig software package is located in /usr/share/doc/dateconfigversion-number .

• /usr/share/doc
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— The reserved directory for all users to store temporary files. Files stored here are not
permanent. A system process removes old files from this directory on a periodic basis. Do not write
any files or directories that you want to keep here.

• /tmp

Your Red Hat Linux system is compatible with many other Linux distributions because of the Filesystem Hierarchy Standard (FHS). The FHS guidelines help to standardize the way system programs and
files are stored on all Linux systems.
To learn more about the FHS, refer to the Official Red Hat Linux Reference Guide Reference Guide.
You can also visit the FHS website: http://www.pathname.com/fhs.

12.2. Identifying and Working with File Types
If you are new to Linux, you may see files with extensions you do not recognize. A file’s extension
is the last part of a file’s name after the final dot (in the file sneakers.txt, "txt" is that file’s
extension).
Here is a brief listing of file extensions and their meanings:

12.2.1. Compressed and Archived Files
• .bz2
• .gz

— a file compressed with bzip2

— a file compressed with gzip

• .tar

— a file archived with tar (short for tape archive), also known as a tar file

• .tbz

— a tarred and bzipped file

• .tgz

— a tarred and gzipped file.

For information on working with bzip2, gzip, and tar files, refer to Section 12.3.

12.2.2. File Formats
• .au

— an audio file

• .gif

— a GIF image file

• .html/.htm
• .jpg

— an HTML file

— a JPEG image file

• .pdf

— an electronic image of a document; PDF stands for Portable Document Format

• .png

— a PNG image file (short for Portable Network Graphic)

• .ps

— a PostScript file; formatted for printing

• .txt

— a plain ASCII text file

• .wav

— an audio file

• .xpm

— an image file
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12.2.3. System Files
• .conf
• .lock
• .rpm

— a configuration file
— a lock file; determines whether a program or device is in use
— a Red Hat Package Manager file used to install software

12.2.4. Programming and Scripting Files
• .c

— a C program language source code file

• .cpp

— a C++ program language source code file

• .h

— a C or C++ program language header file

• .o

— a program object file

• .pl

— a Perl script

• .so

— a library file

• .tcl

— a TCL script

But file extensions are not always used, or used consistently. So what happens when a file does not
have an extension, or the file does not seem to be what the extension says it is supposed to be?
That is when the file command can be helpful.
For instance, you find a file called saturday without an extension. Using the file command, you
can tell what type of file it is by typing:
file saturday

In the example, the command file saturday will display ASCII text, telling you it is a text file.
Any file that is designated as a text file should be readable using the cat, more, or less commands,
or using a text editor.

Tip
To learn more about file, read the man page by typing man file.

For more information on helpful commands for reading files, see Chapter 11.

12.3. File Compression and Archiving
Sometimes it is useful to store a group of files in one file so that they can be backed up, easily
transferred to another directory, or even transferred to a different computer. It is also sometimes useful
to compress files into one file so that they use less disk space and download faster.
It is important to understand the distinction between an archive file and a compressed file. An archive
file is a collection of files and directories that are stored in one file. The archive file is not compressed
— it uses the same amount of disk space as all the individual files and directories combined. A
compressed file is a collection of files and directories that are stored in one file and stored in a way that
uses less disk space than all the individual files and directories combined. If you do not have enough
disk space on your computer, you can compress files that you do not use very often or files that you
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want to save but do not use anymore. You can even create an archive file and then compress it to save
disk space.

Note
An archive file is not compressed, but a compressed file can be an archive file.

12.3.1. Using File Roller
Red Hat Linux includes a graphical utility called File Roller that can compress, decompress, and
archive files and directories. File Roller supports common UNIX and Linux file compression and
archiving formats, and has a simple interface and extensive help documentation if you need it. It
is also integrated into the desktop environment and graphical file manager to make working with
archived files easier.
To start File Roller click Main Menu => Accessories => Archive Manager. You can also start File
Roller from a shell prompt by typing file-roller. Figure 12-1 shows File Roller in action.

Tip
If you using a file manager (such as Nautilus), you can simply double-click the file you wish to
unarchive or decompress to start File Roller. The File Roller browser window will appear with the
decompressed/unarchived file in a folder for you to extract or browse.

Figure 12-1. File Roller in Action
12.3.1.1. Decompressing and Unarchiving with File Roller
To unarchive and/or decompress a file, click the Open toolbar button. A file menu will pop up, allowing you to choose the archive you wish to work with. For example, if you have a file called
foo.tar.gz located in your home directory, highlight the file and click OK. The file will appear
in the main File Roller browser window as a folder, which you can navigate by double-clicking the
folder icon. File Roller preserves all directory and subdirectory hierarchies, which is convenient if
you are looking for a particular file in the archive. You can extract individual files or entire archives
by clicking the Extract button, choosing the directory you would like to save the unarchived files, and
clicking OK.
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12.3.1.2. Creating Archives with File Roller
If you need to free some hard drive space, or send multiple files or a directory of files to another user
over email, File Roller allows you to create archives of your files and directories. To create a new
archive, click New on the toolbar. A file browser will pop up, allowing you to specify an archive name
and the compression technique (you can usually leave this set as Automatic and simply type in the
file archive name and file name extension in the provided text box). Click OK and your new archive
is now ready to be filled with files and directories. To add files to your new archive, click Add, which
will pop up a browser window (Figure 12-2) that you can navigate to find the file or directory you
want to be in the archive. Click OK when you are finished, and Close to close the archive.

Figure 12-2. Creating an Archive with File Roller

Tip
There is much more you can do with File Roller than is explained here. Refer to the File Roller
manual (available by clicking Help => Manual) for more information.

12.3.2. Compressing Files at the Shell Prompt
Compressed files use less disk space and download faster than large, uncompressed files. In Red Hat
Linux you can compress files with the compression tools gzip, bzip2, or zip.
The bzip2 compression tool is recommended because it provides the most compression and is found
on most UNIX-like operating systems. The gzip compression tool can also be found on most UNIXlike operating systems. If you need to transfer files between Linux and other operating system such
as MS Windows, you should use zip because it is more commonly used on those other operating
systems.
Compression Tool

File
Extension

Uncompression Tool

gzip

.gz

gunzip

bzip2

.bz2

bunzip2

zip

.zip

unzip
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Table 12-1. Compression Tools
By convention, files compressed with gzip are given the extension .gz, files compressed with bzip2
are given the extension .bz2, and files compressed with zip are given the extension .zip.
Files compressed with gzip are uncompressed with gunzip, files compressed with bzip2 are uncompressed with bunzip2, and files compressed with zip are uncompressed with unzip.
12.3.2.1. Bzip2 and Bunzip2
To use bzip2 to compress a file, type the following command at a shell prompt:
bzip2 filename

The file will be compressed and saved as filename.bz2.
To expand the compressed file, type the following command:
bunzip2 filename.bz2

The filename.bz2 is deleted and replaced with filename.
You can use bzip2 to compress multiple files and directories at the same time by listing them with a
space between each one:
bzip2 filename.bz2 file1 file2 file3 /usr/work/school

The above command compresses file1, file2, file3, and the contents of the
/usr/work/school directory (assuming this directory exists) and places them in a file named
filename.bz2.

Tip
For more information, type man bzip2 and man bunzip2 at a shell prompt to read the man pages for

bzip2 and bunzip2.

12.3.2.2. Gzip and Gunzip
To use gzip to compress a file, type the following command at a shell prompt:
gzip filename

The file will be compressed and saved as filename.gz.
To expand the compressed file, type the following command:
gunzip filename.gz

The filename.gz is deleted and replaced with filename.
You can use gzip to compress multiple files and directories at the same time by listing them with a
space between each one:
gzip -r filename.gz file1 file2 file3 /usr/work/school
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The above command compresses file1, file2, file3, and the contents of the
/usr/work/school directory (assuming this directory exists) and places them in a file named
filename.gz.

Tip
For more information, type man gzip and man gunzip at a shell prompt to read the man pages for

gzip and gunzip.

12.3.2.3. Zip and Unzip
To compress a file with zip, type the following command:
zip -r filename.zip filesdir

In this example, filename.zip represents the file you are creating and filesdir represents the
directory you want to put in the new zip file. The -r option specifies that you want to include all files
contained in the filesdir directory recursively.
To extract the contents of a zip file, type the following command:
unzip filename.zip

You can use zip to compress multiple files and directories at the same time by listing them with a
space between each one:
zip -r filename.zip file1 file2 file3 /usr/work/school

The above command compresses file1, file2, file3, and the contents of the
/usr/work/school directory (assuming this directory exists) and places them in a file named
filename.zip.

Tip
For more information, type man zip and man unzip at a shell prompt to read the man pages for zip
and unzip.

12.3.3. Archiving Files at the Shell Prompt
A tar file is a collection of several files and/or directories in one file. This is a good way to create
backups and archives.
Some of the options used with the tar are:
• -c

— create a new archive.

— when used with the -c option, use the filename specified for the creation of the tar file;
when used with the -x option, unarchive the specified file.

• -f

• -t

— show the list of files in the tar file.
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• -v

— show the progress of the files being archived.

• -x

— extract files from an archive.

• -z

— compress the tar file with gzip.

• -j

— compress the tar file with bzip2.

To create a tar file, type:
tar -cvf filename.tar files/directories

In this example, filename.tar represents the file you are creating and files/directories represents the files or directories you want to put in the archived file.
You can tar multiple files and directories at the same time by listing them with a space between each
one:
tar -cvf filename.tar /home/mine/work /home/mine/school

The above command places all the files in the work and the school subdirectories of /home/mine
in a new file called filename.tar in the current directory.
To list the contents of a tar file, type:
tar -tvf filename.tar

To extract the contents of a tar file, type:
tar -xvf filename.tar

This command does not remove the tar file, but it places copies of its contents in the current working
directory.
Remember, the tar command does not compress the files by default. To create a tarred and bzipped
compressed file, use the -j option:
tar -cjvf filename.tbz

tar files compressed with bzip2 are conventionally given the extension .tbz.

This command creates an archive file and then compresses it as the file filename.tbz. If you uncompress the filename.tbz file with the bunzip2 command, the filename.tbz file is removed
and replaced with filename.tar.
You can also expand and unarchive a bzip tar file in one command:
tar -xjvf filename.tbz

To create a tarred and gzipped compressed file, use the -z option:
tar -czvf filename.tgz

tar files compressed with gzip are conventionally given the extension .tgz.

This command creates the archive file filename.tar and then compresses it as the file filename.tgz. (The file filename.tar is not saved.) If you uncompress the filename.tgz file with
the gunzip command, the filename.tgz file is removed and replaced with filename.tar.
You can expand a gzip tar file in one command:
tar -xzvf filename.tgz
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Tip
Type the command man tar for more information about the tar command.

12.4. Manipulating Files at the Shell Prompt
Files can be manipulated quite easily using one of the graphical file managers, such as Nautilus or
Konqueror. They can also be manipulated using a shell prompt, which is often faster. This section
explains how to manipulate files at the shell prompt.

12.4.1. Creating Files
You can create new files either with applications (such as text editors) or by using the command
touch, which will create an empty file that you can use to add text or data. To create a file with
touch, type the following at a shell prompt.
touch



filename






Replace filename with the name of your choice. If you run a directory listing that the file
contains zero (0) bytes of information because it is an empty file.
[sam@halloween]ls -l newfile

-rw-rw-r--

1 sam

sam

0 Apr 10 17:09 newfile

12.4.2. Copying Files
Like so many other Linux features, there is a variety of ways to manipulate files and directories. You
can also use wildcards, as explained in Section 11.11.5, to make the process of copying, moving, or
deleting multiple files and directories faster.
To copy a file, type the following command.
cp



source





destination





Replace source with the name of the file you want to copy, and
name of the directory where you want the file to go.



destination



with the

So, to copy the file sneakers.txt to the directory tigger/ in your home directory, move to your
home directory and type:
cp sneakers.txt tigger/

You can use both relative and absolute pathnames with cp. Our home directory is the parent of the
directory tigger; tigger is one directory down from our home directory.
Read the cp man page (type man cp at the shell prompt) for a full list of the options available with
cp. Among the options you can use with cp are the following:
— interactive. Prompts you to confirm if the file is going to overwrite a file in your destination.
This is a handy option because it can help prevent you from making mistakes.

• -i

— recursive. Rather than just copying all the specified files and directories, this will copy the
whole directory tree, subdirectories and all.

• -r
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— verbose. Shows the progress of the files as they are being copied.

Now that you have the file sneakers.txt in the tigger directory, use cp -i to copy the file again
to the same location.
[newuser@localhost newuser]$ cp -i sneakers.txt tigger
cp: overwrite ’tigger/sneakers.txt’?

To overwrite the file that is already there, press [Y] and then [Enter]. If you do not want to overwrite
the file, press [N] and [Enter].

12.4.3. Moving Files
To move files, use the mv command. For more about mv, see the mv man page (type man mv).
Common options for mv include the following:
— interactive. This will prompt you if the file you have selected will overwrite an existing file
in the destination directory. This is a good option, because like the -i option for cp, you will be
given the chance to make sure you want to replace an existing file.

• -i

— force. Overrides the interactive mode and moves without prompting. Unless you know what
you are doing, this option is dangerous; be very careful about using it until you become more
comfortable with your system.

• -f

• -v

— verbose. Shows the progress of the files as they are being moved.

If you want to move a file out of your home directory and into another existing directory, type the
following (you will need to be in your home directory):
mv sneakers.txt tigger

Alternatively, the same command using absolute pathnames looks like mv sneakers.txt

/home/newuser /home/newuser/tigger.

12.4.4. Deleting Files and Directories
You learned about creating files with the touch command, and you created the directory tigger
using mkdir.
Now you need to learn how to delete files and directories. Deleting files and directories with the
rm command is a straightforward process. See the rm man page for more information. Options for
removing files and directories include:
— interactive. Prompts you to confirm the deletion. This option can stop you from deleting a
file by mistake.

• -i

— force. Overrides interactive mode and removes the file(s) without prompting. This might not
be a good idea, unless you know exactly what you are doing.

• -f

• -v

— verbose. Shows the progress of the files as they are being removed.

• -r

— recursive. Will delete a directory and all files and subdirectories it contains.

To delete the file piglet.txt with the rm command, type:
rm piglet.txt
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Warning
Once a file or directory is removed with the rm command, it is gone permanently and cannot be
retreived.

Use the -i (interactive) option to give you a second chance to think about whether or not you really
want to delete the file.
[newuser@localhost newuser]$ rm -i piglet.txt
rm: remove ’piglet.txt’?

You can also delete files using the wildcard *, but be careful, because you can easily delete files you
did not intend to throw away.
To remove a file using a wildcard, you would type:
rm pig*

The above command will remove all files in the directory which start with the letters pig.
You can also remove multiple files using the rm command. For example:
rm piglet.txt sneakers.txt

You can use rmdir to remove a directory (rmdir foo, for example), but only if the directory is
empty. To remove directories with rm, you must specify the -r option.
For example, if you want to recursively remove the directory tigger you would type:
rm -r tigger

If you want to combine options, such as forcing a recursive deletion, you can type:
rm -rf tigger

A safer alternative to using rm for removing directories is the rmdir command. With this command,
you will not be allowed to use recursive deletions, so a directory which has files in it will not be
deleted.
Warning
The rm command can delete your entire file system! If you are logged in as root and you type the
simple command rm -rf /, you are in trouble; this command will recursively remove everything on
your system.

Read the rmdir man page (man rmdir) to find out more about this command.

130

Chapter 12. Managing Files and Directories

Chapter 13.
Updating and Adding Packages to Red Hat
Linux
Red Hat Linux consists of various software applications and utilities, known as RPM packages. A
package is just a file that contains a software program.
This chapter explains three ways to update your system: using Red Hat Network, using the online
Errata List, and using the Red Hat Linux Installation CD-ROMs.

13.1. Red Hat Network
Red Hat Network is an Internet solution for managing one or more Red Hat Linux systems. All
Security Alerts, Bug Fix Alerts, and Enhancement Alerts (collectively known as Errata Alerts) can
be downloaded directly from Red Hat using the Red Hat Update Agent standalone application or
through the RHN Web interface available at http://rhn.redhat.com/.
Red Hat Network saves users time because they receive email when updated packages are released.
Users do not have to search the Web for updated packages or security alerts. By default, Red Hat
Network installs the packages as well. Users do not have to learn how to use RPM or worry about
resolving software package dependencies; RHN does it all.
Each Red Hat Network account comes with:
•

Errata Alerts — learn when Security Alerts, Bug Fix Alerts, and Enhancement Alerts are issued for
all the systems in your network through the Basic interface

•

Automatic email notifications — receive an email notification when an Errata Alert is issued for
your system

•

Scheduled Errata Updates — schedule delivery of Errata Updates (with optional automatic installation)

•

Package installation — Schedule package installation on one or more systems with the click of a
button

•

Red Hat Update Agent — use the Red Hat Update Agent to download the latest software packages for your system (with optional package installation)

•

Red Hat Network website — manage multiple systems, downloaded individual packages, and
schedule actions such as Errata Updates through a secure Web browser connection from any computer.

To start using Red Hat Network, follow these three basic steps:
1. Create a System Profile by running the Red Hat Network Registration Client
(rhn_register) on the system that you want to register.
2. Log in to RHN at http://rhn.redhat.com/ and entitle the system to a service offering. Everyone
receives a free Red Hat Network account for one system. Additional accounts must be purchased.
3. Start scheduling updates through the RHN website, or download and install Errata Updates
using the Red Hat Update Agent.
For more detailed instructions, read the Red Hat Network User Reference Guide available at
http://www.redhat.com/docs/manuals/RHNetwork/.
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Tip
Red Hat Linux includes the Red Hat Network Alert Notification Tool, a convenient panel applet that
displays visible alerts when there is an update for your Red Hat Linux system. Refer to the following
URL for more information about the applet: http://rhn.redhat.com/help/basic/applet.html

13.2. Errata List
It is recommended that new users use Red Hat Network to download and install/upgrade packages.
Updating Errata packages from the Red Hat Linux Errata website is recommended for more experienced Red Hat Linux users. It also requires users to resolve software dependencies manually. A
software dependency is when a package is dependent on other package being installed.
All Security Alerts, Bug Fix Alerts, and Enhancement Alerts (collective known as Errata Alerts) can
also be downloaded from the Red Hat website at http://www.redhat.com/apps/support/errata/. Click
on the Red Hat Linux version you are using to view a list of all available errata for Red Hat Linux.
Click on the name of the Errata Alert that you want to apply to your system. Instructions for updating
the packages are on the individual Errata pages. Red Hat, Inc. tests and approves the RPMs posted on
this site. RPMs downloaded from other sites are not supported.

13.3. Installation CD-ROMs
Place one of the installation CDs in your CD-ROM drive. Inserting a CD in the CD-ROM drive should
automatically open the file manager.
In the file manager screen, click on /mnt/cdrom/RedHat/RPMS. Scroll through the files on the right
and look for the packages you want.
Open a terminal and login as root by typing:
su -

Next, use the rpm command to install the packages. The -Uvh options that follows the command
specifies that you want to install or upgrade the package, that you want to see verbose messages, and
that you want to see hash marks (#) while the package is installing. In this example, the documentation
files, which all begin with rhl, would be installed. The string rhl-*.rpm tells your system to install
all files that begin with rhl and end in .rpm (* is a wildcard and keeps you from having to type out
each of the long file names manually). In place of rhl you should put whatever comes before the first
hyphen in the name of the package you want to install.
rpm -Uvh rhl-*.rpm

Press [Enter]. Type exit at the command line and press [Enter] again. This takes you out of the root
login and back to your user account.
Now that the package is installed, it should appear in the appropriate place in the panel’s main menu.
Refer to the Official Red Hat Linux Customization Guide for more information about RPM.

Chapter 14.
Frequently Asked Questions
This chapter answers some of the most common questions about using Red Hat Linux that you may
ask as you become more familiar with it. From recovering forgotten passwords to troubleshooting
package installation problems, this chapter will ease you step-by-step through some common tasks
and get you on your way.

14.1. Localhost Login and Password
I have installed Red Hat Linux. After rebooting, I get a message telling me it needs a localhost login
and password. What are these?
Unless you specified a host name for your computer, or received that information from a network,
your Red Hat Linux installation will call your machine localhost.localdomain by default.
When you get to that initial prompt, it is asking you to log in to your system. If you created a user
account during installation, you can log in using that user name and password. If you didn’t create a
user account during installation, then you can log in as the super user, also known as root. The root
password is the system password you assigned during installation.
It is highly recommended that you create at least one user account during installation. If you did not,
you can create a new user after logging in as root with the Red Hat User Manager GUI application
or the useradd command-line utility. For more information, refer to Section 1.6.

14.2. Error Messages During Installation of RPMs
How do I install an RPM from a CD or the Internet? I keep getting an error message when I use rpm.
If you are getting an error message similar to failed to open /var/lib/rpm/packages.rpm,
it is because you do not have proper permission to install RPM files.
When you install software, you are often required to make system-wide changes which only root can
make, such as creating new directories outside of your user home directory or making changes to
your system configuration. If you are using your normal user account, you will not have permission
to make such changes by default.
You need to be the root user in order to install RPM files. At a shell prompt, switch to root user by
running the following command:
su

You should then be able to install the RPM file without further errors. For more information about
using RPM and Package Management Tool, refer to the Official Red Hat Linux Customization Guide
on the Red Hat Linux Documentation CD or online at http://www.redhat.com/docs/.

14.3. Starting Applications
I installed an application I downloaded from the Internet, and everything seemed to go fine, but I still
get "command not found" when I type its name. I think I have the right name, so why will it not start?
If you are trying to start an application from the shell prompt and it is not working, try typing out the
full directory path before the name of the application’s executable (such as /usr/local/bin/myexecutable).
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For example, imagine that you have downloaded the setiathome client application and want to try
it out. You follow the directions for installing the software, which creates a subdirectory in your home
directory called seti/. Now, start the application using the full path to the executable file as shown
below:
/home/joe/seti/setiathome

The reason you may need to use the full pathnames in order to start an application is because the
executable wasn’t placed in a directory where your user shell environment knew it could be found
(such as /usr/local/bin).
You can customize your settings so that you won’t be required to use the type the full path to the
application each time. To do this, you will have to edit your PATH environment variable.

14.3.1. Editing Your PATH
If you frequently start programs that are not located in a directory that your user shell has been
configured to search, you will have to edit your user shell configuration file to add the directory
containing the executable you wish to run. You can do this by adding the directory to your PATH
environment variable.

Caution
These instructions are intended only for user accounts. Avoid modifying files such as the root user’s

.bash_profile, because of the potential security risks.

Start a text editor, such as pico, at a shell prompt. You can open the file called .bash_profile by
typing the following:
pico .bash_profile

You will see a PATH statement, similar to the one shown below.
PATH=$PATH:$HOME/bin:/usr/local/bin:

To the end of this statement, add ./ as shown below:
PATH=$PATH:$HOME/bin:/usr/local/bin/:$HOME/seti:

Now, type [Ctrl]-[x]; you will be asked whether you want to save "the modified buffer" (that’s what
Pico calls an updated file); type [y] for "yes." Next, you will see the name the file will be saved as;
press the [Enter] key.
You can then make the changes to .bash_profile take effect immediately by typing the following
command:
source .bash_profile

By doing the above, you do not have to manually add ./ to the beginning of the executable to start an
application located in the directory you’ve added to your PATH.
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14.4. Accessing a Windows Partition
I have a dual-boot system with Red Hat Linux and Windows 98. Is there a way to access my Windows
partition while I am running Linux?
You can access another partition on your system (for example, a Windows partition), in two different
ways.
First, assume that your Windows partition is on your first IDE hard drive, in the first partition
(/dev/hda1).
At a shell prompt, log in as root (type su and then enter the root password).
Create a directory at which the Windows partition will be mounted by typing the following command:
mkdir /mnt/windows

Before you can access the partition, you will need to mount it at the directory you just created. As
root, type the following command at a shell prompt:
mount -t vfat /dev/hda1 /mnt/windows

To automatically mount a Windows partition, you must modify the /etc/fstab file.
At a shell prompt, su to root, following the above example.
Next, open the /etc/fstab in a text editor by typing (for example):
pico /etc/fstab

Add the following on a new line (the /dev/hda1 may vary, but for most users this is correct):
/dev/hda1 /mnt/windows vfat noauto,owner,users 0 0

Press [Ctrl]-[x] and then press [y] for yes when prompted to save the changes. For more information
on the mount command, refer the man page by typing man mount at a shell prompt.
To access the partition, type cd /mnt/windows. To navigate through Windows 98’s embedded
spaces in their directories, surround the directory in quotation marks, as in ls "Program Files".

14.5. Finding Commands Quickly
I was looking at a man page yesterday, but I can’t remember the name of the command I was reading
about, and I didn’t write it down. How do I get the man page back?
The command you used will most likely be stored in a file called .bash_history. By default, this
file records the last 500 commands you typed at the shell prompt.
You can glimpse the history of your commands by typing history at the shell prompt, but the results
will speed by too quickly for your to read ever line.
Another way to view .bash_history is with a utility such as less. Type less .bash_history
at the shell prompt and the results will display one page at a time. To move forward a screen, press
the [Space] bar; to move back a screen, press the [b] key, and to quit, press [q].
Paging through .bash_history to find a command can be tedious. Alternatively, you can search
through the file for keywords using grep, a powerful search utility.
Say you were reading the man page the day before, but cannot recall its name. To search for the
command, type:
history | grep man

136

Chapter 14. Frequently Asked Questions

You will see a list of all the commands you typed which have the word man in them.
There are plenty of ways to your command history. For other tips and tricks, see Section 14.6.

14.6. Tips on Using Command History
What are some other ways I can use command history?
If you type history, you will see a numbered list scroll by very quickly, showing you the previous
500 commands you have used.
You probably do not need to see all of the last 500 commands, so the command history 20 might
be useful. This way, only the previous 20 commands you typed will display (you can use any quantity
as an argument of the history command).

14.6.1. Other Shortcuts
Here are other command history shortcuts which may be useful to you:
•

"Bang, bang": Typing !! (called "bang bang") executes the last command in the history.

•

"Bang number": Typing !number (as in !302) will execute the command which is numbered 302
in the history file.

•

"Bang string": Typing !string (as in !rpm) will execute a command with the most recent
matching string from the history file.

•

[Up arrow] and[ down arrow]: At the shell or GUI terminal prompt, you can simply press the up
arrow to move back through previous commands in your history list (the down arrow will move you
forward through the commands) until you find the command you want. Press [Enter] to execute the
command, just as if you had typed it on the command line.

14.7. Keep ls Output from Scrolling
Whenever I type ls I can barely see the output of the directory because it scrolls by too quickly. How
can I actually read the output?
To prevent the output of ls from scrolling by too quickly, pipe the output to a utility such as less or
more. You will then be able to see the output one screen, or "page" at at time.
To read the contents of /etc with less, type the following command at the shell prompt:
ls -al /etc | less

To move forward a screen, press [Space] bar; to move back a screen, press the [b] key; to quit, press
[q].
You can achieve the same results with more, another paging utility.

14.7.1. Printing ls Output
You can also print directory listings by piping the output to a printer in the same way that you piped
the output to your screen. If you have configured a printer, type the following to pipe the output of a
command to the printer:
ls -al /etc | lpr
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14.8. Forgotten Password
Help! I forgot my root password. How do I log in now?
You can log in using single-user mode and create a new root password.
To enter single-user mode, reboot your computer. If you use the default bootloader, GRUB, you can
enter single user mode by performing the following:
1. At the bootloader menu, type [e] to enter into editing mode.
2. You will be presented with a boot entry listing. Look for the line that looks similar to the following:
kernel /vmlinuz-2.4.18-0.4 ro root=/dev/hda2

Press the arrow key until this line is highlighted and press [e].
3. You can now add the word single once space after the end of the text to tell GRUB to boot
into single-user Linux mode. Press [Enter] to make the editing change take effect.
4. You will be brought back to the edit mode screen. From here, press [b] and GRUB will boot
single-user Linux mode. After it finishes loading, you will be presented with a shell prompt
similar to the following:
sh-2.05#

5. You can now change the root password by typing
bash# passwd root

You will be asked to re-type the password for verification. Once you are finished, the password
will be changed. You can then reboot by typing reboot at the prompt; then you can log in to
root as you normally would.

14.9. Password Maintenance
I forgot or want to change my user account password.
Open a shell prompt and type the following:
passwd username

Replace username with your normal user name.
The passwd will then ask for the new password, which you will need to enter twice. You can now use
the new password to log in to your user account.

14.10. Changing Login from Console to X at Startup
How do I change my login from the console to the graphical screen?
Instead of logging in to your system at the console and typing the startx command to start the X
Window System, you can configure your system so that you can log in directly to X.
You must edit one file, /etc/inittab, by changing just one number in the runlevel section. When
you are finished, reboot the computer. The next time you log in, you will have a graphical login
prompt.
Open a shell prompt. If you’re in your user account, su to root by typing
su

Password: yourrootpassword

138

Chapter 14. Frequently Asked Questions

Now, type pico /etc/inittab to edit the file with Pico. The file /etc/inittab will open. Within
the first screen, you will see a section of the file which looks like this:
# Default runlevel. The runlevels used by RHS are:
#
0 - halt (Do NOT set initdefault to this)
#
1 - Single user mode
#
2 - Multiuser, without NFS (The same as 3, if you do not have networking)
#
3 - Full multiuser mode
#
4 - unused
#
5 - X11
#
6 - reboot (Do NOT set initdefault to this)
#
id:3:initdefault:

To change from a console to a graphical login, you should change the number in the line

id:3:initdefault: from a 3 to a 5.

Warning
Change only the number of the default runlevel from 3 to 5.

Your changed line should look like the following:
id:5:initdefault:

When you are satisfied with your change, save and exit the file using the [Ctrl]-[x] keys. You will see
a message telling you that the file has been modified, and asking you to confirm your change. Type
[Y] for yes.
Now, your next login after reboot will be from the graphical screen.

Appendix A.
The KDE Desktop Environment
A.1. Introducing KDE
KDE is a graphical desktop environment that allows you to access your Red Hat Linux system and
applications using your mouse and keyboard.
This chapter covers the fundamental apsects of using the KDE desktop environment including system
navigation, working with files and applications, and customizing the desktop to suit your needs.
If you would like to learn more about KDE, visit the official website at http://www.kde.org.

A.2. Setting Up KDE
The first time you log into KDE (refer to Chapter 1 for more information about logging into your Red
Hat Linux machine), a setup wizard will appear that allows you to set up your language and locale
settings. Figure A-1 shows the welcome screen of the KDE setup wizard.

Figure A-1. The KDE Setup Wizard

A.3. Finding Help
You can access a comprehensive set of documentation about KDE through the KDE HelpCenter.
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Figure A-2. The KDE HelpCenter
You can access the HelpCenter from the Main Menu by selecting Help. To access HelpCenter from
the desktop, right-click on the desktop and select the Help on desktop.
The opening screen of the KDE HelpCenter browser will appear like Figure A-2. From this main
page, you can view help documentation on topics such as using and configuring the desktop, working
with the many applications included with KDE, and working with the Konquerer file manager.
The HelpCenter allows you to perform searches based on keyword entries and Web queries. To do
this, click on the search tab and type in a keyword, subject, or significant phrase in the Keywords
field. Click on Search or press [Enter] to begin searching the Internet for your subject.

A.4. Using The Desktop
After setting up KDE using the wizard, your default desktop will look similar to Figure A-3.
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Figure A-3. A Typical KDE Desktop
The KDE desktop displays application launchers, document windows, file folders, and so on. You can
also access the main menu and configure the desktop to suit your needs.
The long bar across the bottom of the desktop is the panel. The panel contains application launchers,
status indicators, and the desktop manager. You can have up to 16 desktops running at the same time
in KDE. The panel taskbar shows your currently running applications.
Icons located on the desktop can be files, folders, device links, or application launchers. Click on an
icon to open the associated resource.
The KDE desktop works similarly to other graphical desktop environments. You can drag and drop
files and application icons to any location on the desktop. You can also add new icons for all types
of applications and resources to the desktop, panel, or file manager. The desktop itself is also highly
customizable. You can change the appearance of buttons, window and frame decorations, and backgrounds easily. Configuration tools are also available which allow you to customize the way the desktop behaves at events such as single- and double-clicking mouse buttons and combining (also called
chording) keystrokes to create time-saving shortcuts.
The default KDE desktop displays icons for the trash can, your home directory, the KDE Control
Panel, and a link to the Red Hat website. You can access any one of these resources by clicking on
the associated icon.
When you right-click on these icons, you will see several options for working with these resources,
such as Delete Rename Move to Trash, and Copy.
You can drag and drop unwanted items such as files you no longer need to the Trash icon. Right-click
on the trashcan and select Empty Trash Bin to delete the items from your system permanently.

A.5. Using The Panel
The panel stretches across the bottom of the desktop. By default, it contains the main menu icon and
quick-launch icons for logging out, opening a terminal window, and other common applications and
utilities.

Figure A-4. The Panel
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The panel is highly configurable. You can add and remove buttons that launch applications easily.
Right-click on the panel and select Panel => Configuration to open the panel Settings.
Other tabs in Settings contain options to further customize your panel. Click on Help for more information on these options.
Applications and utilities can be added easily to the panel. To add an application to the panel, rightclick on the panel and choose Panel => Add. Then select Button, Applet, Extension, or Special
Button, and make your choice from the corresponding menus.

A.5.1. Using The Main Menu
The Main Menu
is the central point for using KDE. Clicking on the Main Menu icon on the
panel displays a large master menu from which you can perform tasks such as launch applications,
find files, and configure your desktop. The main menu also contains several submenus that organize
applications and tools into several categories, including Extras, Graphics, Internet, and Games.
From the Main Menu, you can lock your screen, which will display a password-protected screensaver.
You can also run applications from a command line as well as logout of your KDE session.

A.5.2. Using Applets
Applets are small applications that run on the panel. There are several types of applets performing
functions such as system/network monitoring, launching applications by typing commands in a text
box, and even checking the local weather.
There are some applets that run on the panel by default. This section covers them in detail.
A.5.2.1. Working with Multiple Desktops
By default, KDE provides four desktops that you can use to display multiple applications without
having to crowd all of them onto one desktop. Each desktop can hold icons, open applications, and
have individually customized backgrounds.
For example, while you are writing a message in KMail on desktop one, you can have Konqueror
browsing the Web on desktop two, the KWord word processor open on desktop three, and so on.
You can change the number and names of desktops available in KDE by making these adjustments:
1. Right-click on the desktop; you will see a brief menu of actions you can take.
2. Select Configure Desktop; the KDE panel configuration tool will open.
3. Click the Number of Desktops tab (see Figure A-5).
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Figure A-5. The Number of Desktops Tab in the Panel Configuration
You can change the names of your desktops (from Desktop 1, Desktop 2, etc.) by deleting the default
names and typing a new name in each desktop’s corresponding text box.
You can also change the number of desktops available to you by adjusting the slider at the top of the
Number of Desktops tab. For more desktops, drag the bar to the right; for fewer desktops, drag the
bar to the left.
The Desktop, Appearance, and Paths tabs are where you can make various desktop configuration
selections, like icon arrangement and font size.
After you make any adjustments to your desktop configuration, click Apply to save the changes and
close the panel configuration tool.
Buttons for your desktops appear on the panel in the Desktop Pager. Simply click on the tiles to move
to a different desktop.

Tip
You can use the keyboard combination of the [Ctrl] and Function keys to switch desktops. For example, [Ctrl]-[F2] will switch you from desktop one to desktop two, [Ctrl]-[F3] will take you to desktop
three, and so on.

A.5.2.2. Viewing The Taskbar
The taskbar displays all running applications — both minimized and on the desktop.

Figure A-6. Applications on the Taskbar
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You can maximize running applications or bring them to the front of your working windows by clicking on the associated item on the taskbar.

Tip
Another way to bring minimized or background windows to the front is to use the [Alt] and [Tab] keys.
To pick an item from the taskbar, hold down [Alt]-[Tab]. To scroll through the tasks, hold down the [Alt]
key, while pressing the [Tab] key in succession. When you have found the task you want to maximize
and bring to the front, release both keys.

A.5.3. Adding Icons and Applets to the Panel
To further customize the panel for your particular needs, you can include additional applets and icons
(launchers).
To add an applet to the panel, click Main Menu => Configure Panel => Add => Applet. Choose the
applet you want from the menu and it will immediately appear on the panel. You can move the applet
by right-clicking on the applet bar and choosing Move from the menu.
To add a new launcher to the panel, click Main Menu => Configure Panel => Add => Button and
choose the application or resource you wish to add to the panel. This will automatically add an icon
on the panel.

A.5.4. Configuring the KDE Panel
You can hide the panel automatically or manually, place it on any edge of your desktop, change its
size and color, and change the way it behaves. To alter the default panel settings, click Main Menu
=> Configure Panel => Preferences. The Settings window will appear, allowing you to adjust all
panel settings, or any one of the specific properties (Position, Hiding, Look & Feel, Menus, and so
on).

A.6. Managing Files
Konqueror is the file manager and Web browser for the KDE desktop. Konqueror allows you to
configure your KDE desktop, configure your Red Hat Linux system, play multimedia files, browse
digital images, surf the Web, and more from one interface. This section explains some of the ways
Konqueror can help you work with and enjoy your Red Hat Linux experience.
To start Konqueror for file management, click on your home directory icon

.

Konqueror will open up in a window on your desktop, allowing you to navigate through your home
directory and throughout your Red Hat Linux file system. After exploring, you can return to your
home directory by clicking the Home button on the toolbar.
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Figure A-7. The Konqueror File Manager
You can navigate through the file system by clicking on folders within the main window frame or
through the hierarchical file system viewer on the navigation panel as shown in Figure A-7. Files and
folders in the main window frame can be moved or copied to another folder or sent to the trash. You
can also delete files and folders by right-clicking on the item and choosing Delete.
Konqueror can also generate thumbnail icons for text, images, PostScript/PDF files, and Web files.
You can even generate preview sounds from digital music files. From the toolbar choose View => Preview and choose the file types for which you would like to see thumbnail icons generated. Thumbnails
will be immediately generated for any associated files in the Konqueror window.

A.6.1. The Navigation Panel
Another useful feature of Konqueror is the navigation panel. This panel appears on the left side of
the Konqueror window by default. The navigation panel makes many of your personalized resources
available to you in convenient tabbed icons. Figure A-8 shows the navigation panel.

Figure A-8. Working with the Navigation Panel
The navigation panel lets you access your Web bookmarks, browsing history, network resources, file
system, and has a built-in media player for playing multimedia files without having to open a separate
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application. The navigation panel makes Konqueror an effieient solution for users who wish to have
fast and easy access to all of their information.

A.7. Customizing KDE
KDE allows you to configure the desktop and your system to suit your needs. The KDE Control
Center, available by selecting Main Menu => Control Center, lets you customize the look and
behavior of the desktop. The following list explains some of the configuration options in detail.
File Browsing
This section lets you configure the Konqueror file manager and customize certain file operations.
You can also associate files to applications that you prefer (for example, assigning all digital
music files to open in XMMS instead of the default player).
Look & Feel
This sections allows you to customize the visual aspect of your desktop environment. You can
customize background images and configure fonts, themes, icons, panel elements, screensavers,
and window header decorations. You can also customize mouse and keyboard events which
makes working with the desktop as efficient for your needs as possible.
Note
KDE features support for smooth (anti-aliased) fonts. However, not all fonts are smooth by default. In order to have smooth fonts for your entire desktop (whether you are reading text files,
webpages, or text in menus and icons) you must choose fonts that are designed to be antialiased, such as LucidaTypewriter or Courier).

Personalization
This section allows you to set country and language options to your particular locale. You can
also configure accessibility features such as audible and visual cues and keyboard/mouse customization. You can also configure your shell prompt settings via the Konsole option. Privacy
and encryption settings can be configured via the Crypto option.
System
This section is an advanced administration interface. You will need your root password to configure most of these options. This section allows you to configure system boot settings, Linux
kernel configuration, printer settings, and install fonts system-wide. It is strongly recommended
that you leave these settings at their default values unless you understand the consequences of
changing them.
Web Browsing
This section allows you to configure the Konqueror Web browser. You can configure options
such as cache sizes, website cookies, plugins, proxy settings (if available), and enhanced browsing using keyword shortcuts.

A.8. Logging Out of KDE
There are several easy ways to log out from your KDE session:
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•
•
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From the Main Menu, select Logout.
From the desktop, right-click on the desktop and select Logout from the menu.

Figure A-9. KDE Logout Screen
At the logout screen, KDE offers you the chance to save your current settings, which will preserve
your panel configuration and start any applications that you left open in your session.
If you are working in an application and you have not saved your work when you log out, a dialog
will inform you that you will lose your unsaved material when you log out. When you see this dialog,
you can simply select the Cancel button, save your work, then log out again. If you continue without
saving your work, you will lose the unsaved data.
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Appendix B.
Applications
The following table shows some of the Red Hat Linux applications that are available to perform
many common tasks. This is not a complete list of all applications available. Applications in between
(parentheses) denotes the formal name of the application.
Category

Recommended
Application

Word Processors

OpenOffice.org Write

KWord

Spreadsheets

OpenOffice.org Calc,

Gnumeric, KSpread

Presentations

OpenOffice.org Impress

KPresenter, MagicPoint

Charts and
Diagrams

Dia

Kcharts, Kivio, XFig

Graphics

The GIMP, Paint Program
(KPaint)

Icon Editor (K Icon Editor)

Image Viewers

GQview

Image Viewer (Kuickshow), The GIMP

Digital Cameras/Scanners

Digital Camera Tool
(gtKam), Scanning (XSane)

Scan and OCR Program (Kooka), The GIMP

PDAs

Jpilot

KPilot, Evolution

CD Recording

CDRecord X-CD-Roast,

KOnCD

Text Editors

Text Editor (gedit)

Emacs, vi, pico, joe, Kate, KDE Advanced
Editor, nedit

Email Clients

Evolution

Kmail, Mozilla Mail, pine, mutt

Web Browsers

Mozilla

Galeon, Nautilus, Konquerer, Lynx

Chat/Instant
Messaging

Instant Messenger (GAIM)

EPIC, KSirc, X-Chat, Chatzilla

PDF/PostScript
Viewers

PS/PDF Viewer
(KGhostView)

xpdf, Ghostview, GNOME Ghostview

Personal Finance

Gnucash

Fax

Fax Viewer (KFax)

Sound

CD Player (GNOME CD),
Sound Recorder (GNOME
Sound),Volume Monitor
(VUMeter)

Table B-1. Applications

Extras

KDE CD Player, XMMS, Aumix, KDE Sound
Mixer, KDE MidiSynth, KMid
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Appendix C.
A Comparison of Common DOS and Linux
Commands
Many Linux commands typed at a shell prompt are similar to the commands you would type in MSDOS. In fact, some commands are identical.
This appendix provides common commands used at the MS-DOS prompt in Windows and their counterparts in Linux. Basic examples of how the command are used at the Linux shell prompt are also
provided. Note that these commands usually have a number of options. To learn more about each
command, read its associated man page (for example, type man ls at the shell prompt to read about
the ls command).
Command’s
Purpose

MS-DOS

Linux

Basic Linux Example

Copies files

copy

cp

cp thisfile.txt
/home/thisdirectory

Moves files

move

mv

mv thisfile.txt
/home/thisdirectory

Lists files

dir

ls

ls

Clears screen

cls

clear

clear

Closes prompt
window

exit

exit

exit

Displays or sets
date

date

date

date

Deletes files

del

rm

rm thisfile.txt

"Echoes" output on echo
the screen

echo

echo this message

Edits files with
simple text editor

edit

pico(a)

pico thisfile.txt

Compares the
contents of files

fc

diff

diff file1 file2

Finds a string of
text in a file

find

grep

grep this word or phrase

Formats a diskette

format a: (if
diskette is in A:)

mke2fs or
mformat(b)

/sbin/mke2fs /dev/fd0
(/dev/fd0 is the Linux
equivalent of A:)

Displays command
help

command /?

man(c)

man command

Creates a directory

mkdir

mkdir

mkdir directory

thisfile.txt

View a file

more

less(d)

less thisfile.txt

Renames a file

ren

mv

mv thisfile.txt
thatfile.txt(e)
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Command’s
Purpose

MS-DOS

Linux

Basic Linux Example

Displays your
location in the file
system

chdir

pwd

pwd

Changes directories cd pathname
with a specified
path (absolute
path)

cd pathname

cd /directory/directory

Changes directories cd ..
with a relative path

cd ..

cd ..

Displays the time

time

date

date

Shows amount of
RAM and use

mem

free

free

Notes:
a. Pico is a simple text editor; other editors you can use in place of Pico include Emacs and vi.
b. This formats a disk for the DOS filesystem.
c. You can also use info for some commands.
d. The more pager can also be used to page through a file a screen at a time.
e. The mv command can both move a file and, if you want to rename a file in the same directory,
you "move" that file to the same directory with a new name, as in this example.
Table C-1. Similar Commands

Appendix D.
System Directories
This is a list of the primary Red Hat Linux system directories. Each directory is described briefly. For
additional directory information, refer to the Official Red Hat Linux Customization Guide and Official
Red Hat Linux Reference Guide.
• /bin

— Used to store user commands. The directory /usr/bin also stores user commands.

— Location of many system commands, such as shutdown. The directory /usr/bin also
contains many system commands.

• /sbin
• /root

— The home directory of root, the superuser.

• /mnt — This directory

typically contains the mount points for file systems mounted after the system
is booted. For example, the default CD-ROM mount point is /mnt/cdrom.

• /boot

— Contains the kernel and other files used during system startup.

• /lost+found —
• /lib

Used by fsck to place orphaned files (files without names).

— Contains many library files used by programs in /bin and /sbin. The directory

/usr/lib contains more library files.

• /dev

— Stores device files.

• /etc

— Contains many configuration files and directories.

• /var

— For "variable" files, such as log files and the printer spool.

• /usr

— Contains files and directories directly relating to users of the system.

— A virtual file system (not actually stored on the disk) that contains system information
used by certain programs.

• /proc

— A directory that is used to mount the initrd.img image file and load needed device
modules during bootup.

• /initrd

Warning
Do not delete this directory. You will be unable to boot your computer if you delete it and reboot
your Red Hat Linux machine.
• /tmp

— A "scratch pad" for users and programs. /tmp has global read/write access.

• /home

— Typical location of user home directories.
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Appendix E.
Keyboard Shortcuts
Here are a few keyboard shortcuts you can use to perform common tasks quickly. Many more are
available in addition to what is listed here. For more command line and keyboard shortcuts, visit:
http://sunsite.dk/linux-newbie/lnag_commands.html#shortcuts

•

[Ctrl] + [Alt] + [Backspace] = kill X. Kills your current X session and returns you to the login
screen. Use this if the normal exit procedure does not work.

•

[Ctrl] + [Alt] + [Delete] = shutdown and reboot. Shuts down your current session and reboots the
OS. Use only when the normal shutdown procedure does not work.

•

[Ctrl] + [Alt] + [Fn] = switches screens. [Ctrl]+[Alt] + one of the function keys displays a new
screen. [F1] through [F6] are text (console) screens and [F7] is a graphical screen.

•

[Alt] + [Tab] = switch tasks. If you have more than one application open at a time, you can use [Alt]
+ [Tab] to switch among open tasks and applications.

•

[Ctrl] + [a] = move cursor to the beginning of a line. This works in most text editors and in the URL
field in Mozilla.

•

[Ctrl] + [d] = logout of a terminal or console instead of having to type exit or logout.

•

[Ctrl] + [e] = move cursor to end of a line. This works in most text editors and in the URL field in
Mozilla.

•

[Ctrl] + [l] = clear the terminal. This shortcut does the same thing as typing clear at a command
line.

•

[Ctrl] + [u] = clear the current line. If you are working in a terminal, use this shortcut to clear the
current line from the cursor all the way to the end of the line.

•

[Middle Mouse Button] = pastes highlighted text. Use the left mouse button to highlight the text.
Point the cursor to the spot where you want it pasted. Click the middle mouse button to paste it.

•

[Tab] = command autocomplete. Use this command when working in a terminal. Type the first few
characters of a command and then press the [Tab] key. It will automatically complete the command
or show all the commands that match the characters you typed.

•

[Up] and [Down] Arrow = show command history. When working in a terminal, press the [up] or
[down] arrow to scroll through a history of commands you have typed from the current directory.
When you see the command you want to use, press [Enter].

•

clear = clear the terminal. Type this at a command line to clear all displayed data from the
terminal window.

•

exit = logout. Type this at a command line to logout of the current user or root account.

•

history = show history of commands. Type this at a command line to see a numbered list of
the previous 500 commands you typed. To display a shorter list of commands, by type history
followed by a space and a number. For example, history 20.

•

reset = refresh terminal screen. Type this at a command line to refresh the terminal screen if
characters are unclear.
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Appendix E. Keyboard Shortcuts

Index

commands
(See shell prompt)

Symbols
/etc/printcap, 63
/etc/printcap.local, 63

A
accounts
creating, 18
appending standard output, 104
applets
adding to KDE panel, 144
adding to the desktop panel, 25
on the desktop panel, 24
panel
in KDE, 142
applications
and Red Hat Linux, 149
starting from shell prompt, 133
archiving files, 121

cat, 107
cat, using, 102
cd, 96
change directories, 96
chmod, 110
numerical settings, 115
clear, 102
cron, 101
DOS, 151
finding, 135
grep, 107
head, 107
history, 135
locate, 100
ls, 99
keeping output from scrolling, 136
ls -a, 99

B

ls -al, 99
ls, common options with, 100

bunzip2, 123
burning CDs, 34
additional resources, 39
with cdrecord, 37
with mkisofs, 37
with X-CD-Roast, 34
bzip2, 123

pwd, 96

C

rm -r

multiple, 110
print working directory (pwd), 96
reset, 102
rm
(See files, deleting)

cat, 102
cd, 96
CD-rewritable (CD-RW), 34
additional resources, 39
and cdrecord, 37
and mkisofs, 37
CD-writable (CD-R), 34
additional resources, 39
and cdrecord, 37
and mkisofs, 37
and X-CD-Roast, 34
cdrecord, 38
CDs, playing, 79
chmod, 110
numerical settings, 115
clear, 102
command history, 109
tips, 136

(See directories, deleting)
stringing together, 110
su, 98
tail, 107
common user questions, 133
compressing files, 121
conventions
document, viii
copying and pasting text
when using X, xi
creating graphics
with OpenOffice.org Draw, 76
creating user accounts, 18
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D
desktop, 23
applets, 24
KDE, 140
desktops
multiple
KDE, 142
DHCP, 41
directories
changing, 96
copying, 127
deleting, 128
descriptions, 153
listing contents, 99
managing
from shell prompt, 95
moving, 128
diskettes, 29
formatting, 31
KFloppy, 32
mke2fs, 32
mounting, 29
MS-DOS formatted, 30
unmounting, 29
using, 29
DNS
definition, 41
documents, 71
OpenOffice.org, 71
OpenOffice.org Writer, 72
PDF, 77
dot files
(See hidden files)
drag and drop, xi
drawing
OpenOffice.org Draw, 76

E
email clients, 53
Evolution, 54
KMail, 58
Mozilla Mail, 56
Newsgroups, 57
mutt, 59
pine, 59
plain text, 59
mutt, 59
pine, 59
environment variables
PATH, 134
errata
updating with, 132
Evolution
(See email clients)

ext2 file system
and floppy disks, 31

F
FAQ, 133
accessing a Windows partition, 135
finding previous used commands, 135
history tips and tricks, 136
keeping ls output from scrolling, 136
login problems, 137
permissions for installing RPMs, 133
starting applications, 133
feedback
contact information for this manual, xi
FHS
(See Filesystem Hierarchy Standard)
file, 121
file manager
for KDE, 144
Nautilus, 26
file managers, 119
File Roller, 122
file system
understanding, 119
files
archived, 120
archiving, 121
with File Roller, 122
compressed, 120
compressing, 121
with File Roller, 122
copying, 127
copying at a shell prompt, 127
creating
touch, 127
deleting, 128
deleting at a shell prompt, 127
formats, 120
managing
from shell prompt, 95
moving, 128
moving at a shell prompt, 127
renaming at a shell prompt, 127
types of, 120
Filesystem Hierarchy Standard, 120
floppy disks
(See diskettes)
formatting diskettes, 31
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G

K

games and amusements, 82
finding more online, 83
getting started
logging in, 16
Setup Agent, 13
GIMP, 89
opening a file, 90
saving a file, 91
GQview, 87
graphical desktop, 23
applets, 25
customizing, 27
logging out of, 28
main menu, 24
Nautilus, 26
panel, 24
using, 23
workspace, 23
graphical login
changing to, 137
graphics, 89
gunzip, 123
gzip, 123

KDE, 139
applets
adding, 144
multiple desktops, 142
customizing, 146
desktop, 140
desktop icons, 141
desktops
multiple, 142
switching, 143
Konqueror
navigation panel, 145
latest documentation, 139
main menu, 142
panel, 141
applets, 142
switching tasks, 144
Taskbar, 143
website location, 139
keyboard shortcuts, 155
KFloppy, 32
KMail
(See email clients)
Konqueror
(See Web browsers)
KDE file manager, 144
navigation panel, 145
viewing images with, 86

H
help
with KDE
finding, 139
hidden files, 99
history
finding commands using, 135

I
images
additional resources, 92
manipulation, 85
GIMP, 89
viewing, 85, 85
GQview, 87
Konqueror, 86
Nautilus, 85
Internet
configuring, 41
Internet Druid, 41
introduction, vii
IP address, 41

L
less, 105
linux commands
(See shell prompt)
listing directories
(See commands, ls)
log in, 16
logging in, 16
graphical, 137
graphical login, 17
virtual console login, 17
logging out, 20
from the desktop, 28
KDE, 146
saving current settings, 147
login problems
using single-user mode, 137
lpd, 64
ls, 99
printing output, 136
viewing output, 136
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M
main menu
in KDE, 142
on the desktop, 24
mke2fs, 32
mkisofs, 37
mouse
how to use, xi
Mozilla
(See Web browsers)
Mozilla Mail
(See email clients)
mtools, 30
music
Ogg Vorbis, 79
Wave, 79
XMMS, 79
using, 80
mutt
(See email clients)

N
Nautilus, 26
(See Web browsers)
disabling text icons, 26
disabling thumbnails, 26
viewing images with, 85
new users
creating accounts, 18
Newsgroups
(See email clients)

O
online
connecting with Internet Druid, 41
OpenOffice.org, 71
Draw, 76
features, 71
Impress, 75
Writer, 72, 73
ownership and permissions, 110

P
pagers, 105
less, 105
panel
configuring, 26
configuring the, 144
in the graphical desktop, 24
KDE, 141
adding an application, 142

customizing, 141
hiding, 142
partitions
accessing Windows, 135
password
forgotten, 137
passwords
secure, 19
PATH, 134
editing, 133
pathnames
relative and absolute, 96
PDF
viewing, 77
xpdf, 77
permissions
numerical settings, 115
setting for new RPMs, 133
permissions and ownership, 110
pine
(See email clients)
pipes, 105
Point-to-Point Protocol, 41
PPP, 41
presentations
OpenOffice.org Impress, 75
printconf
(See printer configuration)
printer configuration, 63
creating an alias, 68
default printer, 67
delete existing printer, 67
driver options, 69
Assume Unknown Data is Text, 69
Convert Text to Postscript, 69
Effective Filter Locale, 69
Page Size, 69
Prerender Postscript, 69
Send End-of-Transmission (EOT), 69
Send Form-Feed (FF), 69
edit driver, 68
edit existing printer, 67
local printer, 64
modifying existing printers, 67
overriding a printer, 67
rename existing printer, 68
test page, 67
text-based application, 63
Printer Configuration Tool
(See printer configuration)
printing
from command line, 101
pwd, 96

R
Red Hat Network, 131
Red Hat Network Registration Client, 131
Red Hat Update Agent, 131
redhat-config-printer
(See printer configuration)
redirecting standard input, 105
redirection, 102
reset, 102
RHN
(See Red Hat Network)
root, 119
and root login, 119
logging in as, 16
RPM, 132
installing packages, 131
upgrading packages, 131
RPMs
error message while installing, 133
installing with Gnome-RPM, 133

S
Setup Agent, 13
shell, 95
history of, 95
shell prompt, 18
basic commands, 95
chmod, 112
single-user mode, 137
software
installing, 131
upgrading, 131
sound card
configuring, 80
Sound Card Configuration Tool, 80
spreadsheets
OpenOffice.org Calc, 73
standard input
redirecting, 105
standard output
appending, 104
redirecting, 102
Start Here, 27
startup messages
dmesg | more, 106
startx, 17
su, 98
superuser

(See commands, su)
switching desktops
KDE, 143
switching tasks
KDE, 144
system directories
descriptions, 153

T
tab completion, 109
Taskbar
KDE, 143
terminal
(See shell prompt)
terms
introductory, 14
The Graphical Desktop, 17
Trash icon
KDE, 141
troubleshooting
sound card, 80
video card, 81

U
unzip, 123
user account
creating, 18
importance of, 16
utilities
cat, 102
less, 105

W
Web browsers, 43
Konqueror, 47
Mozilla, 43
Nautilus, 47
Windows
accessing on a separate partition
add line to /etc/fstab, 135

X
X Configuration Tool, 81
xpdf, 77
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