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Macromedia Dreamweaver MX is considered in some circles to be the industry standard in web
development tools. It is the market leader among like products, including Microsoft FrontPage
and Adobe GoLive. This workshop will introduce the basic features of Dreamweaver and some
basic web development concepts.

Planning Your Site

In Dreamweaver, the term site can refer either to a Web site or to a local storage location for
the documents belonging to a Web site. The usual way to set up a site is to create a folder on
your local disk that contains all the files for your site, and to create and edit documents within
that folder. You then periodically copy those files to a server that allows other people to view
via the web. This approach is better than creating and editing files on the live Web site itself
because it allows you to test changes in the local site before making them publicly viewable.
Furthermore, you can make a set of changes to the live site all at once instead of one file at a
time.

Site Structure

Organizing your site carefully from the start can save you time later on. If you start creating
documents without thinking about where in your folder hierarchy they should go, you may end
up with a huge, unwieldy folder full of files, or with related files scattered through a half-dozen
similarly named folders.

It’s a good practice to put related pages into the same folder; for example, your company’s
press releases, contact information, and job postings might all go in one folder, and your online
catalog pages in another folder. Use subfolders where necessary. It's also convenient to place
all your images in one location. This way, when you want to insert an image into a page you
know where to find it. Finally, if you use the image in multiple places on the site, you will only
need one copy.
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Designers sometimes place all of the non-HTML items to be used on a site in a folder called
assets. That folder may contain other folders - for example, an images folder, a PDF folder, and
a media folder. Finally if there aren't many assets shared among such groups, you might have a
separate Assets folder for each group of related pages on your site.

One very important note: your local site and your remote web site should have exactly the
same structure. If you create a local site using Dreamweaver and then upload everything to the
remote site, Dreamweaver ensures that the local structure is precisely duplicated in the remote
site.

Planning Site Navigation

Another area where planning pays off is navigation. As you design your site, think about the
experience you want your visitors to have.

You are here: It should always be easy for visitors to figure out where in your site they are,
and how to return to your top-level page.

Searching and indexes: On large sites, it should be easy for visitors to find any information
they want.  An index is also helpful for ADA compliance.

Feedback: Provide a way for visitors to contact the person responsible for maintenance
(webmaster) in case something is wrong with the site, and to contact other relevant people
associated with the company or the site.
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Exploring Dreamweaver

The first time you launch Dreamweaver MX 2004 in Windows it will offer you a choice of two
workspace layouts:  Designer and Coder.

Designer lets you work on pages in a WYSIWYG environment and provides a set of tools
specific to that view.  Coder lets you work in the HTML code view of a page and provides a set
of tools specific to that view.  In both environments there are options that let you view the code
and/or preview the page.  Dreamweaver on our machines is already set to the Designer
workspace layout.

In Windows, Dreamweaver provides an all-in-one-window integrated layout. In the integrated
workspace, all windows and panels are integrated into a single larger application window.  An
example of this window is pictured on the next page.

On the Macintosh, Dreamweaver provides a floating workspace layout, in which each document
is in its own individual window. Panel groups are initially docked together, but can be undocked
into their own windows. Windows "snap" automatically to each other, to the sides of the screen,
and to the Document window as you drag or resize them.
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Dreamweaver workspace elements

The Start page (not pictured above) enables you to open a recent document or create a new
document. From the Start page you can also learn more about Dreamweaver by taking a
product tour or a tutorial.

The Insert bar contains buttons for inserting various types of "objects," such as images,
tables, and layers, into a document. Each object is a piece of HTML code that enables you to
set various attributes as you insert it. For example, you can insert a table by clicking the Table
button in the Insert bar. If you prefer, you can insert objects using the Insert menu instead of
the Insert bar.

The Document toolbar contains buttons that provide options for different views of the
Document window (such as Design view and Code view), various viewing options, and some
common operations such as previewing in a browser.

The Standard toolbar (not displayed in the default workspace layout) contains buttons for
common operations from the File and Edit menus: New, Open, Save, Save All, Cut, Copy, Paste,
Undo, and Redo. To display the Standard toolbar, select View > Toolbars > Standard.
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The Document window displays the current document as you create and edit it.

The Property inspector lets you view and change a variety of properties for the selected
object or text. Each kind of object has different properties. The Property inspector is not
expanded by default in the Coder workspace layout.

The tag selector in the status bar at the bottom of the Document window shows the hierarchy
of tags surrounding the current selection. Click any tag in the hierarchy to select that tag and all
its contents.

Panel groups are sets of related panels grouped together under one heading. To expand a
panel group, click the expander arrow at the left of the group's name; to undock a panel group,
drag the gripper at the left edge of the group's title bar.

The Files panel enables you to manage your files and folders, whether they are part of a
Dreamweaver site or on a remote server. The Files panel also enables you to access all the files
on your local disk, much like Windows Explorer (Windows) or the Finder (Macintosh).

Note: Dreamweaver provides many other panels, inspectors, and windows. To open
Dreamweaver panels, inspectors, and windows, use the Window menu. If you can't find a
panel, inspector, or window that's marked as open, select Window > Arrange Panels to neatly
lay out all open panels.

Creating a Local Site

A local site (the local storage area for your Web site's files) requires a name and a local root
folder where you plan to store all of the site's files. Create a different local site for each Web
site you work on. The local root folder of your site should be a folder you set up specifically for
that site. Don't use your disk as the site root, and don't use the Dreamweaver application
folder. Under the Windows 95/98, 2000, ME, and XP operating systems, a good place to store
your Web sites would be in the My Webs folder inside the My Documents folder. Inside My
Webs, you can create local root folders, one for each site you’re working on.

To Create a Local Site:
1. Click Dreamweaver Site… from the Create New column of the Start Page. The Site

Definition dialog box appears. If the dialog box is showing the Advanced tab, click Basic.
The Site Definition Wizard begins.

2. In the Site Name field, enter a name for the site. The site name you select will appear in
the Site window and on the Site > Manage Sites submenu. The name can be anything
you like (for example, My Web Site). Click Next to proceed.

3. The Wizard next asks if you will use a server technology. You would select Yes only if
you are planning to use any dynamic document types, such as Active Server Pages or
Java. If you are creating only a static site, select “No, I do not want to use a server
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technology”, and click Next to proceed.
4. The next screen asks how you want to work with your files. Click to select “Edit local

copies on my machine, then upload to server when ready (recommended)”.

In the text box where you’re asked where you want to store your files on your local
drive, you can enter the path to the folder where you want to store your Web site. Click
the folder icon to browse to and select the folder, or enter a path and folder name in the
text field. If the local root folder does not yet exist, create it from within the file
browsing dialog box and give it a name (for example, My Website). Click Next to
proceed.

5. The next screen asks how you will connect to your remote server. For the time being,
click on the arrow to select None from the pop-up menu, then click Next.

6. The next screen will show you a summary of your settings. Click Done to close the
Wizard.

The Files panel now shows the new local root
folder for your current site.  There is also a menu
to let you view all of your local disks and sites,
and a menu to let you select the site location you
are viewing (local, remote, or testing).

When you begin creating or adding files to your
site, they will appear in the Files panel under the
local root folder. The Files panel acts as a file
manager, allowing you to copy, paste, delete,
move, and open files as you would on a computer
desktop.

Creating and Editing HTML Documents

Now that you have a site set up, you can begin to create the documents (pages) that constitute
the site. You can create new, blank HTML documents in Dreamweaver, or you can open an
existing HTML document, regardless of how it was created. You can also create a new
document based on a template.

Note: Do not use special characters (such as é, ç, or ¥) or punctuation (such as colons,
slashes, or periods) in the names of files you intend to put on a remote server. Many servers
change these characters during upload, which will cause any links to the files to break.
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To Create a New blank HTML Document
•  Click HTML from the Create New column of the Start Page.

If you open the HTML Code inspector (click on one of the Code view buttons on the Document
toolbar), you can see that the new document isn't really completely blank—it contains HTML,
HEAD, and BODY tags to get you started. As you type in the Document window or insert
objects such as tables and images, you can leave the HTML Code inspector open and watch as
the HTML source code is created.

To open an existing HTML file
Choose from the following options:

•  Click Open from the Open a Recent Item column of the Start Page.

•  Double-click on the file in the Files panel.

Setting Page Properties

Page titles, background images and colors, text and link colors, and margins are among some
of the basic properties of HTML documents.  Click on the Page Properties button in the Property
inspector or select Modify > Page Properties from the menu to reveal the dialog box pictured
below.
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Appearance:

Page font: sets the default font for the entire page

Size: sets the default font size for the entire page

Text color: sets the default color of the text for the entire page

Background color: allows you to set a default page color

Background image: allows you to set an image as the background for a page

Left, Right, Top, and Bottom margin: specify the sizes of page margins in the body tag.
For best cross-browser results, provide margin values for all four margin values instead of
just two. To ensure that no margins appear, set all four values to 0.

Links:

Link font: sets the default font for text links that appear on the page.

Link size: sets the default font size for text links that appear on the page.

Link color: sets the default color for text links that appear on the page.

Rollover link: sets the default color for text links that appear on the page when the mouse
is positioned over them.

Visited link: sets the default color for text links on the page that have been visited.

Underline style: sets how text links will be (or not be) underlined on the page

Headings:

Heading font: sets the default font used for the various heading formats options available
on the page.

Heading 1 – 6: sets the size and color for each the six different heading options available
on the page.

Title/Encoding:

Title: specifies the page title that appears in the title bar of the browser window.

Encoding: specifies the encoding used for characters in the document. Choose Western
(Latin 1) for English and Western European languages.
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Adding Text

To add text to your document, simply type directly in the Document window. You can also copy
text from another application, such as a word processor, and paste it into Dreamweaver.
Dreamweaver does not preserve text formatting applied in the other application but it does,
however, preserve line breaks.

Formatting Text

Formatting in Dreamweaver is similar to using a standard word processor. Use your mouse to
select the text you want to change. If no text is selected, the change applies to subsequent text
you type. To change the font, size, color, and alignment of selected text, use the Text menu or
the Property inspector.

NOTE: Formatting text in the Property inspector overrides formatting set in the Page Properties

To change the overall format of the text:
Use the Format pop-up menu in the Property inspector or the Text > Paragraph Format
submenu to set the default formatting style (Paragraph, Preformatted, Heading 1, Heading 2,
and so on) for a block of text.

To change font characteristics:
Choose from the following options:

•  To change the font, choose a font combination from the Property inspector or from the
Text > Font submenu.

o Browsers display the text using the first font in the combination that is installed
in the user's system. If none of the fonts in the combination is installed, the
browser displays the text as specified by the browser preferences. Choose
Default to remove previously applied font faces; Default applies the default font
for the selected text (either the browser default font or the font assigned to that
tag in the CSS style sheet).

•  To change the font style, click Bold or Italic in the Property inspector, or choose a font
style (Bold, Italic, Underline, and so on) from the Text > Style submenu.

•  To change the font size, choose a size from the Property inspector.
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To change the color of text:
You can change the color of selected text so that the new color overrides the text color set in
Page Properties. (If no text color has been set in Page Properties, the default text color is
black.)

Choose from the following options:
•  In the Property inspector, choose a color from the palette of browser-safe colors by

clicking the color box.

•  Choose Text > Color. The system Color
Picker dialog box appears. Select a color
and click OK.

To return text to the default color:
•  In the Property inspector, click the color

box to open the palette of browser-safe
colors.

•  Click the Erase button (white box with
red slash through it).

*About Web-Safe Colors
In HTML, colors are expressed either as hexadecimal values (for example, #FF0000) or as color
names (red). The colors that are common to Netscape Navigator and Microsoft Internet
Explorer on both Windows and Macintosh systems when running in 256-color mode are called
Web-safe. The conventional wisdom is that there are 216 common colors, and that any
hexadecimal value that combines the pairs 00, 33, 66, 99, CC, or FF (RGB values 0, 51, 102,
153, 204, and 255, respectively) represents a Web-safe color. Testing, however, reveals that
there are only 212 Web-safe colors. Internet Explorer on Windows does not correctly render the
colors #0033FF (0,51,255), #3300FF (51,0,255), #00FF33 (0,255,51), and #33FF00
(51,255,0).

All of the color pickers in Dreamweaver use the 212-color Web-safe palette; selecting a color
from the palette displays the color's hexadecimal value. While the four colors mentioned
previously are not in the Dreamweaver Web-safe palette, you can edit the hexadecimal value in
any color field by hand if you want to use them.

To choose a color outside the Web-safe range, click the Palette button in the lower right corner
of the Dreamweaver color picker to open the system color picker. The system color picker is not
limited to Web-safe colors.
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To align text and elements:
To align text:

•  Select the text you want to align.

•  In the Property inspector, click an alignment option (Left, Right, or Center), or choose
Text > Align and choose an alignment command.

To center elements:
•  Select the element (image, plug-in, table, or other page element) you want to center.

•  From the Text menu, select Align > Center.

Note: You can align and center complete blocks of text; you cannot align or center only
part of a heading or part of a paragraph.

To indent text and remove indentation:
•  Select the desired text.

•  In the Property inspector, click the Indent or Outdent button, or choose Text > Indent
or Outdent.

This applies or removes the BLOCKQUOTE tag when the selected text is a paragraph or
heading; it adds or removes an extra UL or OL tag when the selected text is a list.

Creating lists:
You can create numbered lists, bulleted lists, and definition lists from existing text or from new
text as you type in the Document window.  Lists can also be nested.

To create a new list:
•  Place the insertion point on the line where you want to add a list of new items.

•  Click the Bulleted or Numbered List buttons in the Property inspector, or choose Text >
List and select the type of list desired—Unordered (bulleted) List, Ordered (numbered)
List, or Definition List.

•  Begin typing the list, pressing Enter (Windows) or Return (Macintosh) to begin another
list item.

•  To complete the list, press Enter twice (Windows) or press Return twice (Macintosh).

To create a list using existing text:
•  Select a series of paragraphs to make into a list.

•  Click the Bulleted or Numbered List button in the Property inspector, or choose Text >
List and select the type of list desired—Unordered (bulleted) List, Ordered (numbered)
List, or Definition List.
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To create a nested list:
•  Select the list items you want to nest.

•  Click the Indent button in the Property inspector or choose Text > Indent.

List properties
List properties determine the appearance of the list as a whole and of selected list items,
enabling you to create numbered lists that are not ordered and to change the style midlist. To
view List properties, select a list item and choose Text > List > Properties, or click List Item in
the Property inspector.

(You may need to click the expander arrow in the lower right corner of the Property inspector to
see the List Item button.)

The following options are available, depending on the list type selected:

List Type: specifies the list as numbered, bulleted, menu, or directory.

Style: determines the style of numbers or bullets used for a numbered or bulleted list.  All
items in the list will have this style unless you specify a new style for items within the list.

Start Count: sets the value for the first item in a numbered list.

New Style: enables you to specify a new style for a list item within a list.

Reset Count To: specifies a number other than the incremented value for the list item,
enabling you to create nonsequential numbered lists.
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To check spelling:
Use the Text > Check Spelling command in the Text menu to check the spelling in the current
document. The Check Spelling command ignores HTML tags and attribute values.

Working with Images

Dreamweaver, like most browsers, can display both JPEG and GIF images. Dreamweaver,
Microsoft Internet Explorer 4.0 and later, and Netscape Navigator 4.04 and later also support
PNG images.

In general, JPEG is the superior format for photographic or continuous-tone images, and GIF is
preferred for non-continuous tone images or those with large areas of flat colors. The PNG
format is a patent-free replacement for GIF that includes support for indexed-color, grayscale,
and true-color images. It also provides alpha channel support for transparency. PNG is the
native file format of Macromedia Fireworks.

Inserting an image:
When you insert an image into a Dreamweaver document, Dreamweaver automatically
generates a reference to the file in the HTML. To ensure that this reference is correct, the
image file must be inside the current site. If it is not, Dreamweaver asks whether you want to
copy the file to a folder within the current site.

To insert an image:
•  Do one of the following:

o Place the insertion point where you want the image to appear in the Document
window, and then choose Insert > Image

o Click the Image button on the Insert bar.

o Drag the Image button from the Common tab of the Insert toolbar to the desired
location in the Document window.

o Drag the icon of an image from the desktop or from the Files panel to the
desired location in the Document window; then skip to step 3.

•  In the dialog box that appears, click Browse (Windows) or Choose (Macintosh) to choose
a file, or type the path for the image file.

o If you are working in an unsaved document, Dreamweaver generates a file://
reference to the image file. When you save the document anywhere in the site,
Dreamweaver converts the reference to a document-relative path.

•  Set image properties in the Property inspector.
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Image properties
To view image properties in the Property inspector, select an image in the Document window.

The Property inspector initially displays the most commonly-used properties. Click the expander
arrow in the lower right corner to see all properties.

Name: lets you name an image so you can refer to it with a scripting language such as
JavaScript or VBScript.

W and H: the width and height of the image, in pixels. Dreamweaver automatically updates
these fields with the image’s original dimensions when you insert an image in a page. You
can specify the image size in the following units: pc (picas), pt (points), in (inches), mm
(millimeters), cm (centimeters), and combinations, such as 2in+5mm; Dreamweaver
converts the values to pixels in the HTML source code.

If you set W and H values that do not correspond to the actual width and height of the
image, the image may not display properly in a browser. (To restore the original values,
click the W and H field labels.)

Note: You can change these values to scale the display size of this instance of the image,
but this does not reduce download time, because the browser downloads all image data
before scaling the image. To reduce download time and to ensure that all instances of an
image appear at the same size, use an image-editing application to scale images.

Src: specifies the source file for the image. Click the folder icon to browse to the source file,
or type the path.

Link: specifies a hyperlink for the image. Drag the Point-to-File icon to a file in the Site
window, click the folder icon to browse to a document on your site, or type the URL.

Align: aligns an image and text on the same line.

Alt: specifies alternative text that appears in place of the image for text-only browsers or
for browsers that have been set to download images manually. For visually-impaired users
who use speech synthesizers with text-only browsers, the text is spoken out loud. In some
browsers, this text also appears when the pointer is over the image. In some browsers, this
text also appears when the pointer is over the image.
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V Space and H Space: Adds space, in pixels, above, below, and on both sides of the
image.

Target: specifies the frame or window in which the linked page should load. (This option is
not available when there is no link on the image.) The names of all the frames in the
current document appear on the list. If the specified frame does not exist when the
document is opened in a browser, the linked page loads into a new window that has the
name you specified. Once this window exists, other files can be targeted to it. You can also
choose from the following reserved target names:

_blank loads the linked file into a new, unnamed browser window.

_parent loads the linked file into the parent frameset or window of the frame that
contains the link. If the frame containing the link is not nested, the linked file loads into
the full browser window.

_self loads the linked file into the same frame or window as the link. This target is
implied, so you generally don't need to specify it.

_top loads the linked file into the full browser window, thereby removing all frames.

Low Src: specifies the image that should load before the main image. Many designers use
a 2-bit (black and white) version of the main image because it loads quickly and gives
visitors an idea of what they're waiting for, but you can use any image with the same
dimensions as the main image.

Border: sets the width, in pixels, of the link border around the image. Enter 0 for no
border.

Map Name Field: enables you to create client-side image maps.

Reset Size: resets the W and H values to the original size of the image.

Edit: launches the image editor you specified in External Editors preferences and opens the
selected image. When you save your image file and return to Dreamweaver, Dreamweaver
updates the Document window with the edited image

Aligning elements:
The following Align options appear in the Alignment drop-down menu in the Property inspector,
and can be associated with certain elements, such as images and plug-ins. You can also use the
alignment buttons (left, right, and center) to place selected elements.

Default: generally specifies a baseline alignment, but this default may differ depending on
the browser.

Baseline and Bottom: aligns the text baseline to the bottom of the selected object.
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Absolute bottom: aligns the absolute bottom of the text, including descenders (as in the
letter g) with the bottom of the selected object.

Top: aligns the top of the tallest character in the text
line with the top of the selected object.

Text top: aligns the tallest character in the text line
with the top of the selected object.

Middle: aligns the text baseline with the middle of the
selected object.

Absolute middle: aligns the middle of the selected
object with the middle of the text.

Left: places the selected object on the left margin, wrapping text around it to the right. If
left-aligned text precedes the object on the line, it generally forces left-aligned objects to
wrap to a new line.

Right: places the object on the right margin, wrapping text around the object to the left. If
right-aligned text precedes the object on the line, it generally forces right-aligned objects to
wrap to a new line.

Resizing images:
Resizing resets the WIDTH and HEIGHT attributes of the element. The W and H fields in the
Property inspector display the current width and height of the element as you resize it. The
element's file size does not change.

Bitmap elements such as GIF, JPEG, and PNG images may become pixelated or distorted if you
reset their WIDTH and HEIGHT attributes. To maintain the same aspect ratio, hold down the
Shift key while you resize a bitmap. However, it is recommended that you visually resize these
elements in Dreamweaver only to determine the layout. Once you have determined the ideal
size for your image, edit the file in an image-editing application. Editing the image may also
reduce its file size and thus reduce download time.

To resize an image element:
•  Select the image in the Document window.

Resize handles appear at the bottom and right sides of the element and in the bottom
right corner. If resize handles don't appear, either click away from the element you want
to resize, and then re-select it or click <img> in the tag selector to select the element.

•  Resize the image, by doing one of the following:

o To adjust the width of the image, drag the selection handle on the right side.

o To adjust the height of the image, drag the bottom selection handle.
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o To adjust the width and the height of the image at the same time, drag the
corner selection handle.

o To preserve the image’s aspect ratio (its width-to-height ratio) as you adjust its
dimensions, press the Shift key as you drag the corner selection handle.

Images can be visually resized to a minimum of 8 by 8 pixels. To adjust the width and height of
an image to a smaller size (for example, 1 by 1 pixel), use the Property inspector to enter a
numeric value.

To return a resized image to its original dimensions, click the W and H labels in the
Property inspector.

Working with Tables

Tables are an extremely powerful Web design tool for laying out data and images on an HTML
page. Tables provide Web designers ways to add vertical and horizontal structure to a page.

Tables consist of three basic components:
•  rows (horizontal spacing)

•  columns (vertical spacing)

•  cells (the container created when a row and column intersect)

Use tables to lay out tabular data, to design columns on a page, or to lay out text and graphics
on a Web page. Once you create a table you can easily modify both the appearance and
structure of HTML tables. You can add content; add, delete, split, and merge rows and
columns; modify table, row, or cell properties to add color and alignment; and copy and paste
cells.

For more advanced layout design, you can insert a table within a table, adding even more
flexibility to your pages.

Using Dreamweaver, you can easily convert between a table layout and a layer layout. Both
tables and layers allow you to control the positioning of page elements, but layers aren't
supported in 4.0 and earlier browsers. If your design process requires rapid repositioning of
content, you can use layers to lay out a page and then convert the layers to a table for viewing
in older browsers.
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Inserting a table:
Use the Insert toolbar or the Insert menu to create a table

To insert a table:
•  Do one of the following:

o In the Document window, place the insertion point where you want the table to
appear, then click the Table button on the Common tab of the Insert toolbar.

o Choose Insert > Table.

o Drag the Table button from the Object panel to the desired insertion point on the
page. The Insert Table dialog box appears.

•  In the dialog box, accept the current values or type new values.

Note: The Insert Table dialog box retains the values of the most recent settings you
entered for a table.

o In the Rows field, specify the number of table rows.

o In the Columns field, specify the number of table columns.

o In the Cell Padding field, specify the number of pixels between the cell content
and the cell boundary (or wall).

o In the Cell Spacing field, specify the number of pixels between each table cell.

o In the Width field, specify the width of the table as a number of pixels or as a
percentage of the browser window.

o In the Border field, specify the pixel width of the table border. Enter 0 if you
don't want a border.

•  Click OK to create the table.

If you want to insert a table without having to first specify these options, turn off the “Show
Dialog When Inserting Objects” option in the General preferences.

Adding content to a table cell:
You can add text and images to table cells.

To Add Text to a Table:
•  Click in a cell in which you want to add text, and do one of the following:

o Type text into the table. Table cells automatically expand as you type.
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o Paste text copied from another document.

o Press Tab to move to the next cell or press Shift+Tab to move to the previous
cell. Pressing Tab in the last cell of a table automatically adds another row to the
table.

You can also use the arrow keys to move between cells.

To Add an Image to a Table:
•  Click in the cell in which you want to add an image.

•  Click the Image button in the Common panel of the Insert toolbar, or choose Insert >
Image.

•  In the Select Image Source dialog box, select an image file.

Selecting table elements:
With a single gesture you can select an entire table, row, or column, or a contiguous range of
cells within the table. Once the table or individual cells are selected, you can do the following:

•  Modify the appearance of selected cells or the text contained in them.

•  Copy and paste adjacent cells.

You can also select multiple nonadjacent cells in a table and modify the properties of those
cells. You cannot copy or paste nonadjacent cell selections.

To select the entire table:
•  Click anywhere on the top or bottom edge or click somewhere in the table then click the

<table> tag in the tag inspector. Selection handles appear around the table when it is
selected.

To select rows:
•  Position the insertion point at the left margin of a row.  When the black selection arrow

appears, click.

•  Click inside one of the cells in the row and then click the <tr> tag in the tag inspector.
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To select a column:
•  Position the insertion point at the top of a column. When the black selection arrow

appears, click.

To select a single cell:
•  Click inside the cell and then click the <td> tag in the tag inspector.

To select multiple adjacent cells:
•  Click in a cell and then drag down or across to select the last cell  you want to select.

To select multiple non-adjacent cells:
•  Press and hold the Control button (Windows) or Command button (Macintosh) and click

inside the cells of the table that you would like to select.

Setting table properties
The Property inspector displays table properties when a table is selected. You can also use the
Format Table command to quickly apply a preset design to a selected table.

To Specify Table Properties:
•  Select the table.

•  In the Property inspector, click the expander arrow in the lower right corner to see all
properties.
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To select table layout options:
In the Rows and Cols fields, specify the number of rows and columns in the table.

In the W and H fields, specify the width and height of the table as a number of pixels or as
a percentage of the browser window. You usually don't need to set the height of a table.

Use the Align field to specify how a table aligns with other elements in the same
paragraph, such as text or images. Left aligns the table to the left of other elements, right
aligns the table to the right of other elements, and Center centers the table. You can left-
align, right-align, or center the table relative to the other elements. You can also choose the
browser's default alignment.

Use the Clear Row Heights and Clear Column Widths buttons to delete all table row
height and column width values from the table.

Use the Convert Table Widths and Convert Table Heights to Pixels button to
convert the table width or height from a percentage of the browser window to its current
width or height in pixels.

Use the Convert Table Widths and Convert Table Heights to Percent button to
convert the current table width or height from pixels to a percentage of the browser
window.

To Set Cell Layout:
In the CellPad field, specify the number of pixels between the cell content and the cell
boundary (or wall).

In the CellSpace field, specify the number of pixels between each table cell.

When you don’t explicitly assign values for cell spacing and cell padding, most browsers
display the table as if cell padding were set to 1 and cell spacing were set to 2. To ensure
that browsers display the table with no padding or spacing, set Cell Padding and Cell
Spacing to 0.

To Set Table Borders:
In the Border field, specify the width of the table border in pixels. Most browsers display
the border as a three-dimensional line.
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If you are using the table for page layout, specify a border value of 0. To view cell and table
boundaries when the border is set to 0, choose View > Table Borders.

Use the Brdr color field to select a border color for the entire table.

Use the Bg color options to select the background image or background color for the table

Resizing tables and cells:
You can resize the entire table or individual rows and columns. When you resize the entire
table, all of the cells in the table change proportionally.

To Resize the Table:
•  Select the table.

•  Drag one of the selection handles to resize the table along that dimension. Dragging the
corner handle resizes both dimensions.

To change the size of a row or column:
•  To change row height, drag the bottom row border.

•  To change column width, drag the right column border.

Changing column widths
The Property inspector lets you specify the width of a column in three ways.

To set the column width:
•  Click in any of the columns' cells or select the column.

•  Choose Window > Properties to open the Property inspector.

•  In the W field, do one of the following:

o Enter a number to set the column width to the specified number of pixels.

o Enter a number followed by the percent symbol (%) to set the column width to a
percentage of the table width.

o Leave the field blank (the default) to let the browser and Dreamweaver
determine the proper width based on the contents of the cell and the widths of
the other columns. Generally, space is allocated based on the longest line or the
widest image. This is why one column sometimes becomes much larger than the
other columns in the table when you add content to it.

Clearing Column Widths and Row Heights
The simplest way to set column widths and row heights is to drag the borders of the table.
Dragging a column or row border automatically sets specific values for all of the columns or
rows, either in pixels or as percentages of the table's current dimensions, depending on how
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the table width is specified.

If you can't get the desired result by dragging table borders, you can clear the column widths
and start over.

To change widths and heights:
•  Select the table, choose Modify > Table, and choose Clear Cell Heights or Clear Cell

Widths.

•  Choose Window > HTML Styles and change the widths and heights directly in the HTML
Source inspector.

•  In the Property inspector, enter specific width and height values in the W and H boxes.

Nesting tables:
A nested table is a table within a table. You can configure a nested table as you would any
other table; however, its width is limited by the width of the cell in which it appears.

To nest a table within a table cell:
•  Click in the cell where you want to insert the second table and choose Insert > Table.

•  Specify the table properties in the Insert Table dialog box, and click OK.

Splitting and merging cells
Use the Property inspector or the commands in the Modify > Table submenu to split or merge
cells. You can merge any number of adjacent cells—as long as the entire selection is
rectangular—to produce a single cell that spans several columns or rows. You can split a cell
into any number of rows or columns, regardless of whether it was previously merged.
Dreamweaver automatically restructures the table (adds any necessary COLSPAN or ROWSPAN
attributes) to create the specified arrangement.
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In the following illustration, the cells in the middle of the first two rows have been merged so
that they span two rows.

To merge two or more cells in a table:
•  Select the cells you want to merge.

•  Choose Modify > Table >
Merge Cells, or click the Merge
Cell button in the Property
inspector.

The contents of the individual cells
are placed in the resulting merged
cell. The properties of the first cell
selected are applied to the
merged cell.

To split a merged cell:
•  Click in the cell or select a cell.

•  Choose Modify > Table > Split Cells, or click the Split Cell button in the Property
inspector.

•  In the Split Cell dialog box, choose whether to split the cell into rows or columns, and
then enter the number of rows or columns.

Copying and pasting cells
You can copy and paste multiple table cells at one time, preserving the cell's formatting, or you
can copy and paste only the contents of the cell.

Cells can be pasted at an insertion point or in place of a selection in an existing table. To paste
multiple table cells, the contents of the Clipboard must be compatible with the structure of the
table or the selection in the table in which the cells will be pasted.

To cut or copy cells in a table:
•  Select one or more cells in the table. To be cut or copied, the selected cells must form a

rectangle.



MACROMEDIA DREAMWEAVER MX 2004

26

•  Select Edit > Cut or Edit > Copy

To paste table cells:
•  Choose where to paste the cells.

o To paste cells before or above a particular cell, click in that cell.

o To create new table with the pasted cells, click wherever you want the table to
appear (as long you don't click inside another table).

•  Choose Edit > Paste

o If you are pasting entire rows or columns into an existing table, the rows or
columns are added to the table.

o If you are pasting an individual cell, the contents of the selected cell are
replaced, as long as the Clipboard contents are compatible with the selected cell.

o If you are pasting outside a table, the rows, columns, or cells are used to define
a new table.

To remove cell content but leave the cells intact:
•  Select one or more cells.

•  Choose Edit > Clear or press Delete.

Note: If you select all the cells in a row or column, the row or column, not just its contents, is
removed from the table.

To Copy and Paste the Contents of Cells:
•  Select the text and choose Edit > Copy Text Only. Only the text from the selected cells

is copied onto the Clipboard.

•  Click in a single cell or elsewhere in the Document window, and choose Edit > Paste as
Text.

You cannot paste the selection into a selection of multiple cells.
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About Locations and paths
Understanding the file path between the document you're linking from and the document you're
linking to is essential to creating links.

Each Web page has a unique address, called a Uniform Resource Locator (URL). However,
when you create a local link (a link from one document to another on the same site), you
generally don't specify the entire URL of the document you're linking to; instead, you specify a
relative path from the current document or from the site's root folder. Following are
descriptions of the three types of document paths.

Absolute paths
Absolute paths provide the complete URL of the linked document, including the protocol to use
(usually http:// for Web pages).

For example, http://www.macromedia.com/support/dreamweaver/contents.html is an absolute
path. You must use an absolute path to link to a document on another server. You can also use
absolute-path links to link pages in a site located on your local computer (such as for a Web
presentation). This approach is discouraged. However, as your links would break causing you
files not to open if you transfer the files to another location or change the file structure within
your site

Document-Relative Paths
Document-relative paths are the most appropriate paths to use for local links in most Web sites.
They're particularly useful when the current document and the linked-to document are in the
same folder and are likely to remain together. You can also use a document-relative path to link
to a document in another folder, by specifying the path through the folder hierarchy from the
current document to the linked document. When you specify a document-relative path, you
leave out the part of the absolute URL that is the same for both the current document and the
linked document, providing only the portion of the path that differs.

To link to another file in the same folder as the current document, simply provide the file name
to link to. To link to a file in a subfolder of the current document's folder, provide the name of
the subfolder, then a forward slash, and then the file name to link to. To link to a file in the
parent folder of the current document's folder, precede the file name with ../ (where .. means
"up one level in the folder hierarchy").

Root-Relative Paths
Root-relative paths provide the path from the site's root folder to a document.

Note: If you understand the strengths and limitations of root-relative paths, they can be useful,
but if you're not familiar with root-relative paths, document-relative paths are recommended.

A root-relative path begins with a leading forward slash, which stands for the site root folder.
For example, /support/tips.html is a root-relative path to a file (tips.html) in the support
subfolder of the site's root folder.

A root-relative path often provides the best way to specify links in a Web site in which you need
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to frequently move HTML files from one folder to another. When you move a document that
contains root-relative links, you don't need to change the links; for example, if your HTML files
use root-relative links for dependent files (such as images), then if you move an HTML file, its
dependent-file links are still valid. However, when you move or rename the documents linked to
with root-relative links, you do need to update those links, even if the documents' paths relative
to each other haven't changed. For example, if you move a folder, all root-relative links to files
within that folder must be updated. (If you move or rename files using the Site panel,
Dreamweaver helps you update all relevant links.)

Linking and Navigation

Once you've established a local site in which to store your Web site documents, and created
HTML pages, you'll want to create connections from your documents to other documents or file
types.

Using Dreamweaver, there are several ways to set up hypertext links to documents, images,
multimedia files, or downloadable programs. You can establish links to any text or image
anywhere within a document, including text or images located in a heading, list, table, layer, or
frame.

With Dreamweaver you can easily create the following types of links from text and graphic
images:

•  Internal links, linking documents in the same Web site

•  External links, linking to documents outside of a local Web site

•  E-mail links that open an e-mail form

•  Links to named anchors that allow the visitor to jump to a particular area on the same
Web page or to one on a different page

The HTML tag for creating a hypertext link is called an anchor tag. Dreamweaver creates an
anchor tag for objects, text, or images you create links from. For example, if in the Document
window you selected the text Home Page, then created a link to a file named home.htm, the
HTML source code for the link would look like this:

<a href="home.htm">Home Page</a>

Before creating links, be sure you understand how document-relative paths, root-relative paths,
and absolute paths work.

Linking to a document
There are several ways in Dreamweaver to create links.  To create links between documents

•  Select the text or image in the Document window that will be linked and

•  Do one of the following:
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o Click the folder icon to the right of the Link field to browse to and select a file.
The path to the linked document appears in the URL field. Use the Relative To
pop-up menu in the Select HTML File dialog box to select whether the path is
document relative or root relative, then click Select.

Note: When you change the path type in the Relative To field, Dreamweaver
sets the selection as the default path type for any future links until you change
the selection.

o In the Link field, type the path and file name of the document

To link to a document in your site, enter a document-relative or root-relative
path. To link to a document outside your site, enter an absolute path including
the type of protocol (such as http://).

•  Finally, select a location in which the document will open

To make the linked document appear somewhere other than in the current window or
frame, select an option from the Target pop-up menu on the Property inspector.

_blank loads the linked document in a new, unnamed browser window.

_parent loads the linked document in the parent frameset or window of the frame that
contains the link. If the frame containing the link is not nested, then the linked
document will load into the full browser window.

_self loads the linked document in the same frame or window as the link. This target is
implied, so you usually don't have to specify it.

_top loads the linked document in the full browser window, thereby removing all
frames.

Linking to a named anchor
Named anchors set position placemarkers in a document. Use named anchors to link to a
particular area in the current document or in a different document. Named anchors are often
used to jump to a specific topic or to the top of a document, quickly taking your visitor to the
selected position.

Creating a link to a named anchor is a two-step process. First, create a named anchor, and then
create a link to the named anchor.

Note: Names of anchors are case sensitive.

To Create a Named Anchor:
•  In the Document window, place the insertion point where you want the named anchor.
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•  Choose Insert > Named Anchor (or click the Anchor button on the Common tab of the
Insert toolbar)..

•  In the Anchor Name field of the Insert Named Anchor dialog box, type a name for the
anchor.

If the anchor marker doesn't appear at the insertion point location, choose View > Visual
Aids > Invisible Elements.

To Link to a Named Anchor:
•  In the Document window, select text or an image to create a link from.

•  In the Link field of the Property inspector, type a number sign (#) and the name of the
anchor. For example:

To link to an anchor named "top" on the current document, type #top

To link to an anchor named “top” on a different document in the same folder type
filename.html#top

To link to an anchor named “top” on a document outside your site type the absolute
path to the document and include the anchor.

Creating an email link
An e-mail link opens a new message window (using the mail program associated with the user's
browser) when clicked. In the e-mail message window, the To: field is automatically updated
with the address specified in the e-mail link.

To Create an E-Mail Link Using the Insert E-Mail Link Command:
•  In the Document window, position the insertion point where you want the e-mail link to

appear, or select the text you want to appear as the e-mail link.

•  Choose Insert > Email Link, or, in the Common panel of the Insert toolbar, select Email
Link

o In the Text field of the Insert E-Mail Link dialog box, type or edit the text to
appear in the document as an e-mail link.

•  In the E-Mail field, type the e-mail address mail should be addressed to.

•  Press OK.

To Create an E-Mail Link Using the Property Inspector:
•  Select text, an image or an image in the Document window.

•  In the Link field of the Property inspector, type mailto: followed by an e-mail address.
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Uploading Your Site to a Server

Dreamweaver helps you organize the files in your local and remote sites. It allows you to easily
duplicate the structure of your local site on a remote server, or to duplicate a remote Web site's
structure on your local system. The relative links that you create on your local site continue to
work after you transfer files to the remote site, because the structure of the two sites is
identical.

You create a local site in Dreamweaver by creating a local root folder for the site (or by making
an existing folder into the local root folder), using the New Site command. You then associate
your local site with a remote server using the Define Sites command. When you transfer files
between local and remote sites, Dreamweaver maintains parallel file and folder structures
between your local and remote sites. If needed folders do not yet exist in the site that the files
are being transferred to, Dreamweaver automatically creates those folders. You can also
synchronize the files between your local and remote sites; Dreamweaver copies files in both
directions as necessary, and optionally removes unwanted files as appropriate.

Associating a remote server with a local site
After you've created a local site, use the Define Sites command to add or change associated
remote server information.

•  Choose Site > Manage Sites

•  A dialog box appears listing currently defined sites; select an existing site and click Edit.
(If you have no currently defined sites, click New).

•  Click Next in the wizard until you reach the step that asks “ How do you connect to your
remote server?”

•  Choose one of the following Server Access options:

o Use None if you do not plan to upload your site to a server. Then click OK and
skip the rest of this procedure.

o Use Local/Network if your Web server is mounted as a network drive
(Windows) or as an AppleTalk or NFS server (Macintosh), or if you are running a
Web server on your local machine. Click the folder icon to browse to and select
the folder where your site files are stored on the server. If you want the Remote
pane of the Site window to update automatically as files are added and deleted,
select the Refresh Remote File List Automatically option; for increased speed
when copying files to the remote site, leave this option unselected. (To manually
refresh the Site window at any time, click the Site window's Refresh button.)
Click OK and skip the rest of this procedure.

Note: To manually refresh the Remote pane only, choose View > Refresh
Remote in the Site window (Windows) or Site > Site Files View > Refresh
Remote (Macintosh).
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•  Use FTP if you connect to your Web server using FTP.

Since this is the way we upload files to our server on campus, the following instructions
will cover FTP

Your FTP hostname is the full Internet name or IP address of a computer system.  For example
our server is 128.146.203.161 whereas my personal website is host109.ipowerweb.com.

The folder is where you specify the files should go on the server.

Since everyone’s situation is unique we will handle these on an individual basis.
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Moving files to and from the remote server
Once you’ve set up the remote server you are ready to move your files online.  Dreamweaver
uses the two terms that you must understanding when transferring files to and from the server.

Put means copying the files from the local machine to the remote server.

Get means copying the files from the remote server to the local machine.

When you are ready to Put your files on the
server, select the file or files you want to upload
in the Files panel and click the blue up arrow
(Put).

When you upload files to the server you will be
prompted by a message that asks about including
dependent files.  What Dreamweaver wants to
know is if you would like to also upload images or
other objects that appear on the page you are
uploading and document linked to that file. As a
rule, the only time you should click Yes is the first
time you upload your site.

When you need to Get a copy of a file to edit you
much first change the Local View to Remote View
using the pop-up menu on the right in the picture above.  Then all you need to do is select the
file or files you would like to download to your local machine an click the green down arrow
(Get).
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